<!DOCTYPE html>
<html lang="en">
  <head>
    <meta charset="utf-8">
    <meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no">


  <script src="https://use.typekit.net/ybp1qsc.js"></script>
  <script>try{Typekit.load({ async: true });}catch(e){}</script>
  
    <meta name="csrf-token" content="ChxKWiIjVxl/HBRoPRQ6Pg4fMmErNgAANjz3Nv0QODS/dXXX7xS/BA==">

      <meta name="twitter:card" content="summary">
      <meta name="twitter:site" content="@pff">
      <meta name="twitter:title" content="PFF 2018 NFL Draft Quotable – AFC East">
      <meta name="twitter:description" content="Senior Analyst Mike Renner breaks down each team in the AFC East&#39;s skill positions with added insight from team&#39;s post-draft press conferences.">
      <meta name="twitter:image" content="https://media.profootballfocus.com/2018/05/USATSI_10819312.jpg?w=1024&h=1024">

      <meta name="description" content="Senior Analyst Mike Renner breaks down each team in the AFC East&#39;s skill positions with added insight from team&#39;s post-draft press conferences.">

      <link rel="canonical" href="https://www.profootballfocus.com/news/pro-draft-quotes-afc-east">

    <title>PFF 2018 NFL Draft Quotable – AFC East | Fantasy Analysis | Pro Football Focus</title>

<link rel="shortcut icon" href="/images/favicons/favicon-a0ca957f5abf1ea5f339fd9a781838f1.ico?vsn=d">
<link rel="icon" type="image/png" href="/images/favicons/favicon-16x16-139fb798725dc4683861d459a6b7a7c6.png?vsn=d" sizes="16x16">
<link rel="icon" type="image/png" href="/images/favicons/favicon-32x32-8db0fb77899f8581831b5216ea3b776f.png?vsn=d" sizes="32x32">
<link rel="icon" type="image/png" href="/images/favicons/favicon-96x96-f8f6bc3812781769446b9626a892b1e1.png?vsn=d" sizes="96x96">
<link rel="manifest" href="/manifest.json">
<meta name="theme-color" content="#FFFFFF">
<link rel="apple-touch-icon-precomposed" href="/images/favicons/apple-icon-precomposed-867231551fa406ff08c80f2f6116f002.png?vsn=d">
<link rel="apple-touch-icon" sizes="57x57" href="/images/favicons/apple-icon-57x57-c62538cf57ba96cfa2d28855e7cbad2d.png?vsn=d">
<link rel="apple-touch-icon" sizes="114x114" href="/images/favicons/apple-icon-114x114-24930c0c551fe78234342367dfc64b59.png?vsn=d">
<link rel="apple-touch-icon" sizes="72x72" href="/images/favicons/apple-icon-72x72-933186069f5f87fab57abdd9ea23b15f.png?vsn=d">
<link rel="apple-touch-icon" sizes="144x144" href="/images/favicons/apple-icon-144x144-c5320e28e1a0b0305b587eaf44f9b670.png?vsn=d">
<link rel="apple-touch-icon" sizes="60x60" href="/images/favicons/apple-icon-60x60-746348e1902ef5faa2c4b275f2f22b92.png?vsn=d">
<link rel="apple-touch-icon" sizes="120x120" href="/images/favicons/apple-icon-120x120-ffd6f2ddc5124f382f9140b9707d1f13.png?vsn=d">
<link rel="apple-touch-icon" sizes="76x76" href="/images/favicons/apple-icon-76x76-2aa08ea3ffdd95e8df1b6a8e84b133bc.png?vsn=d">
<link rel="apple-touch-icon" sizes="152x152" href="/images/favicons/apple-icon-152x152-f04c03fe1fe3de263eabb9c53500fd63.png?vsn=d">
<link rel="apple-touch-icon" sizes="180x180" href="/images/favicons/apple-icon-180x180-cc981fb823a01aebc82551a3d76379cc.png?vsn=d">
<meta name="msapplication-TileColor" content="#FFFFFF">
<meta name="msapplication-TileImage" content="/images/favicons/ms-icon-144x144-c5320e28e1a0b0305b587eaf44f9b670.png?vsn=d">
    <link rel="stylesheet" href="/css/webui-44affcc16ddfbf1b990750c83fdef7dd.css?vsn=d">
  </head>
  <body class="updates-products">
<script>
  dataLayer = [{
    'userId': '',
    'loggedInStatus': 'false',
    'subscriptionType': '',
    'internalTraffic': 'No',
    'pageType': 'Article',
    'category': 'Fantasy',
    'section': 'news',
    'datePublished': '20180507',
    'author': 'Michael Renner',
    'contentType': 'Article'
  }];
</script>

<!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-MWLLR6"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-MWLLR6');</script>
<!-- End Google Tag Manager -->
    <div id="app">

  <div id="header" class="hidden-print">
    <div class="container">
      <div class="row">
        <nav class="navbar navbar-toggleable-md navbar-light">
          <button class="navbar-toggler navbar-toggler-left main-nav" type="button" data-toggle="modal" data-target="#mainNav">
            <span class="navbar-toggler-text">Menu</span>
          </button>
            <a class="navbar-toggler navbar-toggler-right sign-in-nav" href="/login">
              <span class="navbar-toggler-text">Sign In</span>
            </a>
          <a class="navbar-brand" href="/">
            <svg class="icon icon-pff-shorthand-white">
              <use xlink:href="/images/webui/symbol-defs.svg#icon-pff-shorthand-white"></use>
            </svg>
          </a>
          <div class="collapse navbar-collapse" id="mainNav">
            <div class="modal-wrapper">
              <button type="button" class="close hidden-lg-up" data-dismiss="modal" aria-label="Close">
                <span aria-hidden="true">×</span>
              </button>
              <a class="navbar-brand" href="#">
                <svg class="icon icon-pff-shorthand-white">
                  <use xlink:href="/images/webui/symbol-defs.svg#icon-pff-shorthand-white"></use>
                </svg>
              </a>
              <ul class="navbar-nav">
                <li class="nav-item">
                  <div class="form-inline closed">
                    <i id="btn-search" class="fa fa-search" aria-hidden="true"></i>
                    <input class="form-control" type="search" placeholder="search ..." id="searchBox">
                    <i class="fa fa-times-circle clear-search" aria-hidden="true"></i>
                  </div>
                </li>
                <!-- FYI if these change, need to also change the error/404 pages -->
                <li class="nav-item ">
<a class="nav-link" href="/nfl">NFL</a>                </li>
                <li class="nav-item ">
<a class="nav-link" href="/fantasy">Fantasy</a>                </li>
                <li class="nav-item ">
<a class="nav-link" href="/draft">NFL Draft</a>                </li>
                <li class="nav-item ">
                  <a class="nav-link" href="/nfl/teams">Teams</a>
                </li>
                <li class="nav-item ">
                  <a class="nav-link" href="/tools">Tools</a>
                </li>
                  <li class="nav-item hidden-md-down">
                    <a class="nav-link btn btn-primary" href="/login">Sign In</a>
                  </li>
              </ul>

                
                <div class="nav-pff-cta hidden-lg-up">
                  <div class="container">
<div class="edge cta">
  <img src="/images/webui/device-banner-phone-01@2x.png" alt="">
  <div class="cta-copy">
    <h2>PFF Edge</h2>
    <p>Full year access to Player Grades, PFF Fantasy, premium content, and special reports.</p>
    <a href="/amember/signup#edge-news">Subscribe</a> &middot; <a href="https://join.profootballfocus.com/edge/#news">Learn More</a>
    <em>$9.99/mo or $39.99/yr</em>
  </div>
</div>
                    <div class="elite cta">
  <img src="/images/webui/device-banner-phone-02@2x.png" alt="">
  <div class="cta-copy">
    <h2>PFF <span>Elite</span></h2>
    <p>The very best of PFF. Our full access pass elevates your football IQ to genius level.</p>
    <a href="/amember/signup#elite-news">Subscribe</a> &middot; <a href="https://join.profootballfocus.com/elite/#news">Learn More</a>
    <em>$34.99/mo or $199.99/yr</em>
  </div>
</div>

                  </div>
                </div>
            </div>
          </div>
        </nav>
      </div>
    </div>
    <!-- .container -->

    <div id="myAccountNav">
      <button type="button" class="close hidden-lg-up" data-dismiss="modal" aria-label="Close">
        <span aria-hidden="true">×</span>
      </button>
      <a class="navbar-brand" href="/">
        <svg class="icon icon-pff-shorthand-white">
          <use xlink:href="/images/webui/symbol-defs.svg#icon-pff-shorthand-white"></use>
        </svg>
      </a>
  <div class="component-member">
    <div class="container member">
      <div class="row">
        <div class="col league-container">
          <h4>My Fantasy Leagues</h4>
          
            <div class="mt-2 mb-2">
              <em>You currently have no fantasy leagues.</em>
            </div>
          <div class="d-flex flex-row justify-content-between mt-2">
            <a href="/fantasy/leagues/new" class="btn btn-primary">
              <i class="fa fa-plus" aria-hidden="true"></i> Create A League
            </a>
          </div>
        </div>
        <!--
        <div class="col team-container">
          <h4>My Teams</h4>
          <div class="team-thumbs">
            <div class="team-row">
              <a href="#">
                <div class="nfl-logo">
                  <svg class="icon icon-buffalo-bills">
                    <use xlink:href="/images/webui/symbol-defs.svg#icon-buffalo-bills"></use>
                  </svg>
                </div>
              </a>
              <a href="#">
                <div class="nfl-logo">
                  <svg class="icon icon-miami-dolphins">
                    <use xlink:href="/images/webui/symbol-defs.svg#icon-miami-dolphins"></use>
                  </svg>
                </div>
              </a>
              <a href="#">
                <div class="nfl-logo">
                  <svg class="icon icon-new-england-patriots">
                    <use xlink:href="/images/webui/symbol-defs.svg#icon-new-england-patriots"></use>
                  </svg>
                </div>
              </a>
              <a href="#">
                <div class="add-team"><i class="fa fa-plus" aria-hidden="true"></i></div>
              </a>
            </div>
          </div>
        </div>
        -->
        <div class="col info-container">
          <h4>My Info</h4>
          <ul>
            <li><a href="/amember/member">Subscriptions</a></li>
            <li><a href="/amember/profile">Profile</a></li>
            <li><a href="/amember/member/payment-history">Payment History</a></li>
            <li><a data-csrf="ChxKWiIjVxl/HBRoPRQ6Pg4fMmErNgAANjz3Nv0QODS/dXXX7xS/BA==" data-method="delete" data-to="/logout" href="#" rel="nofollow">Logout</a></li>
          </ul>
        </div>
      </div>
    </div>
  </div>
    </div>
    <!-- #myAccountNav -->

    <div id="dropdownMenu" class="dropdown-menu">
  <div class="component-member">
    <div class="container member">
      <div class="row">
        <div class="col league-container">
          <h4>My Fantasy Leagues</h4>
          
            <div class="mt-2 mb-2">
              <em>You currently have no fantasy leagues.</em>
            </div>
          <div class="d-flex flex-row justify-content-between mt-2">
            <a href="/fantasy/leagues/new" class="btn btn-primary">
              <i class="fa fa-plus" aria-hidden="true"></i> Create A League
            </a>
          </div>
        </div>
        <!--
        <div class="col team-container">
          <h4>My Teams</h4>
          <div class="team-thumbs">
            <div class="team-row">
              <a href="#">
                <div class="nfl-logo">
                  <svg class="icon icon-buffalo-bills">
                    <use xlink:href="/images/webui/symbol-defs.svg#icon-buffalo-bills"></use>
                  </svg>
                </div>
              </a>
              <a href="#">
                <div class="nfl-logo">
                  <svg class="icon icon-miami-dolphins">
                    <use xlink:href="/images/webui/symbol-defs.svg#icon-miami-dolphins"></use>
                  </svg>
                </div>
              </a>
              <a href="#">
                <div class="nfl-logo">
                  <svg class="icon icon-new-england-patriots">
                    <use xlink:href="/images/webui/symbol-defs.svg#icon-new-england-patriots"></use>
                  </svg>
                </div>
              </a>
              <a href="#">
                <div class="add-team"><i class="fa fa-plus" aria-hidden="true"></i></div>
              </a>
            </div>
          </div>
        </div>
        -->
        <div class="col info-container">
          <h4>My Info</h4>
          <ul>
            <li><a href="/amember/member">Subscriptions</a></li>
            <li><a href="/amember/profile">Profile</a></li>
            <li><a href="/amember/member/payment-history">Payment History</a></li>
            <li><a data-csrf="ChxKWiIjVxl/HBRoPRQ6Pg4fMmErNgAANjz3Nv0QODS/dXXX7xS/BA==" data-method="delete" data-to="/logout" href="#" rel="nofollow">Logout</a></li>
          </ul>
        </div>
      </div>
    </div>
  </div>
    </div>
    <!-- #dropdownMenu -->
  </div>

    
      <div class="pff-cta-top">
<div class="container">
  <div class="row">
    <div class="col edge cta">
      <div class="row">
        <div class="col">
          <img src="/images/webui/banner-edge-desktop@2x.png" alt="">
        </div>
        <div class="col">
          <h2>PFF Edge</h2>
          <p>Full year access to Player Grades, PFF Fantasy, premium content, and special reports.</p>
          <div class="buttons">
            <a href="/amember/signup#edge-news-1" class="btn btn-primary btn-sm btn-block">
              Get PFF Edge
            </a>
            <a href="https://join.profootballfocus.com/edge/#news" class="btn btn-secondary btn-sm btn-block">
              Learn More
            </a>
          </div>
          <em>$9.99/mo or $39.99/yr</em>
        </div>
      </div>
    </div>
    <div class="col elite cta">
      <div class="row">
        <div class="col">
          <img src="/images/webui/banner-elite-desktop@2x.png" alt="">
        </div>
        <div class="col">
          <h2>PFF <span>Elite</span></h2>
          <p>The very best of PFF. Our full access pass elevates your football IQ to genius level. &nbsp;&nbsp;&nbsp;</p>
          <div class="buttons">
            <a href="/amember/signup#elite-news-1" class="btn btn-elite btn-sm btn-block">
              Get PFF Elite
            </a>
            <a href="https://join.profootballfocus.com/elite/#news" class="btn btn-secondary btn-sm btn-block">
              Learn More
            </a>
          </div>
          <em>$34.99/mo or $199.99/yr</em>
        </div>
      </div>
    </div>
  </div>
</div>
      </div>
  
      
  <div class="sub-nav-news">
    <div class="wrapper">
      <div class="row">

        <div class="sub-nav">
          <div class="page-info-lite ">
            <div class="container">
              <div class="row">
                <div class="col">
                  <h1>Fantasy Analysis</h1>
                </div>
              </div>
            </div>
          </div>
  <div class="page-info-lite-desc container">
    <div class="row">
      <div class="col">
        <p>PFF experts use our exclusive player data and signature stats to project player performances for fantasy and DFS games.</p>
      </div>
    </div>
  </div>          <hr/>
  <div class="sub-nav-collapsible">
    <nav class="nav-collapsible">
      <input type="checkbox" id="more" aria-hidden="true" tabindex="-1" class="toggle"/>
      <div class="nav-collapsible-inner">
        <div class="nav-collapsible-logo">
          <a href="/news" class="nav-collapsible-link ">Latest</a>
        </div>
        <ul class="nav-collapsible-list">
            <li class="nav-collapsible-item">
              <a href="/news/category/news" class="nav-collapsible-link ">Team & Player News</a>
            </li>
            <li class="nav-collapsible-item">
              <a href="/news/category/nfl" class="nav-collapsible-link ">NFL</a>
            </li>
            <li class="nav-collapsible-item">
              <a href="/news/category/fantasy" class="nav-collapsible-link current">Fantasy</a>
            </li>
            <li class="nav-collapsible-item">
              <a href="/news/category/draft" class="nav-collapsible-link ">Draft</a>
            </li>
            <li class="nav-collapsible-item">
              <a href="/news/category/dfs" class="nav-collapsible-link ">DFS</a>
            </li>
          <li class="nav-collapsible-item">
            <a href="/podcasts" class="nav-collapsible-link">Podcasts</a>
          </li>
        </ul>
        <div class="nav-collapsible-toggle">
          <label for="more" aria-hidden="true" class="nav-collapsible-link">More</label>
        </div>
      </div>
    </nav>
  </div>        </div>

        <div class="col article">
          <div class="news-article">

            <article>
              <h2>PFF 2018 NFL Draft Quotable – AFC East</h2>
              <div class="news-article-info">
                By Michael Renner &bullet;
                
May 7, 2018              </div>

              <picture>
                <source media="(max-width: 575px)" srcset="https://media.profootballfocus.com/2018/05/USATSI_10819312.jpg?w=576&amp;h=720">
                <source media="(min-width: 576px) and (max-width: 991px)" srcset="https://media.profootballfocus.com/2018/05/USATSI_10819312.jpg?w=916&amp;h=720">
                <img src="https://media.profootballfocus.com/2018/05/USATSI_10819312.jpg?w=916&amp;h=720" alt="">
              </picture>
              <em class="caption">May 4, 2018; Florham Park, NJ, USA;  New York Jets quarterback Sam Darnold (14) throws the ball during New York Jets rookie mini camp at Atlantic Health Training Center. Mandatory Credit: Noah K. Murray-USA TODAY Sports</em>

<p>One of the best parts about working at PFF is being surrounded by talented, hard-working individuals. My fantasy colleague Scott Barrett being one of my favorites among them. Luckily for me, and for you, Scott has no life. He spent his post-draft weekend pouring over every franchise&#8217;s press conferences to glean whatever bit of insight the coaches and executives unwittingly let slip.</p>
<p>Here are some of the most insightful quotes on the offensive skill position players drafted this past weekend with the added context of PFF’s data.</p>
<p><img class="alignnone wp-image-214755" src="https://media.profootballfocus.com/2017/07/BUF-Bills-Header.png" alt="" width="650" srcset="https://media.profootballfocus.com/2017/07/BUF-Bills-Header.png 650w, https://media.profootballfocus.com/2017/07/BUF-Bills-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /></p>
<h3><a href="https://www.profootballfocus.com/nfl/teams/buffalo-bills/4">Pick No. 7</a> – <a href="https://www.profootballfocus.com/nfl/players/josh-allen/46601">Josh Allen</a>, QB, Wyoming</h3>
<p><strong>GM <a href="http://www.buffalobills.com/video/videos/McDermott-You-Look-for-Guys-Who-Can-Make-Plays/4d76837b-ba3e-491a-bec9-0f96507f5869" target="_blank" rel="noopener noreferrer">Brandon Beane</a></strong>: “Big. Big guy. He’s an athlete&#8230; I don&#8217;t want to rank where we had them (the quarterbacks), but we thought an awful lot of Josh. (Also mentioned other teams’ unwillingness to trade down at various spots.”</p>
<p><strong>HC Sean McDermott</strong>: &#8220;Let&#8217;s not lose sight of the guys already on the roster and the work that they&#8217;re putting in.&#8221;</p>
<p><strong>Beane (<a href="https://twitter.com/MatthewFairburn/status/990376620291756033" target="_blank" rel="noopener noreferrer">later</a>)</strong>: &#8220;[We&#8217;ll] give Allen a chance to win the job, but [we] don&#8217;t plan to rush him in any way.&#8221;</p>
<h4><strong>PFF’s Take:</strong></h4>
<p>Not rushing Allen would likely be for the best. He was the sixth-ranked quarterback on our final draft board and only posted a 74.1 overall grade last year. From the 2018 NFL Draft Guide: “H<em>e must get better at handling the easy stuff, from working in the quick game to throwing with touch and accuracy to all levels of the field.</em>”</p>
<p><img class="alignnone wp-image-214771" src="https://media.profootballfocus.com/2017/07/MIA-Dolphins-Header.png" alt="" width="650" srcset="https://media.profootballfocus.com/2017/07/MIA-Dolphins-Header.png 650w, https://media.profootballfocus.com/2017/07/MIA-Dolphins-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /></p>
<h3><a href="https://www.profootballfocus.com/nfl/teams/miami-dolphins/17">Pick No. 42</a> – <a href="https://www.profootballfocus.com/nfl/players/mike-gesicki/47153">Mike Gesicki</a>, TE, Penn State</h3>
<p><strong>GM <a href="http://www.miamiherald.com/sports/nfl/miami-dolphins/article210027234.html" target="_blank" rel="noopener noreferrer">Chris Grier</a></strong>: &#8220;Everyone talks about him not being a great blocker. Well there&#8217;s a lot of really good tight ends that are pass-catchers that aren&#8217;t great blockers. It&#8217;s about giving effort and stuff. The one thing we really loved is the skillset offensively… Red zone matchups. He&#8217;s big and long and fast. High points the ball well&#8230; Loved the film. You see his play speed on film. The jump, on film. It&#8217;s a matchup league. He&#8217;s got a unique skillset.”</p>
<h4><strong>PFF’s Take:</strong></h4>
<p>Grier was very correct about Gesicki’s run-blocking where he never earned a grade higher than 50.5. That still didn’t stop us as well from putting him as the No. 2 tight end on our big board. His 75.0 percent catch rate in contested situations was the best among tight ends in the draft.</p>
<p><img class="alignnone wp-image-214776" src="https://media.profootballfocus.com/2017/07/NYJ-Jets-Header.png" alt="" width="650" srcset="https://media.profootballfocus.com/2017/07/NYJ-Jets-Header.png 650w, https://media.profootballfocus.com/2017/07/NYJ-Jets-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /></p>
<h3><a href="https://www.profootballfocus.com/nfl/teams/new-york-jets/22">Pick No. 3</a> – <a href="https://www.profootballfocus.com/nfl/players/sam-darnold/29048">Sam Darnold</a>, QB, USC</h3>
<p><a href="https://www.profootballfocus.com/news/draft-jets-select-sam-darnold-third-overall"><img class="alignnone wp-image-247548" src="https://media.profootballfocus.com/2018/04/IMG_26042018_182805_0.png" alt="" width="800" srcset="https://media.profootballfocus.com/2018/04/IMG_26042018_182805_0.png 800w, https://media.profootballfocus.com/2018/04/IMG_26042018_182805_0-300x169.png 300w, https://media.profootballfocus.com/2018/04/IMG_26042018_182805_0-768x432.png 768w" sizes="(max-width: 706px) 89vw, (max-width: 767px) 82vw, 740px" /></a></p>
<p><strong>HC <a href="http://www.newyorkjets.com/videos/videos/Jets-Draft-Press-Conference---Round-1-426/00dd2037-c50c-4848-b458-46518d89a152" target="_blank" rel="noopener noreferrer">Todd Bowles</a></strong>: (On Year 1 expectations) &#8220;There&#8217;s no timetable. We&#8217;ve gotta see how fast he learns and how fast he can grasp everything and then get some experience. We&#8217;re not gonna throw him in there, but at the same time we&#8217;re not gonna hold him back either.&#8221;</p>
<h4><strong>PFF’s Take:</strong></h4>
<p>Josh McCown posted a 77.1 overall grade last season while Teddy Bridgewater had an 82.1 grade during his last healthy season. They have other options if they want to ‘redshirt’ Darnold.</p>
<p><img class="alignnone wp-image-214773" src="https://media.profootballfocus.com/2017/07/NE-Patriots-Header.png" alt="" width="650" srcset="https://media.profootballfocus.com/2017/07/NE-Patriots-Header.png 650w, https://media.profootballfocus.com/2017/07/NE-Patriots-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /></p>
<h3><a href="https://www.profootballfocus.com/nfl/teams/new-england-patriots/19">Pick No. 31</a> – <a href="https://www.profootballfocus.com/nfl/players/sony-michel/27589">Sony Michel</a>, RB, Georgia</h3>
<p><a href="https://www.profootballfocus.com/news/draft-patriots-select-sony-michel-31st-overall"><img class="alignnone wp-image-247672" src="https://media.profootballfocus.com/2018/04/IMG_26042018_213152_0.png" alt="" width="800" srcset="https://media.profootballfocus.com/2018/04/IMG_26042018_213152_0.png 800w, https://media.profootballfocus.com/2018/04/IMG_26042018_213152_0-300x169.png 300w, https://media.profootballfocus.com/2018/04/IMG_26042018_213152_0-768x432.png 768w" sizes="(max-width: 706px) 89vw, (max-width: 767px) 82vw, 740px" /></a></p>
<p><strong>Director of Player Personnel <a href="http://www.patriots.com/video/2018/04/27/nick-caserio-426-both-players-come-great-program" target="_blank" rel="noopener noreferrer">Nick Caserio</a></strong>: &#8220;Athletic player. Got a lot of carries. Sony is productive in the passing game.&#8221;</p>
<p><strong>Caserio</strong>: (When asked why they drafted a running back so highly, when they typically wait on the position in the draft.) “We think he&#8217;s a good football player… [But] everyone gets the same opportunity when they get here, regardless of where they&#8217;re picked&#8230; We draft for value, not need.”</p>
<p><strong>Caserio</strong>: “Essentially you&#8217;re talking about developmental players, [when discussing rookies]. It doesn&#8217;t really matter where you&#8217;re picked. These players all got a long way to go. A lot of work to do. They&#8217;re behind our players. They&#8217;re behind [on the playbook].&#8221;</p>
<h4><strong>PFF’s Take:</strong></h4>
<p>Not much insight here from Caserio, but the ‘productive in the passing game’ claim is eyebrow-raising. Michel had 63 catches for 578 yards in four seasons at Georgia including only eight this past season. That’s not necessarily indicative of skill level – and his 31 broken tackles on those catches in impressive – but it’s hard to call that productive.</p>


            </article>

            <div class="social">
              <span class="social-copy">What do you think? Start a conversation…</span>
              <div class="social-icons">
                <a href="http://www.twitter.com/share?url=https://www.profootballfocus.com/news/pro-draft-quotes-afc-east" class="fa fa-twitter share-icon" target="_blank"></a>
                <a href="https://www.facebook.com/sharer/sharer.php?u=https://www.profootballfocus.com/news/pro-draft-quotes-afc-east" class="fa fa-facebook share-icon"></a>
                <a href="whatsapp://send?text=https://www.profootballfocus.com/news/pro-draft-quotes-afc-east" class="fa fa-whatsapp share-icon" data-action="share/whatsapp/share"></a>
              </div>
            </div>

              <div class="pff-cta-article p-3">
                <h4>PFF Edge & <span>Elite</span></h4>
<a class="col-md-6 btn btn-secondary" href="https://www.profootballfocus.com/features-and-faq/?camp=ftrfeats">Learn More &amp; Compare</a>              </div>
          </div>
        </div>

      </div>
    </div>
  </div>
      <div id="footer" class="hidden-print">
    <div class="container">
      <div class="row">
        <div class="col footer-menu">
          <h4 class="mb-4"><a href="/newsletter?camp=emfooter">Get PFF Updates</a></h4>
          <h4>Customer Service</h4>
          <ul>
            <li>
              <a href="https://pff.desk.com/">FAQS</a>
            </li>
            <li>
              <a href="https://pff.desk.com/customer/portal/emails/new">Contact Us</a>
            </li>
          </ul>
        </div>
        <div class="col footer-menu">
          <h4>About Us</h4>
          <ul>
            <li>
              <a href="/jobs">Jobs</a>
            </li>
            <li>
              <a href="/media">Media &amp; Partnerships</a>
            </li>
            <li>
              <a href="/pff-offers">Special Offers</a>
            </li>
          </ul>
        </div>
        <div class="col footer-content">
          <div class="icons-social">
            <a href="/pff-rss" class="rss"><span class="fa fa-rss"></span></a>
            <a href="/newsletter" class="email"><span class="fa fa-envelope"></span></a>
            <a href="https://twitter.com/pff" class="twitter"><span class="fa fa-twitter"></span></a>
            <a href="https://www.facebook.com/ProFootballFocus/" class="facebook"><span class="fa fa-facebook">&nbsp;</span></a>
            <a href="/podcasts" class="podcasts"><span class="fa fa-headphones">&nbsp;</span></a>
          </div>
          <div class="container-footer-links">
            <img src="/images/webui/pff-shorthand-white.svg" class="logo">
            <div class="footer-links">
              <a href="/sitemap">Sitemap</a>
              <i class="fa fa-circle" aria-hidden="true"></i>
              <a href="/privacy">Privacy Policy</a>
              <i class="fa fa-circle" aria-hidden="true"></i>
              <a href="/terms">Terms of Use</a>
            </div>
            <span>&copy; 2017 ProFootballFocus.com All rights reserved.</span>
          </div>
        </div>
      </div>
    </div>
  </div>

    </div>
    <script src="/js/webui-98bf7a498f72637fc276fd4d97874b5a.js?vsn=d"></script>
  </body>
</html>
