<!DOCTYPE html>
<html lang="en">
  <head>
<meta charset="utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no">


  <script src="https://use.typekit.net/ybp1qsc.js"></script>
  <script>try{Typekit.load({ async: true });}catch(e){}</script>
  
<meta name="csrf-token" content="MAYya1QdKyhlS2pGExwLOxkpDWQJJgAAE7Y92hBqUy87RWdhHo84KA==">
<meta name="google-site-verification" content="m2N80aEy8ONIhYvVOHT-XogcBBskiZd84_MBObKLOqo" />

  <meta name="twitter:card" content="summary">
  <meta name="twitter:site" content="@pff">
  <meta name="twitter:title" content="Under-the-radar rookies to watch – AFC East">
  <meta name="twitter:description" content="As NFL training camps heat up across the country, PFF is keeping an eye on some intriguing, under-the-radar rookies looking to earn meaningful snaps throughout the season">
  <meta name="twitter:image" content="https://media.profootballfocus.com/2018/08/Edmunds.jpg?w=1024&h=1024">

  <meta name="description" content="As NFL training camps heat up across the country, PFF is keeping an eye on some intriguing, under-the-radar rookies looking to earn meaningful snaps throughout the season">

  <link rel="canonical" href="https://www.profootballfocus.com/news/pro-under-the-radar-rookies-to-watch-afc-east">

<title>Under-the-radar rookies to watch – AFC East | NFL Analysis | Pro Football Focus</title>

<link rel="shortcut icon" href="/images/favicons/favicon-a0ca957f5abf1ea5f339fd9a781838f1.ico?vsn=d">
<link rel="icon" type="image/png" href="/images/favicons/favicon-16x16-139fb798725dc4683861d459a6b7a7c6.png?vsn=d" sizes="16x16">
<link rel="icon" type="image/png" href="/images/favicons/favicon-32x32-8db0fb77899f8581831b5216ea3b776f.png?vsn=d" sizes="32x32">
<link rel="icon" type="image/png" href="/images/favicons/favicon-96x96-f8f6bc3812781769446b9626a892b1e1.png?vsn=d" sizes="96x96">
<link rel="manifest" href="/manifest.json">
<meta name="theme-color" content="#FFFFFF">
<link rel="apple-touch-icon-precomposed" href="/images/favicons/apple-icon-precomposed-867231551fa406ff08c80f2f6116f002.png?vsn=d">
<link rel="apple-touch-icon" sizes="57x57" href="/images/favicons/apple-icon-57x57-c62538cf57ba96cfa2d28855e7cbad2d.png?vsn=d">
<link rel="apple-touch-icon" sizes="114x114" href="/images/favicons/apple-icon-114x114-24930c0c551fe78234342367dfc64b59.png?vsn=d">
<link rel="apple-touch-icon" sizes="72x72" href="/images/favicons/apple-icon-72x72-933186069f5f87fab57abdd9ea23b15f.png?vsn=d">
<link rel="apple-touch-icon" sizes="144x144" href="/images/favicons/apple-icon-144x144-c5320e28e1a0b0305b587eaf44f9b670.png?vsn=d">
<link rel="apple-touch-icon" sizes="60x60" href="/images/favicons/apple-icon-60x60-746348e1902ef5faa2c4b275f2f22b92.png?vsn=d">
<link rel="apple-touch-icon" sizes="120x120" href="/images/favicons/apple-icon-120x120-ffd6f2ddc5124f382f9140b9707d1f13.png?vsn=d">
<link rel="apple-touch-icon" sizes="76x76" href="/images/favicons/apple-icon-76x76-2aa08ea3ffdd95e8df1b6a8e84b133bc.png?vsn=d">
<link rel="apple-touch-icon" sizes="152x152" href="/images/favicons/apple-icon-152x152-f04c03fe1fe3de263eabb9c53500fd63.png?vsn=d">
<link rel="apple-touch-icon" sizes="180x180" href="/images/favicons/apple-icon-180x180-cc981fb823a01aebc82551a3d76379cc.png?vsn=d">
<meta name="msapplication-TileColor" content="#FFFFFF">
<meta name="msapplication-TileImage" content="/images/favicons/ms-icon-144x144-c5320e28e1a0b0305b587eaf44f9b670.png?vsn=d">
    <link rel="stylesheet" href="/css/webui-0c645c0fa0338a29338307e7584c1957.css?vsn=d">
  </head>
  <body class="updates-products">
<script>
  dataLayer = [{
    'userId': '',
    'loggedInStatus': 'false',
    'subscriptionType': '',
    'internalTraffic': 'No',
    'pageType': 'Article',
    'category': 'NFL',
    'section': 'news',
    'datePublished': '20180809',
    'author': 'Mike Johnson',
    'contentType': 'Article'
  }];
</script>

<!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-MWLLR6"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-MWLLR6');</script>
<!-- End Google Tag Manager -->
    <div id="app">
  <div id="header" class="hidden-print">
    <div class="container">
      <div class="row">
        <nav class="navbar navbar-toggleable-md navbar-light">
          <button class="navbar-toggler navbar-toggler-left main-nav" type="button" data-toggle="modal" data-target="#mainNav">
            <span class="navbar-toggler-text">Menu</span>
          </button>
            <a class="navbar-toggler navbar-toggler-right sign-in-nav" href="/login">
              <span class="navbar-toggler-text">Sign In</span>
            </a>
          <a class="navbar-brand" href="/">
            <svg class="icon icon-pff-shorthand-white">
              <use xlink:href="/images/webui/symbol-defs.svg#icon-pff-shorthand-white"></use>
            </svg>
          </a>
          <div class="collapse navbar-collapse" id="mainNav">
            <div class="modal-wrapper">
              <button type="button" class="close hidden-lg-up" data-dismiss="modal" aria-label="Close">
                <span aria-hidden="true">×</span>
              </button>
              <a class="navbar-brand" href="#">
                <svg class="icon icon-pff-shorthand-white">
                  <use xlink:href="/images/webui/symbol-defs.svg#icon-pff-shorthand-white"></use>
                </svg>
              </a>
              <div class="l-main-nav">
                <div class="l-main-nav__search">
                  <div class="form-search form-inline closed">
                    <i id="btn-search" class="fa fa-search" aria-hidden="true"></i>
                    <input class="form-control" type="search" placeholder="search ..." id="searchBox">
                    <i class="fa fa-times-circle clear-search" aria-hidden="true"></i>
                  </div>
                </div>
                <div class="l-main-nav__links">

                  <nav class="main-nav">
                    <!-- FYI if these change, need to also change the error/404 pages -->
<a class="main-nav__link main-nav__link--nfl" href="/nfl">                      <span class="main-nav__link-title">NFL</span>
                      <span class="main-nav__link-description">
                        NFL Analysis, Grades & Stats
                      </span>
</a>                    <a href="https://premium.profootballfocus.com/nfl/teams" class="main-nav__link main-nav__link--premium-stats">
                      <span class="main-nav__link-title">
                        Premium Stats 2.0
                        <span class="new-badge new-badge--post">New</span>
                      </span>
                      <span class="main-nav__link-description">
                        Advanced Player & Team Performance Stats
                      </span>
                    </a>
                    <a href="http://join.profootballfocus.com/elite/" class="main-nav__link">
                      <span class="main-nav__link-title">
                        Greenline
                        <span class="new-badge new-badge--post">Coming Soon</span>
                      </span>
                      <span class="main-nav__link-description">
                        Spread, Moneyline and Over/Under Picks
                      </span>
                    </a>
<a class="main-nav__link main-nav__link--fantasy" href="/fantasy">                      <span class="main-nav__link-title">Fantasy</span>
                      <span class="main-nav__link-description">
                        Expert Rankings, Projections & More
                      </span>
</a>                    <a class="main-nav__link main-nav__link--draft" href="/draft">
                    <span class="main-nav__link-title">Draft</span>
                    <span class="main-nav__link-description">
                      NFL Draft Rankings & Scouting Reports
                    </span>
</a>                    <a class="main-nav__link main-nav__link--tools" href="/tools">
                      <span class="main-nav__link-title">Tools</span>
                      <span class="main-nav__link-description">Access Everything with Your PFF Subscription</span>
                    </a>
                  </nav>
                </div>

                <div class="l-main-nav__account">
                  <div class="my-account-login hidden-md-down">
                    <a class="btn btn-primary" href="/login">Sign In</a>
                  </div>
                </div>
              </div>
            </div>
          </div>
        </nav>
      </div>
    </div>
    <!-- .container -->

    <div id="myAccountNav">
      <button type="button" class="close hidden-lg-up" data-dismiss="modal" aria-label="Close">
        <span aria-hidden="true">×</span>
      </button>
      <a class="navbar-brand" href="/">
        <svg class="icon icon-pff-shorthand-white">
          <use xlink:href="/images/webui/symbol-defs.svg#icon-pff-shorthand-white"></use>
        </svg>
      </a>
  <div class="component-member">
    <div class="container member">
      <div class="row">
        <div class="col league-container">
          <h4>My Fantasy Leagues</h4>
          
            <div class="mt-2 mb-2">
              <em>You currently have no fantasy leagues.</em>
            </div>
          <div class="d-flex flex-row justify-content-between mt-2">
            <a href="/fantasy/leagues/new" class="btn btn-primary">
              <i class="fa fa-plus" aria-hidden="true"></i> Create A League
            </a>
          </div>
        </div>
        <!--
        <div class="col team-container">
          <h4>My Teams</h4>
          <div class="team-thumbs">
            <div class="team-row">
              <a href="#">
                <div class="nfl-logo">
                  <svg class="icon icon-buffalo-bills">
                    <use xlink:href="/images/webui/symbol-defs.svg#icon-buffalo-bills"></use>
                  </svg>
                </div>
              </a>
              <a href="#">
                <div class="nfl-logo">
                  <svg class="icon icon-miami-dolphins">
                    <use xlink:href="/images/webui/symbol-defs.svg#icon-miami-dolphins"></use>
                  </svg>
                </div>
              </a>
              <a href="#">
                <div class="nfl-logo">
                  <svg class="icon icon-new-england-patriots">
                    <use xlink:href="/images/webui/symbol-defs.svg#icon-new-england-patriots"></use>
                  </svg>
                </div>
              </a>
              <a href="#">
                <div class="add-team"><i class="fa fa-plus" aria-hidden="true"></i></div>
              </a>
            </div>
          </div>
        </div>
        -->
        <div class="col info-container">
          <h4>My Info</h4>
          <ul>
            <li><a href="/amember/member">Subscriptions</a></li>
            <li><a href="/amember/profile">Profile</a></li>
            <li><a href="/amember/member/payment-history">Payment History</a></li>
            <li><a data-csrf="MAYya1QdKyhlS2pGExwLOxkpDWQJJgAAE7Y92hBqUy87RWdhHo84KA==" data-method="delete" data-to="/logout" href="/logout" rel="nofollow">Logout</a></li>
          </ul>
        </div>
      </div>
    </div>
  </div>
    </div>
    <!-- #myAccountNav -->

    <div id="dropdownMenu" class="dropdown-menu">
  <div class="component-member">
    <div class="container member">
      <div class="row">
        <div class="col league-container">
          <h4>My Fantasy Leagues</h4>
          
            <div class="mt-2 mb-2">
              <em>You currently have no fantasy leagues.</em>
            </div>
          <div class="d-flex flex-row justify-content-between mt-2">
            <a href="/fantasy/leagues/new" class="btn btn-primary">
              <i class="fa fa-plus" aria-hidden="true"></i> Create A League
            </a>
          </div>
        </div>
        <!--
        <div class="col team-container">
          <h4>My Teams</h4>
          <div class="team-thumbs">
            <div class="team-row">
              <a href="#">
                <div class="nfl-logo">
                  <svg class="icon icon-buffalo-bills">
                    <use xlink:href="/images/webui/symbol-defs.svg#icon-buffalo-bills"></use>
                  </svg>
                </div>
              </a>
              <a href="#">
                <div class="nfl-logo">
                  <svg class="icon icon-miami-dolphins">
                    <use xlink:href="/images/webui/symbol-defs.svg#icon-miami-dolphins"></use>
                  </svg>
                </div>
              </a>
              <a href="#">
                <div class="nfl-logo">
                  <svg class="icon icon-new-england-patriots">
                    <use xlink:href="/images/webui/symbol-defs.svg#icon-new-england-patriots"></use>
                  </svg>
                </div>
              </a>
              <a href="#">
                <div class="add-team"><i class="fa fa-plus" aria-hidden="true"></i></div>
              </a>
            </div>
          </div>
        </div>
        -->
        <div class="col info-container">
          <h4>My Info</h4>
          <ul>
            <li><a href="/amember/member">Subscriptions</a></li>
            <li><a href="/amember/profile">Profile</a></li>
            <li><a href="/amember/member/payment-history">Payment History</a></li>
            <li><a data-csrf="MAYya1QdKyhlS2pGExwLOxkpDWQJJgAAE7Y92hBqUy87RWdhHo84KA==" data-method="delete" data-to="/logout" href="/logout" rel="nofollow">Logout</a></li>
          </ul>
        </div>
      </div>
    </div>
  </div>
    </div>
    <!-- #dropdownMenu -->
  </div>

    
      <div class="pff-cta-top">
<div class="product-callouts">
  <div class="product-callouts__inner">
    <div class="product-callouts__phone">
      <img src="/images/webui/banner-edge-desktop@3x.png" alt="">
    </div>
    <div class="product-callouts__edge">
      <div class="product-callout-box">
        <div class="product-callout product-callout--inverse">
          <h2 class="product-callout__title">PFF Edge</h2>
          <p><em>Includes:</em></p>
          <ul class="product-feature-list product-feature-list--inverse">
            <li>PFF Player Grades</li>
            <li>Fantasy Draft Tools, Rankings & More</li>
            <li>
              <span class="new-badge new-badge--pre">New</span>
              2018 Fantasy Playbook
            </li>
            <li>
              <span class="new-badge new-badge--pre">New</span>
              2018 QB Annual
            </li>
          </ul>
          <div class="product-callout__buttons">
            <a href="/amember/signup#edge-news-1" class="btn btn-primary">
              Get PFF Edge
            </a>
            <a href="https://join.profootballfocus.com/edge/#news" class="btn btn-secondary">
              Learn More
            </a>
          </div>
          <em>$9.99/mo or $39.99/yr</em>
        </div>
      </div>
    </div>
    <div class="product-callouts__elite">
      <div class="product-callout-box product-callout-box--emphasized">
        <div class="product-callout">
          <h2 class="product-callout__title">PFF <span class="u-text-gold">Elite</span></h2>
          <p><em>Our complete subscription, featuring all of EDGE, <strong>plus:</strong></em></p>
          <ul class="product-feature-list">
            <li>
              <span class="new-badge new-badge--pre">New</span>
              Premium Stats 2.0
            </li>
            <li>
              <span class="new-badge new-badge--pre">Coming Soon</span>
              PFF Greenline Game Picks
            </li>
            <li>DFS Optimizer</li>
            <li>ELITE Facebook Group</li>
          </ul>
          <div class="product-callout__buttons">
            <a href="/amember/signup#elite-news-1" class="btn btn-elite">
              Get PFF Elite
            </a>
            <a href="https://join.profootballfocus.com/elite/#news" class="btn btn-secondary">
              Learn More
            </a>
          </div>
          <em>$34.99/mo or $199.99/yr</em>
        </div>
      </div>
    </div>
  </div>
</div>
      </div>

      <div class="new-at-pff">
        <div class="new-at-pff__container">
          <h2 class="new-at-pff__title u-text-green">Featured Elite Tools</h2>
          <div class="new-at-pff-grid">
            <div class="new-at-pff-grid__left">
              <div class="new-at-pff-callout">
                <a href="https://premium.profootballfocus.com/nfl/teams"><img class="new-at-pff-callout__thumb" src="/images/webui/psv2_thumb@2x.png" alt="Premium Stats Version 2"></a>
                <div class="new-at-pff-callout__copy">
                  <h3 class="new-at-pff-callout__title">Premium Stats 2.0</h3>
                  <p class="u-mb-0">The Best Advanced Stats Database</p>
                  <p class="new-at-pff-callout__access">Go beyond traditional stats with PFF metrics like QB Adjusted Completion %, RB Elusive Rating, CB Coverage Snaps, and dozens of other performance stats.</p>
                  <a href="https://premium.profootballfocus.com/nfl/teams" class="link-cta">Click here</a>
                </div>
              </div>
            </div>
            <div class="new-at-pff-grid__right">
              <div class="new-at-pff-callout">
                <a href="https://www.profootballfocus.com/news/pro-pff-greenline-introduction"><img class="new-at-pff-callout__thumb" src="/images/webui/greenline_thumb@2x.png" alt="Greenline"></a>
                <div class="new-at-pff-callout__copy">
                  <h3 class="new-at-pff-callout__title">PFF Greenline</h3>
                  <p class="u-mb-0"><em class="u-text-green">Coming Soon:</em> Spread, Moneyline and Over/Under Picks</p>
                  <p class="new-at-pff-callout__access">Greenline is a pick dashboard with exclusive game data and spread analysis.</p>
                  <a href="https://www.profootballfocus.com/news/pro-pff-greenline-introduction" class="link-cta">Learn More</a>
                </div>
              </div>
            </div>
          </div>
        </div>
      </div>
  
      
  <div class="sub-nav-news">
    <div class="wrapper">
      <div class="row">

        <div class="sub-nav">
          <div class="page-info-lite ">
            <div class="container">
              <div class="row">
                <div class="col">
                  <h1>NFL Analysis</h1>
                </div>
              </div>
            </div>
          </div>
  <div class="page-info-lite-desc container">
    <div class="row">
      <div class="col">
        <p>PFF experts use our exclusive player grades and signature stats to analyze the performance of each NFL team and player.</p>
      </div>
    </div>
  </div>          <hr/>
  <div class="sub-nav-collapsible">
    <nav class="nav-collapsible">
      <input type="checkbox" id="more" aria-hidden="true" tabindex="-1" class="toggle"/>
      <div class="nav-collapsible-inner">
        <div class="nav-collapsible-logo">
          <a href="/news" class="nav-collapsible-link ">Latest</a>
        </div>
        <ul class="nav-collapsible-list">
            <li class="nav-collapsible-item">
              <a href="/news/category/news" class="nav-collapsible-link ">Team & Player News</a>
            </li>
            <li class="nav-collapsible-item">
              <a href="/news/category/nfl" class="nav-collapsible-link current">NFL</a>
            </li>
            <li class="nav-collapsible-item">
              <a href="/news/category/fantasy" class="nav-collapsible-link ">Fantasy</a>
            </li>
            <li class="nav-collapsible-item">
              <a href="/news/category/draft" class="nav-collapsible-link ">Draft</a>
            </li>
            <li class="nav-collapsible-item">
              <a href="/news/category/dfs" class="nav-collapsible-link ">DFS</a>
            </li>
          <li class="nav-collapsible-item">
            <a href="/podcasts" class="nav-collapsible-link">Podcasts</a>
          </li>
        </ul>
        <div class="nav-collapsible-toggle">
          <label for="more" aria-hidden="true" class="nav-collapsible-link">More</label>
        </div>
      </div>
    </nav>
  </div>        </div>

        <div class="col article">
          <div class="news-article">

            <article>
              <h2>Under-the-radar rookies to watch – AFC East</h2>
              <div class="news-article-info">
                By Mike Johnson &bullet;
                
Aug 9, 2018              </div>

              <picture>
                <source media="(max-width: 575px)" srcset="https://media.profootballfocus.com/2018/08/Edmunds.jpg?w=576&amp;h=720">
                <source media="(min-width: 576px) and (max-width: 991px)" srcset="https://media.profootballfocus.com/2018/08/Edmunds.jpg?w=916&amp;h=720">
                <img src="https://media.profootballfocus.com/2018/08/Edmunds.jpg?w=916&amp;h=720" alt="">
              </picture>
              <em class="caption">Jul 27, 2018; Pittsford, NY, USA; Buffalo Bills linebacker Tremaine Edmunds (49) on the field during training camp at St. John Fisher College. Mandatory Credit: Mark Konezny-USA TODAY Sports</em>

<p>In addition to our <a href="https://www.profootballfocus.com/news/pro-training-camp-takeaways-in-the-afc-west/">Training Camp Takeaway</a> series that kicked off last week, we at PFF are also hot on the trails of some intriguing rookies to keep your eyes on as we progress through the preseason. Some rookies are wowing during their first training camp and may be pushing hard for some well-deserved, extra snaps during preseason games.</p>
<p>With our wealth of knowledge both at the NFL and FBS level, here are some under-the-radar rookies that have been turning heads and that you may get to see a lot of this preseason, and what they did in college a year ago:</p>
<p><img class="alignnone wp-image-252791" src="https://media.profootballfocus.com/2018/08/premium2-banner.png" alt="" width="728" srcset="https://media.profootballfocus.com/2018/08/premium2-banner.png 728w, https://media.profootballfocus.com/2018/08/premium2-banner-300x37.png 300w" sizes="(max-width: 728px) 100vw, 728px" /></p>
<h3><a href="https://www.profootballfocus.com/nfl/teams/buffalo-bills/4">Buffalo Bills</a></h3>
<p><img class="alignnone wp-image-253177" src="https://media.profootballfocus.com/2018/08/TremaineEdmunds.jpg" alt="" width="1413" srcset="https://media.profootballfocus.com/2018/08/TremaineEdmunds.jpg 1413w, https://media.profootballfocus.com/2018/08/TremaineEdmunds-300x170.jpg 300w, https://media.profootballfocus.com/2018/08/TremaineEdmunds-768x434.jpg 768w, https://media.profootballfocus.com/2018/08/TremaineEdmunds-1024x579.jpg 1024w" sizes="(max-width: 706px) 89vw, (max-width: 767px) 82vw, 740px" /></p>
<h5>LB <a href="https://www.profootballfocus.com/nfl/players/tremaine-edmunds/50905">Tremaine Edmunds</a></h5>
<p>Although Edmunds was a first-round pick, he has flown somewhat under-the-radar as most of the talk of camp has been focused around fellow first-round pick <a href="https://www.profootballfocus.com/nfl/players/josh-allen/46601">Josh Allen</a> and the quarterback competition. The Bills allowed former linebacker <a href="https://www.profootballfocus.com/nfl/players/preston-brown/8708">Preston Brown</a> to sign with the Cincinnati Bengals in free agency leaving a major hole in the middle of the defense. The opportunity is there for the rookie to be an instant contributor to the defense this season. Edmunds is a physical monster at the linebacker position with an athletic profile unmatched by any other linebacker that came out of the draft, and at just 19 years old he has plenty of room to grow. His production was outstanding at Virginia Tech with 128 defensive stops over the past three seasons. Edmunds was also a significant factor on the blitz in 2017, notching six sacks and 17 pressures. This is an added bonus for the Bills who produced a 39.5-percent pressure rate on blitzes last season, fourth-lowest mark in the NFL.</p>
<p>&nbsp;</p>
<h3><a href="https://www.profootballfocus.com/nfl/teams/miami-dolphins/17">Miami Dolphins</a></h3>
<h5>RB <a href="https://www.profootballfocus.com/nfl/players/kalen-ballage/45741">Kalen Ballage</a></h5>
<p>Fourth-round pick Ballage is currently battling for snaps behind <a href="https://www.profootballfocus.com/nfl/players/kenyan-drake/10707">Kenyan Drake</a> and <a href="https://www.profootballfocus.com/nfl/players/frank-gore/2282">Frank Gore</a> on the Dolphins running back depth chart. Ballage offers intriguing potential and versatility, and teams noticed, as his stock rose leading up to the draft. Ballage was extremely impressive as a receiver during the week of Senior Bowl practices, winning consistently in all practice situations. He is an impressive athlete in a big body, and he has the ability to perform well as runner, receiver and returner at the NFL level despite his relatively pedestrian college production. The rookie running back only averaged 2.7 yards per carry after contact over his college career and broke only 15 tackles on 167 carries in 2017 with Arizona State. He will need to improve in this area to compete with the likes of Drake, who led NFL running backs at 4.5 yards after contact per attempt. The skills and potential are there for Ballage to succeed with the Dolphins, and he’ll be an exciting player to monitor throughout the preseason.</p>
<p>&nbsp;</p>
<h3><a href="https://www.profootballfocus.com/nfl/teams/new-england-patriots/19">New England Patriots</a></h3>
<h5>CB <a href="https://www.profootballfocus.com/nfl/players/duke-dawson/51576">Duke Dawson</a></h5>
<p>Atop the Patriots cornerback depth chart sit <a href="https://www.profootballfocus.com/nfl/players/stephon-gilmore/7016">Stephon Gilmore</a>, <a href="https://www.profootballfocus.com/nfl/players/jason-mccourty/5127">Jason McCourty</a> and <a href="https://www.profootballfocus.com/nfl/players/eric-rowe/9480">Eric Rowe</a>, who are all better suited on outside coverage. However, a second-round pick Dawson, could find an opportunity to push for snaps in the slot this season. Dawson is currently battling with the likes of <a href="https://www.profootballfocus.com/nfl/players/jonathan-jones/11217">Jonathan Jones</a> and <a href="https://www.profootballfocus.com/nfl/players/cyrus-jones/10694">Cyrus Jones</a> among others for slot coverage duties as we head into 2018. Throughout his collegiate career, he allowed a 47.5-percent catch rate in coverage, and his 0.77 yards per coverage snap ranked 22nd among draft-eligible cornerbacks in 2017. Last season at Florida, Dawson allowed a passer rating against of just 37.1, and while in slot coverage he allowed just 13 receptions on 30 targets over 170 snaps for the Gators. Jonathan Jones led the Patriots with 269 snaps in the slot last season, allowing a passer rating of 92.8, but the team also matches safeties in slot coverage at a high rate as well. New England finished with the fifth-highest snap rate in terms of safety usage in the slot with a mark of 17.9 percent last season. The utilization of the 5-foot-10 Dawson will be an interesting aspect of the defense to monitor throughout the preseason.</p>
<p>&nbsp;</p>
<h3><a href="https://www.profootballfocus.com/nfl/teams/new-york-jets/22">New York Jets</a></h3>
<p><img class="alignnone wp-image-253178" src="https://media.profootballfocus.com/2018/08/ParryNickerson.jpg" alt="" width="1415" srcset="https://media.profootballfocus.com/2018/08/ParryNickerson.jpg 1415w, https://media.profootballfocus.com/2018/08/ParryNickerson-300x169.jpg 300w, https://media.profootballfocus.com/2018/08/ParryNickerson-768x434.jpg 768w, https://media.profootballfocus.com/2018/08/ParryNickerson-1024x578.jpg 1024w" sizes="(max-width: 706px) 89vw, (max-width: 767px) 82vw, 740px" /></p>
<h5>CB <a href="https://www.profootballfocus.com/nfl/players/parry-nickerson/50511">Parry Nickerson</a></h5>
<p>As a sixth-round selection by the Jets, Nickerson enters the cornerback room buried behind current starters <a href="https://www.profootballfocus.com/nfl/players/trumaine-johnson/7067">Trumaine Johnson</a> and <a href="https://www.profootballfocus.com/nfl/players/morris-claiborne/7012">Morris Claiborne</a>, but his talent could be too hard to ignore throughout camp. Far from many people’s radars, Nickerson had three good years of PFF grading, and he was exceptional in coverage the past two seasons allowing a NFL passer rating of just 41.0 (2017) and 32.5 (2016) when targeted. The rookie cornerback also allowed just two touchdowns over those two seasons, and he had only one game in 2017 in which he surrendered more than three receptions. He is a welcome sight to the Jets defense who recorded an overall coverage grade of just 53.4 a season ago, worst in the NFL. Nickerson has the athleticism and enough size and length to play at a high level in the NFL, and he will be a player to observe leading up to the season.</p>
<h3>Under-the-radar rookies to watch series</h3>
<hr />
<p><strong><em>AFC East | <a href="https://www.profootballfocus.com/news/pro-under-the-radar-rookies-to-watch-afc-north">AFC North</a> | <a href="https://www.profootballfocus.com/news/pro-under-the-radar-rookies-to-watch-afc-south">AFC South</a> | <a href="https://www.profootballfocus.com/news/pro-under-the-radar-rookies-to-watch-afc-west">AFC West</a><br />
NFC East | NFC North | NFC South | NFC West</em></strong></p>
<p>&nbsp;</p>


            </article>

            <div class="social">
              <span class="social-copy">What do you think? Start a conversation…</span>
              <div class="social-icons">
                <a href="http://www.twitter.com/share?url=https://www.profootballfocus.com/news/pro-under-the-radar-rookies-to-watch-afc-east" class="fa fa-twitter share-icon" target="_blank"></a>
                <a href="https://www.facebook.com/sharer/sharer.php?u=https://www.profootballfocus.com/news/pro-under-the-radar-rookies-to-watch-afc-east" class="fa fa-facebook share-icon"></a>
                <a href="whatsapp://send?text=https://www.profootballfocus.com/news/pro-under-the-radar-rookies-to-watch-afc-east" class="fa fa-whatsapp share-icon" data-action="share/whatsapp/share"></a>
              </div>
            </div>

              <div class="pff-cta-article p-3">
                <h4>PFF Edge & <span>Elite</span></h4>
<a class="col-md-6 btn btn-secondary" href="https://www.profootballfocus.com/features-and-faq/?camp=ftrfeats">Learn More &amp; Compare</a>              </div>
          </div>
        </div>

      </div>
    </div>
  </div>
      <div id="footer" class="hidden-print">
    <div class="container">
      <div class="row">
        <div class="col footer-menu">
          <h4 class="mb-4"><a href="/newsletter?camp=emfooter">Get PFF Updates</a></h4>
          <h4>Customer Service</h4>
          <ul>
            <li>
              <a href="https://pff.desk.com/">FAQS</a>
            </li>
            <li>
              <a href="https://pff.desk.com/customer/portal/emails/new">Contact Us</a>
            </li>
          </ul>
        </div>
        <div class="col footer-menu">
          <h4>About Us</h4>
          <ul>
            <li>
              <a href="/jobs">Jobs</a>
            </li>
            <li>
              <a href="/media">Media &amp; Partnerships</a>
            </li>
            <li>
              <a href="/pff-offers">Special Offers</a>
            </li>
          </ul>
        </div>
        <div class="col footer-content">
          <div class="icons-social">
            <a href="/pff-rss" class="rss"><span class="fa fa-rss"></span></a>
            <a href="/newsletter" class="email"><span class="fa fa-envelope"></span></a>
            <a href="https://twitter.com/pff" class="twitter"><span class="fa fa-twitter"></span></a>
            <a href="https://www.facebook.com/ProFootballFocus/" class="facebook"><span class="fa fa-facebook">&nbsp;</span></a>
            <a href="/podcasts" class="podcasts"><span class="fa fa-headphones">&nbsp;</span></a>
          </div>
          <div class="container-footer-links">
            <img src="/images/webui/pff-shorthand-white.svg" class="logo">
            <div class="footer-links">
              <a href="/sitemap">Sitemap</a>
              <i class="fa fa-circle" aria-hidden="true"></i>
              <a href="/privacy">Privacy Policy</a>
              <i class="fa fa-circle" aria-hidden="true"></i>
              <a href="/terms">Terms of Use</a>
            </div>
            <span>&copy; 2017 ProFootballFocus.com All rights reserved.</span>
          </div>
        </div>
      </div>
    </div>
  </div>

    </div>
    <script src="/js/vendor.chunk-9a9d8f0467e9d6fa96f81ce605fbae2d.js?vsn=d"></script>
    <script src="/js/webui-7afd4305988dd30ea84c47404bd120bc.js?vsn=d"></script>
  </body>
</html>
