<!DOCTYPE html>
<html lang="en">
  <head>
<meta charset="utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no">

<meta name="csrf-token" content="HHwKLGFNVi0pDnAMLQNoXjlfPzJkAAAAQ8sBP5nFQ77xKo2/j/SA+A==">
<meta name="google-site-verification" content="m2N80aEy8ONIhYvVOHT-XogcBBskiZd84_MBObKLOqo" />

  <meta name="twitter:card" content="summary">
  <meta name="twitter:site" content="@pff">
  <meta name="twitter:title" content="The top late-round rookies from all 32 teams through Week 5">
  <meta name="twitter:description" content="NFL Editor Austin Gayle highlights the top late-round and undrafted players from all 32 NFL teams. ">
  <meta name="twitter:image" content="https://media.profootballfocus.com/2018/10/USATSI_113059321.jpg?w=1024&h=1024">

  <meta name="description" content="NFL Editor Austin Gayle highlights the top late-round and undrafted players from all 32 NFL teams. ">

  <link rel="canonical" href="https://www.profootballfocus.com/news/pro-the-top-late-round-rookies-from-all-32-teams-through-week-5">

<meta name="merlin-version" content="1.19.20">

<title>The top late-round rookies from all 32 teams through Week 5 | NFL Analysis | Pro Football Focus</title>

<link rel="shortcut icon" href="/images/favicons/favicon-a0ca957f5abf1ea5f339fd9a781838f1.ico?vsn=d">
<link rel="icon" type="image/png" href="/images/favicons/favicon-16x16-139fb798725dc4683861d459a6b7a7c6.png?vsn=d" sizes="16x16">
<link rel="icon" type="image/png" href="/images/favicons/favicon-32x32-8db0fb77899f8581831b5216ea3b776f.png?vsn=d" sizes="32x32">
<link rel="icon" type="image/png" href="/images/favicons/favicon-96x96-f8f6bc3812781769446b9626a892b1e1.png?vsn=d" sizes="96x96">
<link rel="manifest" href="/manifest.json">
<meta name="theme-color" content="#FFFFFF">
<link rel="apple-touch-icon-precomposed" href="/images/favicons/apple-icon-precomposed-867231551fa406ff08c80f2f6116f002.png?vsn=d">
<link rel="apple-touch-icon" sizes="57x57" href="/images/favicons/apple-icon-57x57-c62538cf57ba96cfa2d28855e7cbad2d.png?vsn=d">
<link rel="apple-touch-icon" sizes="114x114" href="/images/favicons/apple-icon-114x114-24930c0c551fe78234342367dfc64b59.png?vsn=d">
<link rel="apple-touch-icon" sizes="72x72" href="/images/favicons/apple-icon-72x72-933186069f5f87fab57abdd9ea23b15f.png?vsn=d">
<link rel="apple-touch-icon" sizes="144x144" href="/images/favicons/apple-icon-144x144-c5320e28e1a0b0305b587eaf44f9b670.png?vsn=d">
<link rel="apple-touch-icon" sizes="60x60" href="/images/favicons/apple-icon-60x60-746348e1902ef5faa2c4b275f2f22b92.png?vsn=d">
<link rel="apple-touch-icon" sizes="120x120" href="/images/favicons/apple-icon-120x120-ffd6f2ddc5124f382f9140b9707d1f13.png?vsn=d">
<link rel="apple-touch-icon" sizes="76x76" href="/images/favicons/apple-icon-76x76-2aa08ea3ffdd95e8df1b6a8e84b133bc.png?vsn=d">
<link rel="apple-touch-icon" sizes="152x152" href="/images/favicons/apple-icon-152x152-f04c03fe1fe3de263eabb9c53500fd63.png?vsn=d">
<link rel="apple-touch-icon" sizes="180x180" href="/images/favicons/apple-icon-180x180-cc981fb823a01aebc82551a3d76379cc.png?vsn=d">
<meta name="msapplication-TileColor" content="#FFFFFF">
<meta name="msapplication-TileImage" content="/images/favicons/ms-icon-144x144-c5320e28e1a0b0305b587eaf44f9b670.png?vsn=d">
    <link rel="stylesheet" href="/css/webui-7e29225e02a8cd73659150a82fd6bdb5.css?vsn=d">
  </head>
  <body class="updates-products">
<script>
  dataLayer = [{
    'userId': '',
    'loggedInStatus': 'false',
    'subscriptionType': '',
    'internalTraffic': 'No',
    'pageType': 'Article',
    'category': 'NFL',
    'section': 'news',
    'datePublished': '20181011',
    'author': 'Austin Gayle',
    'contentType': 'Article'
  }];
</script>

<!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-MWLLR6"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-MWLLR6');</script>
<!-- End Google Tag Manager -->

    <div id="app">
  <div id="header" class="hidden-print">
    <div class="container">
      <div class="row">
        <nav class="navbar navbar-toggleable-md navbar-light">
          <button class="navbar-toggler navbar-toggler-left main-nav" type="button" data-toggle="modal" data-target="#mainNav">
            <span class="navbar-toggler-text">Menu</span>
          </button>
            <a class="navbar-toggler navbar-toggler-right sign-in-nav" href="/login">
              <span class="navbar-toggler-text">Sign In</span>
            </a>
          <a class="navbar-brand" href="/">
            <svg class="icon icon-pff-shorthand-white">
              <use xlink:href="/images/webui/symbol-defs.svg#icon-pff-shorthand-white"></use>
            </svg>
          </a>
          <div class="collapse navbar-collapse" id="mainNav">
            <div class="modal-wrapper">
              <button type="button" class="close hidden-lg-up" data-dismiss="modal" aria-label="Close">
                <span aria-hidden="true">×</span>
              </button>
              <a class="navbar-brand" href="#">
                <svg class="icon icon-pff-shorthand-white">
                  <use xlink:href="/images/webui/symbol-defs.svg#icon-pff-shorthand-white"></use>
                </svg>
              </a>
              <div class="l-main-nav">
                <div class="l-main-nav__search">
                  <div class="form-search form-inline closed">
                    <i id="btn-search" class="fa fa-search" aria-hidden="true"></i>
                    <input class="form-control" type="search" placeholder="search ..." id="searchBox">
                    <i class="fa fa-times-circle clear-search" aria-hidden="true"></i>
                  </div>
                </div>
                <div class="l-main-nav__links">

                  <nav class="main-nav">
                    <!-- FYI if these change, need to also change the error/404 pages -->
<a class="main-nav__link main-nav__link--nfl" href="/nfl">                      <span class="main-nav__link-title">NFL</span>
                      <span class="main-nav__link-description">
                        NFL Analysis, Grades & Stats
                      </span>
</a>                    <a href="https://premium.profootballfocus.com/nfl/teams" class="main-nav__link main-nav__link--premium-stats">
                      <span class="main-nav__link-title">
                        Premium Stats 2.0
                        <span class="new-badge new-badge--post">New</span>
                      </span>
                      <span class="main-nav__link-description">
                        Advanced Player & Team Performance Stats
                      </span>
                    </a>
                    <a href="/greenline" class="main-nav__link main-nav__link--premium-stats">
                      <span class="main-nav__link-title">
                        PFF Greenline
                        <span class="new-badge new-badge--post">New</span>
                      </span>
                      <span class="main-nav__link-description">
                        Spread, Moneyline and Over/Under Picks
                      </span>
                    </a>
<a class="main-nav__link main-nav__link--fantasy" href="/fantasy">                      <span class="main-nav__link-title">Fantasy</span>
                      <span class="main-nav__link-description">
                        Expert Rankings, Projections & More
                      </span>
</a>                    <a class="main-nav__link main-nav__link--draft" href="/draft">
                    <span class="main-nav__link-title">College & Draft</span>
                    <span class="main-nav__link-description">
                      College Football & NFL Draft Analysis
                    </span>
</a>                    <a class="main-nav__link main-nav__link--tools" href="/tools">
                      <span class="main-nav__link-title">Tools</span>
                      <span class="main-nav__link-description">Access Everything with Your PFF Subscription</span>
                    </a>
                  </nav>
                </div>

                <div class="l-main-nav__account">
                  <div class="my-account-login hidden-md-down">
                    <a class="btn btn-primary" href="/login">Sign In</a>
                  </div>
                </div>
              </div>
            </div>
          </div>
        </nav>
      </div>
    </div>
    <!-- .container -->

    <div id="myAccountNav">
      <button type="button" class="close hidden-lg-up" data-dismiss="modal" aria-label="Close">
        <span aria-hidden="true">×</span>
      </button>
      <a class="navbar-brand" href="/">
        <svg class="icon icon-pff-shorthand-white">
          <use xlink:href="/images/webui/symbol-defs.svg#icon-pff-shorthand-white"></use>
        </svg>
      </a>
  <div class="component-member">
    <div class="container member">
      <div class="row">
        <div class="col league-container">
          <h4>My Fantasy Leagues</h4>
          
            <div class="mt-2 mb-2">
              <em>You currently have no fantasy leagues.</em>
            </div>
          <div class="d-flex flex-row justify-content-between mt-2">
            <a href="/fantasy/leagues/new" class="btn btn-primary">
              <i class="fa fa-plus" aria-hidden="true"></i> Create A League
            </a>
          </div>
        </div>
        <!--
        <div class="col team-container">
          <h4>My Teams</h4>
          <div class="team-thumbs">
            <div class="team-row">
              <a href="#">
                <div class="nfl-logo">
                  <svg class="icon icon-buffalo-bills">
                    <use xlink:href="/images/webui/symbol-defs.svg#icon-buffalo-bills"></use>
                  </svg>
                </div>
              </a>
              <a href="#">
                <div class="nfl-logo">
                  <svg class="icon icon-miami-dolphins">
                    <use xlink:href="/images/webui/symbol-defs.svg#icon-miami-dolphins"></use>
                  </svg>
                </div>
              </a>
              <a href="#">
                <div class="nfl-logo">
                  <svg class="icon icon-new-england-patriots">
                    <use xlink:href="/images/webui/symbol-defs.svg#icon-new-england-patriots"></use>
                  </svg>
                </div>
              </a>
              <a href="#">
                <div class="add-team"><i class="fa fa-plus" aria-hidden="true"></i></div>
              </a>
            </div>
          </div>
        </div>
        -->
        <div class="col info-container">
          <h4>My Info</h4>
          <ul>
            <li><a href="/amember/member">Subscriptions</a></li>
            <li><a href="/amember/profile">Profile</a></li>
            <li><a href="/amember/member/payment-history">Payment History</a></li>
            <li><a data-csrf="HHwKLGFNVi0pDnAMLQNoXjlfPzJkAAAAQ8sBP5nFQ77xKo2/j/SA+A==" data-method="delete" data-to="/logout" href="/logout" rel="nofollow">Logout</a></li>
          </ul>
        </div>
      </div>
    </div>
  </div>
    </div>
    <!-- #myAccountNav -->

    <div id="dropdownMenu" class="dropdown-menu">
  <div class="component-member">
    <div class="container member">
      <div class="row">
        <div class="col league-container">
          <h4>My Fantasy Leagues</h4>
          
            <div class="mt-2 mb-2">
              <em>You currently have no fantasy leagues.</em>
            </div>
          <div class="d-flex flex-row justify-content-between mt-2">
            <a href="/fantasy/leagues/new" class="btn btn-primary">
              <i class="fa fa-plus" aria-hidden="true"></i> Create A League
            </a>
          </div>
        </div>
        <!--
        <div class="col team-container">
          <h4>My Teams</h4>
          <div class="team-thumbs">
            <div class="team-row">
              <a href="#">
                <div class="nfl-logo">
                  <svg class="icon icon-buffalo-bills">
                    <use xlink:href="/images/webui/symbol-defs.svg#icon-buffalo-bills"></use>
                  </svg>
                </div>
              </a>
              <a href="#">
                <div class="nfl-logo">
                  <svg class="icon icon-miami-dolphins">
                    <use xlink:href="/images/webui/symbol-defs.svg#icon-miami-dolphins"></use>
                  </svg>
                </div>
              </a>
              <a href="#">
                <div class="nfl-logo">
                  <svg class="icon icon-new-england-patriots">
                    <use xlink:href="/images/webui/symbol-defs.svg#icon-new-england-patriots"></use>
                  </svg>
                </div>
              </a>
              <a href="#">
                <div class="add-team"><i class="fa fa-plus" aria-hidden="true"></i></div>
              </a>
            </div>
          </div>
        </div>
        -->
        <div class="col info-container">
          <h4>My Info</h4>
          <ul>
            <li><a href="/amember/member">Subscriptions</a></li>
            <li><a href="/amember/profile">Profile</a></li>
            <li><a href="/amember/member/payment-history">Payment History</a></li>
            <li><a data-csrf="HHwKLGFNVi0pDnAMLQNoXjlfPzJkAAAAQ8sBP5nFQ77xKo2/j/SA+A==" data-method="delete" data-to="/logout" href="/logout" rel="nofollow">Logout</a></li>
          </ul>
        </div>
      </div>
    </div>
  </div>
    </div>
    <!-- #dropdownMenu -->
  </div>

    
      <div class="pff-cta-top">
<div class="product-callouts">
  <div class="product-callouts__inner">
    <div class="product-callouts__phone">
      <img src="/images/webui/banner-edge-desktop@3x.png" alt="">
    </div>
    <div class="product-callouts__edge">
      <div class="product-callout-box">
        <div class="product-callout product-callout--inverse">
          <h2 class="product-callout__title">PFF Edge</h2>
          <p><em>Includes:</em></p>
          <ul class="product-feature-list product-feature-list--inverse">
            <li>PFF Player Grades</li>
            <li>Fantasy Draft Tools, Rankings & More</li>
            <li>
              <span class="new-badge new-badge--pre">New</span>
              2018 Fantasy Playbook
            </li>
            <li>
              <span class="new-badge new-badge--pre">New</span>
              2018 QB Annual
            </li>
          </ul>
          <div class="product-callout__buttons">
            <a href="/amember/signup#edge-news-1" class="btn btn-primary">
              Get PFF Edge
            </a>
            <a href="https://join.profootballfocus.com/edge/#news" class="btn btn-secondary">
              Learn More
            </a>
          </div>
          <em>$9.99/mo or $39.99/yr</em>
        </div>
      </div>
    </div>
    <div class="product-callouts__elite">
      <div class="product-callout-box product-callout-box--emphasized">
        <div class="product-callout">
          <h2 class="product-callout__title">PFF <span class="u-text-gold">Elite</span></h2>
          <p><em>Our complete subscription, featuring all of EDGE, <strong>plus:</strong></em></p>
          <ul class="product-feature-list">
            <li>
              <span class="new-badge new-badge--pre">New</span>
              Premium Stats 2.0
            </li>
            <li>
              <span class="new-badge new-badge--pre">New</span>
              PFF Greenline Game Picks
            </li>
            <li>DFS Optimizer</li>
            <li>ELITE Facebook Group</li>
          </ul>
          <div class="product-callout__buttons">
            <a href="/amember/signup#elite-news-1" class="btn btn-elite">
              Get PFF Elite
            </a>
            <a href="https://join.profootballfocus.com/elite/#news" class="btn btn-secondary">
              Learn More
            </a>
          </div>
          <em>$34.99/mo or $199.99/yr</em>
        </div>
      </div>
    </div>
  </div>
</div>
      </div>

      <div class="new-at-pff">
        <div class="new-at-pff__container">
          <h2 class="new-at-pff__title u-text-green">Featured Elite Tools</h2>
          <div class="new-at-pff-grid">
            <div class="new-at-pff-grid__left">
              <div class="new-at-pff-callout">
                <a href="https://premium.profootballfocus.com/nfl/teams"><img class="new-at-pff-callout__thumb" src="/images/webui/psv2_thumb@2x.png" alt="Premium Stats Version 2"></a>
                <div class="new-at-pff-callout__copy">
                  <h3 class="new-at-pff-callout__title">Premium Stats 2.0</h3>
                  <p class="u-mb-0">The Best Advanced Stats Database</p>
                  <p class="new-at-pff-callout__access">Go beyond traditional stats with PFF metrics like QB Adjusted Completion %, RB Elusive Rating, CB Coverage Snaps, and dozens of other performance stats.</p>
                  <a href="https://premium.profootballfocus.com/nfl/teams" class="link-cta">Click here</a>
                </div>
              </div>
            </div>
            <div class="new-at-pff-grid__right">
              <div class="new-at-pff-callout">
                <a href="/greenline"><img class="new-at-pff-callout__thumb" src="/images/webui/greenline_thumb@2x.png" alt="Greenline"></a>
                <div class="new-at-pff-callout__copy">
                  <h3 class="new-at-pff-callout__title">PFF Greenline</h3>
                  <p class="u-mb-0">Spread, Moneyline and Over/Under Picks</p>
                  <p class="new-at-pff-callout__access">Greenline is a pick dashboard with exclusive game data and spread analysis.</p>
                  <a href="/greenline" class="link-cta">Click here</a>
                </div>
              </div>
            </div>
          </div>
        </div>
      </div>
  
      
  <div class="sub-nav-news">
    <div class="wrapper">
      <div class="row">

        <div class="sub-nav">
          <div class="page-info-lite ">
            <div class="container">
              <div class="row">
                <div class="col">
                  <h1>NFL Analysis</h1>
                </div>
              </div>
            </div>
          </div>
  <div class="page-info-lite-desc container">
    <div class="row">
      <div class="col">
        <p>PFF experts use our exclusive player grades and signature stats to analyze the performance of each NFL team and player.</p>
      </div>
    </div>
  </div>          <hr/>
  <div class="sub-nav-collapsible">
    <nav class="nav-collapsible">
      <input type="checkbox" id="more" aria-hidden="true" tabindex="-1" class="toggle"/>
      <div class="nav-collapsible-inner">
        <div class="nav-collapsible-logo">
          <a href="/news" class="nav-collapsible-link ">Latest</a>
        </div>
        <ul class="nav-collapsible-list">
            <li class="nav-collapsible-item">
              <a href="/news/category/nfl" class="nav-collapsible-link current">NFL</a>
            </li>
            <li class="nav-collapsible-item">
              <a href="/news/category/fantasy" class="nav-collapsible-link ">Fantasy</a>
            </li>
            <li class="nav-collapsible-item">
              <a href="/news/category/draft" class="nav-collapsible-link ">College & Draft</a>
            </li>
            <li class="nav-collapsible-item">
              <a href="/news/category/dfs" class="nav-collapsible-link ">DFS</a>
            </li>
            <li class="nav-collapsible-item">
              <a href="/news/category/forecast" class="nav-collapsible-link ">Forecast Picks</a>
            </li>
          <li class="nav-collapsible-item">
            <a href="/podcasts" class="nav-collapsible-link">Podcasts</a>
          </li>
        </ul>
        <div class="nav-collapsible-toggle">
          <label for="more" aria-hidden="true" class="nav-collapsible-link">More</label>
        </div>
      </div>
    </nav>
  </div>        </div>

        <div class="col article">
          <div class="news-article">

            <article>
              <h2>The top late-round rookies from all 32 teams through Week 5</h2>
              <div class="news-article-info">
                By Austin Gayle &bullet;
                
Oct 11, 2018              </div>

              <picture>
                <source media="(max-width: 575px)" srcset="https://media.profootballfocus.com/2018/10/USATSI_113059321.jpg?w=576&amp;h=720">
                <source media="(min-width: 576px) and (max-width: 991px)" srcset="https://media.profootballfocus.com/2018/10/USATSI_113059321.jpg?w=916&amp;h=720">
                <img src="https://media.profootballfocus.com/2018/10/USATSI_113059321.jpg?w=916&amp;h=720" alt="">
              </picture>
              <em class="caption">Sep 23, 2018; Baltimore, MD, USA; Denver Broncos linebacker Josey Jewell (47) breaks up a pass intended fro Baltimore Ravens tight end Mark Andrews (89) during the third quarter at M&amp;amp;T Bank Stadium. Mandatory Credit: Tommy Gilligan-USA TODAY Sports</em>

<p>Teams expect to see early returns from their early-round picks as rookies, while late-rounders and undrafted players usually receive a pass for at least their rookie campaigns. However, some of the draft&#8217;s castaways make an immediate impact at the NFL level. This is a list of those guys.</p>
<p><em>[Editors&#8217; note: This list is compiled of each team&#8217;s top late-round contributor, which is considered any rookie player drafted after Round 3 or undrafted that has played at least 40 primary (offense or defense) snaps or 30 special teams snaps.]</em></p>
<p><a href="https://join.profootballfocus.com/elite/"><img class="aligncenter size-full wp-image-228804" src="https://media.profootballfocus.com/2018/03/bygame-banner.png" alt="" width="100%" /></a></p>
<h3>AFC EAST</h3>
<p><img class="alignnone wp-image-214776 size-full" src="https://media.profootballfocus.com/2017/07/NYJ-Jets-Header.png" alt="" width="650" height="120" srcset="https://media.profootballfocus.com/2017/07/NYJ-Jets-Header.png 650w, https://media.profootballfocus.com/2017/07/NYJ-Jets-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /></p>
<h5><b>RB <a href="https://premium.profootballfocus.com/nfl/players/trenton-cannon/66446/special-teams/summary?season=2018&amp;weekGroup=REGPO">TRENTON CANNON</a>, 6th ROUND</b></h5>
<p>Sixth-round Virginia State product Trenton Cannon has played just 13 offensive snaps this season, but he’s made the most of his 37 special teams snaps. He has played at least seven special teams snaps in four separate units and earned a 71.1 overall grade in the process.</p>
<p><img class="alignnone wp-image-214773 size-full" src="https://media.profootballfocus.com/2017/07/NE-Patriots-Header.png" alt="" width="650" height="120" srcset="https://media.profootballfocus.com/2017/07/NE-Patriots-Header.png 650w, https://media.profootballfocus.com/2017/07/NE-Patriots-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /></p>
<h5><b>LB <a href="https://www.profootballfocus.com/nfl/players/jawhaun-bentley/50966">Ja’Whaun Bentley</a>, 5th Round</b></h5>
<p>Unfortunately for the Patriots’ late-round star, Ja’Whaun Bentley can’t build on his stellar start to his rookie campaign, as he will spend the rest of it on the Injured Reserve with torn biceps. Before bad news struck, however, the former Purdue linebacker earned an 81.7 overall and 84.5 coverage grades – an early sign that Bentley has a bright future ahead in Foxborough.</p>
<p><img class="alignnone wp-image-214755 size-full" src="https://media.profootballfocus.com/2017/07/BUF-Bills-Header.png" alt="" width="650" height="120" srcset="https://media.profootballfocus.com/2017/07/BUF-Bills-Header.png 650w, https://media.profootballfocus.com/2017/07/BUF-Bills-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /></p>
<h5><b>CB <a href="https://www.profootballfocus.com/nfl/players/taron-johnson/49511">Taron Johnson</a>, 4th Round</b></h5>
<p>Stepping in as the Bills’ primary slot cornerback, Weber State alumnus Taron Johnson has performed well on the big stage. He earned 77.0-plus overall grades in Weeks 4 &amp; 5, and he ranks inside the top-20 in yards allowed per coverage snap (1.03) among qualifying slot cornerbacks.</p>
<p><img class="alignnone wp-image-214771 size-full" src="https://media.profootballfocus.com/2017/07/MIA-Dolphins-Header.png" alt="" width="650" height="120" srcset="https://media.profootballfocus.com/2017/07/MIA-Dolphins-Header.png 650w, https://media.profootballfocus.com/2017/07/MIA-Dolphins-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /></p>
<h5>RB <a href="https://premium.profootballfocus.com/nfl/players/kalen-ballage/45741/offense/summary?season=2018&amp;weekGroup=REGPO">Kalen Ballage</a>, 4th Round</h5>
<p>Stowed behind the likes of Frank Gore and Kenyan Drake, former Arizona State running back Kalen Ballage has just three offensive snaps this season. He has, however, made a positive impact on special teams, earning a 70.7 overall grade across 33 special teams snaps. Making his way onto the field will take time, but yielding positive results in the game’s third phase is always a strong way to start as a rookie pushing for playing time.</p>
<h3>AFC NORTH</h3>
<p><img class="alignnone wp-image-214758 size-full" src="https://media.profootballfocus.com/2017/07/CIN-Bengals-Header.png" alt="" width="650" height="120" srcset="https://media.profootballfocus.com/2017/07/CIN-Bengals-Header.png 650w, https://media.profootballfocus.com/2017/07/CIN-Bengals-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /></p>
<h5>RB <a href="https://premium.profootballfocus.com/nfl/players/mark-walton/45996/offense/receiving/summary?season=2018&amp;weekGroup=REGPO">Mark Walton</a>, 4th Round</h5>
<p>With injuries to Giovani Bernard and Joe Mixon, former Miami (Fla.) running back Mark Walton has played 47 offensive snaps in Weeks 3-5. He has just five carries for nine yards in said span, but he did flash his pass-catching ability on a 24-yard reception against Atlanta in Week 4 and has slowly started to adjust to the speed of the NFL. He’s also the only Bengals late-rounder to qualify, so that helps his case.</p>
<p><img class="alignnone size-large wp-image-262019" src="https://media.profootballfocus.com/2018/10/AVGE-1024x577.jpg" alt="" width="525" height="296" srcset="https://media.profootballfocus.com/2018/10/AVGE-1024x577.jpg 1024w, https://media.profootballfocus.com/2018/10/AVGE-300x169.jpg 300w, https://media.profootballfocus.com/2018/10/AVGE-768x432.jpg 768w, https://media.profootballfocus.com/2018/10/AVGE.jpg 1389w" sizes="(max-width: 525px) 100vw, 525px" /></p>
<p><img class="alignnone wp-image-214759 size-full" src="https://media.profootballfocus.com/2017/07/CLV-Browns-Header.png" alt="" width="650" height="120" srcset="https://media.profootballfocus.com/2017/07/CLV-Browns-Header.png 650w, https://media.profootballfocus.com/2017/07/CLV-Browns-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /></p>
<h5><b>Edge </b><a href="https://premium.profootballfocus.com/nfl/players/genard-avery/49699/snap/summary?season=2018&amp;weekGroup=REGPO"><b>Genard Avery</b></a><b>, 5th Round</b></h5>
<p>Former Memphis standout Genard Avery was on pace for Defensive Rookie of the Year to start the season with his 90.3 overall grade in Week 1. And though he’s settled down a bit since, Avery still owns an 80.0 overall grade and an even more impressive 80.0 pass-rush grade so far this season. He has recorded multiple pressures in four of five games, as well.</p>
<p><img class="alignnone wp-image-214754 size-full" src="https://media.profootballfocus.com/2017/07/BLT-Ravens-Header.png" alt="" width="650" height="120" srcset="https://media.profootballfocus.com/2017/07/BLT-Ravens-Header.png 650w, https://media.profootballfocus.com/2017/07/BLT-Ravens-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /></p>
<h5><b>LB </b><a href="https://premium.profootballfocus.com/nfl/players/kenny-young/51029/defense/summary?season=2018&amp;weekGroup=REGPO"><b>Kenny Young</b></a><b>, 4th Round</b></h5>
<p>Kenny Young has undoubtedly struggled as a primary piece to the Ravens’ defense, earning just a 58.2 overall grade across 170 defensive snaps. However, the experience he’s gaining will benefit him long term, and the high-end potential he has flashed in bursts is promising for the young buck’s future. He currently ranks fourth among all rookie defenders in defensive stops (15).</p>
<p><img class="alignnone wp-image-214779 size-full" src="https://media.profootballfocus.com/2017/07/PIT-Steelers-Header.png" alt="" width="650" height="120" srcset="https://media.profootballfocus.com/2017/07/PIT-Steelers-Header.png 650w, https://media.profootballfocus.com/2017/07/PIT-Steelers-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /></p>
<h5>LB <a href="https://premium.profootballfocus.com/nfl/players/matthew-thomas/50942/special-teams/summary?season=2018&amp;weekGroup=REGPO">Matthew Thomas</a>, Undrafted</h5>
<p>Undrafted Florida State linebacker Matthew Thomas, a former five-star recruit coming out of Miami (Fla.) in 2013, recorded one defensive stop in his four defensive snaps in Week 5 and may be in line for more defensive snaps in the near future. He has also contributed significantly on special teams, playing 50 total snaps across three separate units and recording three tackles.</p>
<p><a href="https://www.profootballfocus.com/podcasts"><img class="aligncenter size-full wp-image-228804" src="https://media.profootballfocus.com/2017/10/podcast-banner.png" alt="" width="100%" /></a></p>
<h3>AFC SOUTH</h3>
<p><strong><img class="alignnone wp-image-214765 size-full" src="https://media.profootballfocus.com/2017/07/IND-Colts-Header.png" alt="" width="650" height="120" srcset="https://media.profootballfocus.com/2017/07/IND-Colts-Header.png 650w, https://media.profootballfocus.com/2017/07/IND-Colts-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /> </strong></p>
<h5>G/T <a href="https://premium.profootballfocus.com/nfl/players/braden-smith/46794/offense/summary?season=2018&amp;weekGroup=REGPO">Braden Smith</a>, 5th Round</h5>
<p>The Colts called on fifth-round pick Braden Smith earlier than they likely wanted to, and they called on him to play a position they likely didn’t want him to, either. However, Smith has responded to the calls admirably, as the former Auburn guard allowed just one pressure en route to an 80.1 overall grade across his 83 offensive snaps at right tackle in Week 5. With veteran Matt Slauson heading to the Injured Reserve, Smith will return to guard for Indianapolis and likely maintain his high-end play.</p>
<p><strong><img class="alignnone wp-image-214764 size-full" src="https://media.profootballfocus.com/2017/07/HST-Texans-Header.png" alt="" width="650" height="120" srcset="https://media.profootballfocus.com/2017/07/HST-Texans-Header.png 650w, https://media.profootballfocus.com/2017/07/HST-Texans-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /> </strong></p>
<h5><b>WR </b><a href="https://premium.profootballfocus.com/nfl/players/keke-coutee/47698/offense/receiving/summary?season=2018&amp;weekGroup=REGPO"><b>Keke Coutee</b></a><b>, 4th Round</b></h5>
<p>Former Texas Tech wide receiver Keke Coutee has come alive in recent weeks, catching 17-of-20 targets for 160 yards and a score in Weeks 4 &amp; 5. The 5-foot-11, 180-pound wideout rebounded after two early drops in Week 4 to become a reliable target for Deshaun Watson with great yards-after-the-catch ability.</p>
<p><strong><img class="alignnone wp-image-214783 size-full" src="https://media.profootballfocus.com/2017/07/TEN-Titans-Header.png" alt="" width="650" height="120" srcset="https://media.profootballfocus.com/2017/07/TEN-Titans-Header.png 650w, https://media.profootballfocus.com/2017/07/TEN-Titans-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /> </strong></p>
<h5>Edge <a href="https://premium.profootballfocus.com/nfl/players/sharif-finch/50221/defense/summary?season=2018&amp;weekGroup=REGPO">Sharif Finch</a>, Undrafted</h5>
<p>Undrafted Temple edge defender Sharif Finch has quietly turned in quality performances with Tennessee in his limited role on the defense, as he’s recorded three total pressures and one defensive stop in just 41 defensive snaps.</p>
<p><strong><img class="alignnone wp-image-214766 size-full" src="https://media.profootballfocus.com/2017/07/JAX-Jaguars-Header.png" alt="" width="650" height="120" srcset="https://media.profootballfocus.com/2017/07/JAX-Jaguars-Header.png 650w, https://media.profootballfocus.com/2017/07/JAX-Jaguars-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /></strong></p>
<h5>CB <a href="https://premium.profootballfocus.com/nfl/players/tre-herndon/50380/defense/summary?season=2018&amp;weekGroup=REGPO">Tre Herndon</a>, Undrafted</h5>
<p>Seventh-round punter Logan Cooke has been one of the worst punters in the NFL in nearly every metric, and none of the other Jaguars’ late-rounders have played enough snaps to qualify. Tre Herndon hasn’t blown the doors off Jacksonville with his special teams play, but he does lead all rookies with 68 special teams snaps and has recorded three tackles through Week 5.</p>
<h3>AFC WEST</h3>
<p><img class="alignnone size-large wp-image-262023" src="https://media.profootballfocus.com/2018/10/JEWS-1024x575.jpg" alt="" width="525" height="295" srcset="https://media.profootballfocus.com/2018/10/JEWS-1024x575.jpg 1024w, https://media.profootballfocus.com/2018/10/JEWS-300x169.jpg 300w, https://media.profootballfocus.com/2018/10/JEWS-768x432.jpg 768w, https://media.profootballfocus.com/2018/10/JEWS.jpg 1390w" sizes="(max-width: 525px) 100vw, 525px" /></p>
<p><img class="alignnone wp-image-214761 size-full" src="https://media.profootballfocus.com/2017/07/DEN-Broncos-Header.png" alt="" width="650" height="120" srcset="https://media.profootballfocus.com/2017/07/DEN-Broncos-Header.png 650w, https://media.profootballfocus.com/2017/07/DEN-Broncos-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /></p>
<h5>LB <a href="https://www.profootballfocus.com/nfl/players/josey-jewell/50720">Josey Jewell</a>, 4th Round</h5>
<p>Credit Broncos general manager John Elway for his efforts in the later rounds of this year’s draft, as he has seen positive returns from multiple late-round and undrafted rookies in this season, including running back Phillip Lindsay (undrafted) and wide receiver DaeSean Hamilton (fourth round). Former Iowa linebacker Josey Jewell, however, gets the nod for this list.</p>
<p>The 6-foot-2, 236-pound Jewell has earned the fifth-highest overall grade (85.9) among all rookies – not just the castaways picked up on Day 3 and after the draft. He has thrived in rotation the Broncos’ starters at off-ball linebacker and looks to be making a case for a starting spot. He also leads all rookies in special teams snaps (131) through Week 5.</p>
<p><img class="alignnone wp-image-214767 size-full" src="https://media.profootballfocus.com/2017/07/KC-Chiefs-Header.png" alt="" width="650" height="120" srcset="https://media.profootballfocus.com/2017/07/KC-Chiefs-Header.png 650w, https://media.profootballfocus.com/2017/07/KC-Chiefs-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /></p>
<h5>S <a href="https://premium.profootballfocus.com/nfl/players/armani-watts/51264/snap/summary?season=2018&amp;weekGroup=REGPO">Armani Watts</a>, 4th Round</h5>
<p>Chiefs rookie safety Armani Watts turned in abysmal performances in across limited snaps Weeks 2 &amp; 3, but he has since rebounded in his expanded role. Playing 35 defensive snaps in Weeks 4 &amp; 5, Watts earned 77.0 and 72.0 overall grades, respectively.</p>
<p><img class="alignnone wp-image-214768 size-full" src="https://media.profootballfocus.com/2017/07/LAC-Chargers-Header.png" alt="" width="650" height="120" srcset="https://media.profootballfocus.com/2017/07/LAC-Chargers-Header.png 650w, https://media.profootballfocus.com/2017/07/LAC-Chargers-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /></p>
<h5><b>S </b><a href="https://premium.profootballfocus.com/nfl/players/kyzir-white/44485/defense/summary?season=2018&amp;weekGroup=REGPO"><b>Kyzir White</b></a><b>, 4th Round</b></h5>
<p>While he has experienced some growing pains in Los Angeles, rookie safety Kyzir White has avoided a disastrous start despite taking a trial-by-fire approach to his rookie season. Prior to going down with a knee injury in the Thursday practice prior to Week 4, White earned a respectable 65.6 overall grade across his 142 defensive snaps.</p>
<p><img class="alignnone size-large wp-image-262018" src="https://media.profootballfocus.com/2018/10/HURST1-1024x577.jpg" alt="" width="525" height="296" srcset="https://media.profootballfocus.com/2018/10/HURST1-1024x577.jpg 1024w, https://media.profootballfocus.com/2018/10/HURST1-300x169.jpg 300w, https://media.profootballfocus.com/2018/10/HURST1-768x433.jpg 768w, https://media.profootballfocus.com/2018/10/HURST1.jpg 1386w" sizes="(max-width: 525px) 100vw, 525px" /></p>
<p><img class="alignnone wp-image-214777 size-full" src="https://media.profootballfocus.com/2017/07/OAK-Raiders-Header.png" alt="" width="650" height="120" srcset="https://media.profootballfocus.com/2017/07/OAK-Raiders-Header.png 650w, https://media.profootballfocus.com/2017/07/OAK-Raiders-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /></p>
<h5><b>DI <a href="https://www.profootballfocus.com/nfl/players/maurice-hurst/38563">Maurice Hurst</a>, 5th Round</b></h5>
<p>Slotted as the No. 3 overall player on our final big board, Maurice Hurst’s strong play out of the gates comes as no surprise. Hurst leads all Raiders defenders with at least 10 defensive snaps in overall grade (81.0), and he’s already recorded nine defensive stops and seven total pressures across his 191 defensive snaps.</p>
<p><a href="https://join.profootballfocus.com/edge/"><img class="aligncenter size-full wp-image-228804" src="https://media.profootballfocus.com/2017/10/scout-edge-banner.png" alt="" width="100%" /></a></p>
<h3>NFC EAST</h3>
<p><img class="alignnone wp-image-214760 size-full" src="https://media.profootballfocus.com/2017/07/DAL-Cowboys-Header.png" alt="" width="650" height="120" srcset="https://media.profootballfocus.com/2017/07/DAL-Cowboys-Header.png 650w, https://media.profootballfocus.com/2017/07/DAL-Cowboys-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /></p>
<h5>Edge <a href="https://premium.profootballfocus.com/nfl/players/dorance-armstrong/48557/snap/summary?season=2018&amp;weekGroup=REGPO">Dorance Armstrong</a>, 4th Round</h5>
<p>Former Kansas edge defender Dorance Armstrong struggled out of the gate a bit, but he’s just now starting to gain momentum. He has recorded six total pressures and two defensive stops in Weeks 2-5 and hasn’t missed a tackle since Week 1.</p>
<p><img class="alignnone wp-image-214784 size-full" src="https://media.profootballfocus.com/2017/07/WAS-Redskins-Header.png" alt="" width="650" height="120" srcset="https://media.profootballfocus.com/2017/07/WAS-Redskins-Header.png 650w, https://media.profootballfocus.com/2017/07/WAS-Redskins-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /></p>
<h5>CB <a href="https://premium.profootballfocus.com/nfl/players/danny-johnson/49379/defense/summary?season=2018&amp;weekGroup=REGPO">Danny Johnson</a>, Undrafted</h5>
<p>While he’s played just one defensive snap so far this season, Washington’s Danny Johnson has provided quite versatile on special teams. He has played at least 12 snaps on four separate special teams units and missed zero tackles in the process.</p>
<p><img class="alignnone wp-image-214778 size-full" src="https://media.profootballfocus.com/2017/07/PHI-Eagles-Header.png" alt="" width="650" height="120" srcset="https://media.profootballfocus.com/2017/07/PHI-Eagles-Header.png 650w, https://media.profootballfocus.com/2017/07/PHI-Eagles-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /></p>
<h5>CB <a href="https://premium.profootballfocus.com/nfl/players/avonte-maddox/50543/defense/summary?season=2018&amp;weekGroup=REGPO">Avonte Maddox</a>, 4th Round</h5>
<p>Avonte Maddox has flashed at times on special teams while turning a 47.6 overall grade across his 82 defensive snaps. Most recently, Maddox earned a 52.8 overall grade across 62 defensive snaps against the Vikings in Week 5. The former Pittsburgh safety didn’t leap off the stat sheet, but he didn’t allow any receptions as the primary coverage defender and showed some signs that he could start to trend upward with more experience.</p>
<p><img class="alignnone wp-image-214775 size-full" src="https://media.profootballfocus.com/2017/07/NYG-Giants-Header.png" alt="" width="650" height="120" srcset="https://media.profootballfocus.com/2017/07/NYG-Giants-Header.png 650w, https://media.profootballfocus.com/2017/07/NYG-Giants-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /></p>
<h5>CB <a href="https://premium.profootballfocus.com/nfl/players/sean-chandler/51315/snap/summary?season=2018&amp;weekGroup=REGPO">Sean Chandler</a>, Undrafted</h5>
<p>Undrafted rookie cornerback Sean Chandler has been a man among boys on special teams, earning the second-highest overall grade (82.2) among all rookies. He has also played a whopping 71 special teams snaps across multiple units, proving to be a valuable Swiss army knife for the Giants.</p>
<h3>NFC NORTH</h3>
<p><img class="alignnone wp-image-214772 size-full" src="https://media.profootballfocus.com/2017/07/MIN-Vikings-Header.png" alt="" width="650" height="120" srcset="https://media.profootballfocus.com/2017/07/MIN-Vikings-Header.png 650w, https://media.profootballfocus.com/2017/07/MIN-Vikings-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /></p>
<h5>TE <a href="https://premium.profootballfocus.com/nfl/players/tyler-conklin/47124/offense/receiving/summary?season=2018&amp;weekGroup=REGPO">Tyler Conklin</a>, 5th Round</h5>
<p>In addition to playing 42 special teams snaps, Tyler Conklin has 42 offensive snaps for the Vikings through Week 5. He has impressed in pass protection (70.9) pass-block grade and caught both of his targets for 13 yards and a first down.</p>
<p><img class="alignnone wp-image-214763 size-full" src="https://media.profootballfocus.com/2017/07/GB-Packers-Header.png" alt="" width="650" height="120" srcset="https://media.profootballfocus.com/2017/07/GB-Packers-Header.png 650w, https://media.profootballfocus.com/2017/07/GB-Packers-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /></p>
<h5>P <a href="https://premium.profootballfocus.com/nfl/players/jk-scott/38809/snap/summary?season=2018&amp;weekGroup=REGPO">JK Scott</a>, 5th<span style="font-size: 13.3333px;"> </span>Round</h5>
<p>Punters are people, too. And Packers rookie punter J.K. Scott is among the league’s best punters so far this season, as he leads all rookies and fifth among all punters in overall grade (73.6) through Week 5.</p>
<p><img class="alignnone size-large wp-image-262024" src="https://media.profootballfocus.com/2018/10/D-HANDdd-1024x576.jpg" alt="" width="525" height="295" srcset="https://media.profootballfocus.com/2018/10/D-HANDdd-1024x576.jpg 1024w, https://media.profootballfocus.com/2018/10/D-HANDdd-300x169.jpg 300w, https://media.profootballfocus.com/2018/10/D-HANDdd-768x432.jpg 768w, https://media.profootballfocus.com/2018/10/D-HANDdd.jpg 1389w" sizes="(max-width: 525px) 100vw, 525px" /></p>
<p><img class="alignnone wp-image-214762 size-full" src="https://media.profootballfocus.com/2017/07/DET-Lions-Header.png" alt="" width="650" height="120" srcset="https://media.profootballfocus.com/2017/07/DET-Lions-Header.png 650w, https://media.profootballfocus.com/2017/07/DET-Lions-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /></p>
<h5>DI <a href="https://www.profootballfocus.com/nfl/players/dashawn-hand/48386">Da’Shawn Hand</a>, 4th Round</h5>
<p>Former Alabama standout Da’Shawn Hand has picked up where he left off in Tuscaloosa, taking his special run-defense to Detroit. His 77.1 run-defense grade ranks seventh among all rookie defenders through five weeks.</p>
<p><img class="alignnone wp-image-214757 size-full" src="https://media.profootballfocus.com/2017/07/CHI-Bears-Header.png" alt="" width="650" height="120" srcset="https://media.profootballfocus.com/2017/07/CHI-Bears-Header.png 650w, https://media.profootballfocus.com/2017/07/CHI-Bears-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /></p>
<h5>DI <a href="https://premium.profootballfocus.com/nfl/players/bilal-nichols/28451/defense/summary?season=2018&amp;weekGroup=REGPO">Bilal Nichols</a>, 5th Round</h5>
<p>Former Delaware product Bilal Nichols has played just 50 defensive snaps this season, but his play has been special in the limited sample size. He has recorded an impressive 86.9 overall grade through Week 5, logging two pressures and three defensive stops in the process.</p>
<h3>NFC SOUTH</h3>
<p><img class="alignnone wp-image-214753 size-full" src="https://media.profootballfocus.com/2017/07/ATL-Falcons-Header.png" alt="" width="650" height="120" srcset="https://media.profootballfocus.com/2017/07/ATL-Falcons-Header.png 650w, https://media.profootballfocus.com/2017/07/ATL-Falcons-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /></p>
<h5><b>RB <a href="https://www.profootballfocus.com/nfl/players/ito-smith/45932">Ito Smith</a>, 4th Round</b></h5>
<p>Ito Smith hasn’t played a ton for the Falcons (71 offensive snaps), but his play even in limited fashion has been strong. He hasn’t allowed a pressure in his 16 pass-block snaps, and he’s caught all eight of his catchable targets through Week 5. He continues to improve and provide value in a backfield that is struggling in wake of Deonvta Freeman’s injuries.</p>
<p><img class="alignnone wp-image-214782 size-full" src="https://media.profootballfocus.com/2017/07/TB-Buccaneers-Header.png" alt="" width="650" height="120" srcset="https://media.profootballfocus.com/2017/07/TB-Buccaneers-Header.png 650w, https://media.profootballfocus.com/2017/07/TB-Buccaneers-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /></p>
<h5><b>S <a href="https://www.profootballfocus.com/nfl/players/jordan-whitehead/49196">Jordan Whitehead</a>, 4th Round</b></h5>
<p>Bucs’ Jordan Whitehead, a fourth-round safety product out of Pittsburgh, played well for Tampa Bay before going down with an injury. He recorded eight combined tackles while missing zero, and he allowed just two receptions for 37 yards in coverage. After being a full participant in practice Wednesday, Whitehead should pick up where he left off in Week 6.</p>
<p><img class="alignnone wp-image-214774 size-full" src="https://media.profootballfocus.com/2017/07/NO-Saints-Header.png" alt="" width="650" height="120" srcset="https://media.profootballfocus.com/2017/07/NO-Saints-Header.png 650w, https://media.profootballfocus.com/2017/07/NO-Saints-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /></p>
<h5><b>DI </b><a href="https://premium.profootballfocus.com/nfl/players/taylor-stallworth/48935/defense/summary?season=2018&amp;weekGroup=REGPO"><b>Taylor Stallworth</b></a><b>, Undrafted</b></h5>
<p>Taylor Stallworth is the only late-round rookie that has played at least 40 offensive or defensive snaps for New Orleans so far this season, and he impressed in a limited role in the Saints’ defense. He has recorded one pressure and one defensive stop in his 96 defensive snaps.</p>
<p><img class="alignnone wp-image-214756 size-full" src="https://media.profootballfocus.com/2017/07/CAR-Panthers-Header.png" alt="" width="650" height="120" srcset="https://media.profootballfocus.com/2017/07/CAR-Panthers-Header.png 650w, https://media.profootballfocus.com/2017/07/CAR-Panthers-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /></p>
<h5><b>TE </b><a href="https://premium.profootballfocus.com/nfl/players/ian-thomas/42130/offense/receiving/summary?season=2018&amp;weekGroup=REGPO"><b>Ian Thomas</b></a><b>, 4th Round</b></h5>
<p>Ian Thomas’ 45.8 overall grade doesn’t look great, but he is the only Panthers&#8217; late-round rookie to play at least 40 defensive snaps this season. He has, however, impressed in pass protection (75.5 pass-block grade) across a limited sample size (11 pass-block snaps). The early experience is good for Thomas’ development, but he’ll need to turn things around in a hurry, specifically in the passing game, if he’s going to really be a high-end contributor rather than the team’s only qualifying rookie.</p>
<p><a href="https://premium.profootballfocus.com/nfl/teams"><img class="aligncenter size-full wp-image-228804" src="https://media.profootballfocus.com/2018/07/premium2-banner.png" alt="" width="100%" /></a></p>
<h3>NFC WEST</h3>
<p><img class="alignnone wp-image-214752 size-full" src="https://media.profootballfocus.com/2017/07/ARZ-Cardinals-Header.png" alt="" width="650" height="120" srcset="https://media.profootballfocus.com/2017/07/ARZ-Cardinals-Header.png 650w, https://media.profootballfocus.com/2017/07/ARZ-Cardinals-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /></p>
<h5>LB <a href="https://premium.profootballfocus.com/nfl/players/zeke-turner/49167?season=2018&amp;weekGroup=REGPO">Zeke Turner</a>, Undrafted</h5>
<p>Running back Chase Edmonds almost stole this spot away from Cardinals’ Zeke Turner, but the former Washington linebacker has played too well on special teams overlook him at this point. Turner’s 79.0 overall grade across 84 special teams snaps ranks fifth among all rookies so far this season.</p>
<p><img class="alignnone wp-image-214780 size-full" src="https://media.profootballfocus.com/2017/07/SEA-Seahawks-Header.png" alt="" width="650" height="120" srcset="https://media.profootballfocus.com/2017/07/SEA-Seahawks-Header.png 650w, https://media.profootballfocus.com/2017/07/SEA-Seahawks-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /></p>
<h5><b>TE </b><a href="https://premium.profootballfocus.com/nfl/players/will-dissly/30762/offense/receiving/summary?season=2018&amp;weekGroup=REGPO"><b>Will Dissly</b></a><b>, 4th Round</b></h5>
<p>After his three-reception, 105-yard performance in Week 2, rookie tight end Will Dissly has (expectedly) fallen back down to Earth. However, his fall hasn’t been as significant as you’d expect with a fourth-round blocking tight end, as he currently owns a 71.4 overall grade and a 75.2 pass-block grade.</p>
<p><img class="alignnone wp-image-214781 size-full" src="https://media.profootballfocus.com/2017/07/SF-49ers-Header.png" alt="" width="650" height="120" srcset="https://media.profootballfocus.com/2017/07/SF-49ers-Header.png 650w, https://media.profootballfocus.com/2017/07/SF-49ers-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /></p>
<h5>San Francisco 49ers: CB <a href="https://premium.profootballfocus.com/nfl/players/d-j-reed-jr/26940/defense/summary?season=2018&amp;weekGroup=REGPO">D.J. Reed</a>, 5th Round</h5>
<p>D.J. Reed is the only rookie on the 49ers’ roster drafted outside of the third round that has played any special teams snaps or defensive snaps, making him the top choice by default, unfortunately. He has earned one of the lowest grades as a special teamer (29.9) and just a 52.2 overall grade across his 119 defensive snaps. He has also missed three tackles already.</p>
<p><img class="alignnone wp-image-233179 size-full" src="https://media.profootballfocus.com/2017/11/LA-Rams-Header-2017.png" alt="" width="650" height="120" srcset="https://media.profootballfocus.com/2017/11/LA-Rams-Header-2017.png 650w, https://media.profootballfocus.com/2017/11/LA-Rams-Header-2017-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /></p>
<h5>Edge <a href="https://premium.profootballfocus.com/nfl/players/john-franklin-myers/50088/special-teams/summary?season=2018&amp;weekGroup=REGPO">John Franklin-Myers</a>, 4th Round</h5>
<p>Los Angeles entered the 2018 season with a desperate need for someone to step along the edge of its defensive line, and fourth-round rookie John Franklin-Myers has done just that. His eight total pressures rank T-fifth among all rookie defenders through five weeks.</p>


            </article>

            <div class="social">
              <span class="social-copy">What do you think? Start a conversation…</span>
              <div class="social-icons">
                <a href="http://www.twitter.com/share?url=https://www.profootballfocus.com/news/pro-the-top-late-round-rookies-from-all-32-teams-through-week-5" class="fa fa-twitter share-icon" target="_blank"></a>
                <a href="https://www.facebook.com/sharer/sharer.php?u=https://www.profootballfocus.com/news/pro-the-top-late-round-rookies-from-all-32-teams-through-week-5" class="fa fa-facebook share-icon"></a>
                <a href="whatsapp://send?text=https://www.profootballfocus.com/news/pro-the-top-late-round-rookies-from-all-32-teams-through-week-5" class="fa fa-whatsapp share-icon" data-action="share/whatsapp/share"></a>
              </div>
            </div>

              <div class="pff-cta-article p-3">
                <h4>PFF Edge & <span>Elite</span></h4>
<a class="col-md-6 btn btn-secondary" href="https://www.profootballfocus.com/features-and-faq/?camp=ftrfeats">Learn More &amp; Compare</a>              </div>
          </div>
        </div>

      </div>
    </div>
  </div>
      <div id="footer" class="hidden-print">
    <div class="container">
      <div class="row">
        <div class="col footer-menu">
          <h4 class="mb-4"><a href="/newsletter?camp=emfooter">Get PFF Updates</a></h4>
          <h4>Customer Service</h4>
          <ul>
            <li>
              <a href="https://pff.desk.com/">FAQS</a>
            </li>
            <li>
              <a href="https://pff.desk.com/customer/portal/emails/new">Contact Us</a>
            </li>
          </ul>
        </div>
        <div class="col footer-menu">
          <h4>About Us</h4>
          <ul>
            <li>
              <a href="/jobs">Jobs</a>
            </li>
            <li>
              <a href="/media">Media &amp; Partnerships</a>
            </li>
            <li>
              <a href="/pff-offers">Special Offers</a>
            </li>
            <li>
              <a href="/team-services">Teams, Agents & Media</a>
            </li>
          </ul>
        </div>
        <div class="col footer-content">
          <div class="icons-social">
            <a href="/pff-rss" class="rss"><span class="fa fa-rss"></span></a>
            <a href="/newsletter" class="email"><span class="fa fa-envelope"></span></a>
            <a href="https://twitter.com/pff" class="twitter"><span class="fa fa-twitter"></span></a>
            <a href="https://www.facebook.com/ProFootballFocus/" class="facebook"><span class="fa fa-facebook">&nbsp;</span></a>
            <a href="/podcasts" class="podcasts"><span class="fa fa-headphones">&nbsp;</span></a>
          </div>
          <div class="container-footer-links">
            <img src="/images/webui/pff-shorthand-white.svg" class="logo">
            <div class="footer-links">
              <a href="/sitemap">Sitemap</a>
              <i class="fa fa-circle" aria-hidden="true"></i>
              <a href="/privacy">Privacy Policy</a>
              <i class="fa fa-circle" aria-hidden="true"></i>
              <a href="/terms">Terms of Use</a>
            </div>
            <span>&copy; 2018 ProFootballFocus.com All rights reserved.</span>
          </div>
        </div>
      </div>
    </div>
  </div>

    </div>
    <script src="/js/vendor.chunk-e38f1579e2857cfdcda85b5cc8c3976b.js?vsn=d"></script>
    <script src="/js/webui-a5923729535e1e8c9f49173f3225e156.js?vsn=d"></script>
  </body>
</html>
