<!DOCTYPE html>
<html lang="en">
  <head>
    <meta charset="utf-8">
    <meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no">


  <script src="https://use.typekit.net/ybp1qsc.js"></script>
  <script>try{Typekit.load({ async: true });}catch(e){}</script>
  
    <meta name="csrf-token" content="LGxuSH8rJgUvMEIvBRhoIx1cPicvEAAATYEq0eDicAilkwPYKwRejg==">

      <meta name="twitter:card" content="summary">
      <meta name="twitter:site" content="@pff">
      <meta name="twitter:title" content="All 32 NFL team&#39;s 2018 NFL Draft grades">
      <meta name="twitter:description" content="Senior Analysts Steve Palazzolo and Sam Monson hand out their immediate takes from every pick, on every team of the 2018 NFL Draft.">
      <meta name="twitter:image" content="https://media.profootballfocus.com/2018/04/USATSI_10807756.jpg?w=1024&h=1024">

      <meta name="description" content="Senior Analysts Steve Palazzolo and Sam Monson hand out their immediate takes from every pick, on every team of the 2018 NFL Draft.">

      <link rel="canonical" href="https://www.profootballfocus.com/news/pro-all-32-nfl-teams-2018-nfl-draft-grades">

    <title>All 32 NFL team&#39;s 2018 NFL Draft grades | NFL Analysis | Pro Football Focus</title>

<link rel="shortcut icon" href="/images/favicons/favicon-a0ca957f5abf1ea5f339fd9a781838f1.ico?vsn=d">
<link rel="icon" type="image/png" href="/images/favicons/favicon-16x16-139fb798725dc4683861d459a6b7a7c6.png?vsn=d" sizes="16x16">
<link rel="icon" type="image/png" href="/images/favicons/favicon-32x32-8db0fb77899f8581831b5216ea3b776f.png?vsn=d" sizes="32x32">
<link rel="icon" type="image/png" href="/images/favicons/favicon-96x96-f8f6bc3812781769446b9626a892b1e1.png?vsn=d" sizes="96x96">
<link rel="manifest" href="/manifest.json">
<meta name="theme-color" content="#FFFFFF">
<link rel="apple-touch-icon-precomposed" href="/images/favicons/apple-icon-precomposed-867231551fa406ff08c80f2f6116f002.png?vsn=d">
<link rel="apple-touch-icon" sizes="57x57" href="/images/favicons/apple-icon-57x57-c62538cf57ba96cfa2d28855e7cbad2d.png?vsn=d">
<link rel="apple-touch-icon" sizes="114x114" href="/images/favicons/apple-icon-114x114-24930c0c551fe78234342367dfc64b59.png?vsn=d">
<link rel="apple-touch-icon" sizes="72x72" href="/images/favicons/apple-icon-72x72-933186069f5f87fab57abdd9ea23b15f.png?vsn=d">
<link rel="apple-touch-icon" sizes="144x144" href="/images/favicons/apple-icon-144x144-c5320e28e1a0b0305b587eaf44f9b670.png?vsn=d">
<link rel="apple-touch-icon" sizes="60x60" href="/images/favicons/apple-icon-60x60-746348e1902ef5faa2c4b275f2f22b92.png?vsn=d">
<link rel="apple-touch-icon" sizes="120x120" href="/images/favicons/apple-icon-120x120-ffd6f2ddc5124f382f9140b9707d1f13.png?vsn=d">
<link rel="apple-touch-icon" sizes="76x76" href="/images/favicons/apple-icon-76x76-2aa08ea3ffdd95e8df1b6a8e84b133bc.png?vsn=d">
<link rel="apple-touch-icon" sizes="152x152" href="/images/favicons/apple-icon-152x152-f04c03fe1fe3de263eabb9c53500fd63.png?vsn=d">
<link rel="apple-touch-icon" sizes="180x180" href="/images/favicons/apple-icon-180x180-cc981fb823a01aebc82551a3d76379cc.png?vsn=d">
<meta name="msapplication-TileColor" content="#FFFFFF">
<meta name="msapplication-TileImage" content="/images/favicons/ms-icon-144x144-c5320e28e1a0b0305b587eaf44f9b670.png?vsn=d">
    <link rel="stylesheet" href="/css/webui-8c9dfddfddea853e25227592d2933e11.css?vsn=d">
  </head>
  <body class="updates-products">
<script>
  dataLayer = [{
    'userId': '',
    'loggedInStatus': 'false',
    'subscriptionType': '',
    'internalTraffic': 'No',
    'pageType': 'Article',
    'category': 'NFL',
    'section': 'news',
    'datePublished': '20180428',
    'author': 'Sam Monson and Steve Palazzolo',
    'contentType': 'Article'
  }];
</script>

<!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-MWLLR6"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-MWLLR6');</script>
<!-- End Google Tag Manager -->
    <div id="app">

  <div id="header" class="hidden-print">
    <div class="container">
      <div class="row">
        <nav class="navbar navbar-toggleable-md navbar-light">
          <button class="navbar-toggler navbar-toggler-left main-nav" type="button" data-toggle="modal" data-target="#mainNav">
            <span class="navbar-toggler-text">Menu</span>
          </button>
            <a class="navbar-toggler navbar-toggler-right sign-in-nav" href="/login">
              <span class="navbar-toggler-text">Sign In</span>
            </a>
          <a class="navbar-brand" href="/">
            <svg class="icon icon-pff-shorthand-white">
              <use xlink:href="/images/webui/symbol-defs.svg#icon-pff-shorthand-white"></use>
            </svg>
          </a>
          <div class="collapse navbar-collapse" id="mainNav">
            <div class="modal-wrapper">
              <button type="button" class="close hidden-lg-up" data-dismiss="modal" aria-label="Close">
                <span aria-hidden="true">×</span>
              </button>
              <a class="navbar-brand" href="#">
                <svg class="icon icon-pff-shorthand-white">
                  <use xlink:href="/images/webui/symbol-defs.svg#icon-pff-shorthand-white"></use>
                </svg>
              </a>
              <ul class="navbar-nav">
                <li class="nav-item">
                  <div class="form-inline closed">
                    <i id="btn-search" class="fa fa-search" aria-hidden="true"></i>
                    <input class="form-control" type="search" placeholder="search ..." id="searchBox">
                    <i class="fa fa-times-circle clear-search" aria-hidden="true"></i>
                  </div>
                </li>
                <!-- FYI if these change, need to also change the error/404 pages -->
                <li class="nav-item ">
<a class="nav-link" href="/nfl">NFL</a>                </li>
                <li class="nav-item ">
<a class="nav-link" href="/fantasy">Fantasy</a>                </li>
                <li class="nav-item ">
<a class="nav-link" href="/draft">NFL Draft</a>                </li>
                <li class="nav-item ">
                  <a class="nav-link" href="/nfl/teams">Teams</a>
                </li>
                <li class="nav-item ">
                  <a class="nav-link" href="/tools">Tools</a>
                </li>
                  <li class="nav-item hidden-md-down">
                    <a class="nav-link btn btn-primary" href="/login">Sign In</a>
                  </li>
              </ul>

                
                <div class="nav-pff-cta hidden-lg-up">
                  <div class="container">
<div class="edge cta">
  <img src="/images/webui/device-banner-phone-01@2x.png" alt="">
  <div class="cta-copy">
    <h2>PFF Edge</h2>
    <p>Full year access to Player Grades, PFF Fantasy, premium content, and special reports.</p>
    <a href="/amember/signup#edge-news">Subscribe</a> &middot; <a href="https://join.profootballfocus.com/edge/#news">Learn More</a>
    <em>$9.99/mo or $39.99/yr</em>
  </div>
</div>
                    <div class="elite cta">
  <img src="/images/webui/device-banner-phone-02@2x.png" alt="">
  <div class="cta-copy">
    <h2>PFF <span>Elite</span></h2>
    <p>The very best of PFF. Our full access pass elevates your football IQ to genius level.</p>
    <a href="/amember/signup#elite-news">Subscribe</a> &middot; <a href="https://join.profootballfocus.com/elite/#news">Learn More</a>
    <em>$34.99/mo or $199.99/yr</em>
  </div>
</div>

                  </div>
                </div>
            </div>
          </div>
        </nav>
      </div>
    </div>
    <!-- .container -->

    <div id="myAccountNav">
      <button type="button" class="close hidden-lg-up" data-dismiss="modal" aria-label="Close">
        <span aria-hidden="true">×</span>
      </button>
      <a class="navbar-brand" href="/">
        <svg class="icon icon-pff-shorthand-white">
          <use xlink:href="/images/webui/symbol-defs.svg#icon-pff-shorthand-white"></use>
        </svg>
      </a>
  <div class="component-member">
    <div class="container member">
      <div class="row">
        <div class="col league-container">
          <h4>My Fantasy Leagues</h4>
          
            <div class="mt-2 mb-2">
              <em>You currently have no fantasy leagues.</em>
            </div>
          <div class="d-flex flex-row justify-content-between mt-2">
            <a href="/fantasy/leagues/new" class="btn btn-primary">
              <i class="fa fa-plus" aria-hidden="true"></i> Create A League
            </a>
          </div>
        </div>
        <!--
        <div class="col team-container">
          <h4>My Teams</h4>
          <div class="team-thumbs">
            <div class="team-row">
              <a href="#">
                <div class="nfl-logo">
                  <svg class="icon icon-buffalo-bills">
                    <use xlink:href="/images/webui/symbol-defs.svg#icon-buffalo-bills"></use>
                  </svg>
                </div>
              </a>
              <a href="#">
                <div class="nfl-logo">
                  <svg class="icon icon-miami-dolphins">
                    <use xlink:href="/images/webui/symbol-defs.svg#icon-miami-dolphins"></use>
                  </svg>
                </div>
              </a>
              <a href="#">
                <div class="nfl-logo">
                  <svg class="icon icon-new-england-patriots">
                    <use xlink:href="/images/webui/symbol-defs.svg#icon-new-england-patriots"></use>
                  </svg>
                </div>
              </a>
              <a href="#">
                <div class="add-team"><i class="fa fa-plus" aria-hidden="true"></i></div>
              </a>
            </div>
          </div>
        </div>
        -->
        <div class="col info-container">
          <h4>My Info</h4>
          <ul>
            <li><a href="/amember/member">Subscriptions</a></li>
            <li><a href="/amember/profile">Profile</a></li>
            <li><a href="/amember/member/payment-history">Payment History</a></li>
            <li><a data-csrf="LGxuSH8rJgUvMEIvBRhoIx1cPicvEAAATYEq0eDicAilkwPYKwRejg==" data-method="delete" data-to="/logout" href="#" rel="nofollow">Logout</a></li>
          </ul>
        </div>
      </div>
    </div>
  </div>
    </div>
    <!-- #myAccountNav -->

    <div id="dropdownMenu" class="dropdown-menu">
  <div class="component-member">
    <div class="container member">
      <div class="row">
        <div class="col league-container">
          <h4>My Fantasy Leagues</h4>
          
            <div class="mt-2 mb-2">
              <em>You currently have no fantasy leagues.</em>
            </div>
          <div class="d-flex flex-row justify-content-between mt-2">
            <a href="/fantasy/leagues/new" class="btn btn-primary">
              <i class="fa fa-plus" aria-hidden="true"></i> Create A League
            </a>
          </div>
        </div>
        <!--
        <div class="col team-container">
          <h4>My Teams</h4>
          <div class="team-thumbs">
            <div class="team-row">
              <a href="#">
                <div class="nfl-logo">
                  <svg class="icon icon-buffalo-bills">
                    <use xlink:href="/images/webui/symbol-defs.svg#icon-buffalo-bills"></use>
                  </svg>
                </div>
              </a>
              <a href="#">
                <div class="nfl-logo">
                  <svg class="icon icon-miami-dolphins">
                    <use xlink:href="/images/webui/symbol-defs.svg#icon-miami-dolphins"></use>
                  </svg>
                </div>
              </a>
              <a href="#">
                <div class="nfl-logo">
                  <svg class="icon icon-new-england-patriots">
                    <use xlink:href="/images/webui/symbol-defs.svg#icon-new-england-patriots"></use>
                  </svg>
                </div>
              </a>
              <a href="#">
                <div class="add-team"><i class="fa fa-plus" aria-hidden="true"></i></div>
              </a>
            </div>
          </div>
        </div>
        -->
        <div class="col info-container">
          <h4>My Info</h4>
          <ul>
            <li><a href="/amember/member">Subscriptions</a></li>
            <li><a href="/amember/profile">Profile</a></li>
            <li><a href="/amember/member/payment-history">Payment History</a></li>
            <li><a data-csrf="LGxuSH8rJgUvMEIvBRhoIx1cPicvEAAATYEq0eDicAilkwPYKwRejg==" data-method="delete" data-to="/logout" href="#" rel="nofollow">Logout</a></li>
          </ul>
        </div>
      </div>
    </div>
  </div>
    </div>
    <!-- #dropdownMenu -->
  </div>

    
      <div class="pff-cta-top">
<div class="container">
  <div class="row">
    <div class="col edge cta">
      <div class="row">
        <div class="col">
          <img src="/images/webui/banner-edge-desktop@2x.png" alt="">
        </div>
        <div class="col">
          <h2>PFF Edge</h2>
          <p>Full year access to Player Grades, PFF Fantasy, premium content, and special reports.</p>
          <div class="buttons">
            <a href="/amember/signup#edge-news-1" class="btn btn-primary btn-sm btn-block">
              Get PFF Edge
            </a>
            <a href="https://join.profootballfocus.com/edge/#news" class="btn btn-secondary btn-sm btn-block">
              Learn More
            </a>
          </div>
          <em>$9.99/mo or $39.99/yr</em>
        </div>
      </div>
    </div>
    <div class="col elite cta">
      <div class="row">
        <div class="col">
          <img src="/images/webui/banner-elite-desktop@2x.png" alt="">
        </div>
        <div class="col">
          <h2>PFF <span>Elite</span></h2>
          <p>The very best of PFF. Our full access pass elevates your football IQ to genius level. &nbsp;&nbsp;&nbsp;</p>
          <div class="buttons">
            <a href="/amember/signup#elite-news-1" class="btn btn-elite btn-sm btn-block">
              Get PFF Elite
            </a>
            <a href="https://join.profootballfocus.com/elite/#news" class="btn btn-secondary btn-sm btn-block">
              Learn More
            </a>
          </div>
          <em>$34.99/mo or $199.99/yr</em>
        </div>
      </div>
    </div>
  </div>
</div>
      </div>
  
      
  <div class="sub-nav-news">
    <div class="wrapper">
      <div class="row">

        <div class="sub-nav">
          <div class="page-info-lite ">
            <div class="container">
              <div class="row">
                <div class="col">
                  <h1>NFL Analysis</h1>
                </div>
              </div>
            </div>
          </div>
  <div class="page-info-lite-desc container">
    <div class="row">
      <div class="col">
        <p>PFF experts use our exclusive player grades and signature stats to analyze the performance of each NFL team and player.</p>
      </div>
    </div>
  </div>          <hr/>
  <div class="sub-nav-collapsible">
    <nav class="nav-collapsible">
      <input type="checkbox" id="more" aria-hidden="true" tabindex="-1" class="toggle"/>
      <div class="nav-collapsible-inner">
        <div class="nav-collapsible-logo">
          <a href="/news" class="nav-collapsible-link ">Latest</a>
        </div>
        <ul class="nav-collapsible-list">
            <li class="nav-collapsible-item">
              <a href="/news/category/news" class="nav-collapsible-link ">Team & Player News</a>
            </li>
            <li class="nav-collapsible-item">
              <a href="/news/category/nfl" class="nav-collapsible-link current">NFL</a>
            </li>
            <li class="nav-collapsible-item">
              <a href="/news/category/fantasy" class="nav-collapsible-link ">Fantasy</a>
            </li>
            <li class="nav-collapsible-item">
              <a href="/news/category/draft" class="nav-collapsible-link ">Draft</a>
            </li>
            <li class="nav-collapsible-item">
              <a href="/news/category/dfs" class="nav-collapsible-link ">DFS</a>
            </li>
          <li class="nav-collapsible-item">
            <a href="/podcasts" class="nav-collapsible-link">Podcasts</a>
          </li>
        </ul>
        <div class="nav-collapsible-toggle">
          <label for="more" aria-hidden="true" class="nav-collapsible-link">More</label>
        </div>
      </div>
    </nav>
  </div>        </div>

        <div class="col article">
          <div class="news-article">

            <article>
              <h2>All 32 NFL team&#39;s 2018 NFL Draft grades</h2>
              <div class="news-article-info">
                By Sam Monson and Steve Palazzolo &bullet;
                
Apr 28, 2018              </div>

              <picture>
                <source media="(max-width: 575px)" srcset="https://media.profootballfocus.com/2018/04/USATSI_10807756.jpg?w=576&amp;h=720">
                <source media="(min-width: 576px) and (max-width: 991px)" srcset="https://media.profootballfocus.com/2018/04/USATSI_10807756.jpg?w=916&amp;h=720">
                <img src="https://media.profootballfocus.com/2018/04/USATSI_10807756.jpg?w=916&amp;h=720" alt="">
              </picture>
              <em class="caption">Apr 27, 2018; Berea, OH, USA; Cleveland Browns first round picks, Baker Mayfield (left) and Denzel Ward show off Browns jerseys during a press conference at the Cleveland Browns training facility. Mandatory Credit: Ken Blaze-USA TODAY Sports</em>

<p>The 2018 NFL Draft is officially in the books. After a flurry of history-making picks and eye-raising selections from Thursday to Saturday, 256 players were selected to join one of each of the 32 NFL teams. With that, we give you our full draft recap, with analysis on each team&#8217;s day and every selection every team made during the weekend.</p>
<p>For more information on who your favorite team drafted, it&#8217;s not too late to get our 2018 NFL Draft Guide with expanded profiles, scouting reports, PFF signature stats and extensive details on over 300 players you cannot find anywhere else.</p>
<p><a href="https://www.profootballfocus.com/features-and-faq/" target="_blank" rel="noopener noreferrer"><img class="aligncenter size-full wp-image-228804" src="https://media.profootballfocus.com/2018/03/DRAFT-banner.png" alt="" width="100%" /></a></p>
<p><em><strong>[Editor&#8217;s note: below lists every team&#8217;s selection in the 2018 NFL Draft by: round (overall selection), player, position, school or university, PFF overall grade.]</strong></em></p>
<p><img class="alignnone wp-image-214755" src="https://media.profootballfocus.com/2017/07/BUF-Bills-Header.png" alt="" width="650" srcset="https://media.profootballfocus.com/2017/07/BUF-Bills-Header.png 650w, https://media.profootballfocus.com/2017/07/BUF-Bills-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /></p>
<p><span style="font-weight: 400;">1 (7) Josh Allen, QB, Wyoming, 73.6</span></p>
<p><span style="font-weight: 400;">1 (16) Tremaine Edmunds, LB, Virginia Tech, 87.1</span></p>
<p><span style="font-weight: 400;">3 (96) Harrison Phillips, DI, Stanford, 90.3</span></p>
<p><span style="font-weight: 400;">4 (121) Taron Johnson, CB, Weber State, n/a</span></p>
<p><span style="font-weight: 400;">5 (154) Siran Neal, S, Jacksonville State, n/a</span></p>
<p><span style="font-weight: 400;">5 (166) Wyatt Teller, G, Virginia Tech, 86.7</span></p>
<p><span style="font-weight: 400;">6 (187) Ray-Ray McCloud, WR, Clemson, 68.5</span></p>
<p><span style="font-weight: 400;">7 (255) Austin Proehl, WR, UNC, 80.3</span></p>
<p><strong>Day 1</strong>: The rumors were heavy that the Bills would move up to take Josh Allen, and they did just that. Allen has a cannon for an arm, combined with the size and athleticism to make spectacular plays outside the pocket, but he comes with big question marks in key areas, namely his accuracy and decision-making. He’s ranked among the nation’s worst in negatively-graded throws over the last two years and he finished 29th<sup> </sup>out of 38 quarterbacks in the draft class at avoiding turnover-worthy throws last season. The big-time throws are a part of his game as Allen had the highest percentage in the nation in 2016, while ranking seventh in the draft class last year, and the Bills must let him use his arm and playmaking ability down the field while trying to mitigate the accuracy issues and play recognition that has held his game back despite his electric skillset.</p>
<p>Buffalo then made a move to grab Tremaine Edmunds, adding a much-needed athletic presence for the middle of their zone-heavy defense. Edmunds is not as polished as some of the other top linebackers in this class as he’ll often take the wrong gap in the run game, but his movement skills make him a weapon in coverage, whether covering ground in zone or matching up against opposing tight ends. He ranked ninth in the draft class with a run-stop percentage of 12.5 while posting a solid coverage grade of 81.0.</p>
<p><strong>Day 2</strong>: The Bills didn’t have a second-round pick, and they add help for their run defense with Harrison Phillips in the third. He is one of the best interior run defenders in the class, leading the way with a run-stop percentage of 13.3 last season to go with a 90.2 grade against the run. However, Phillips has not shown much as a pass-rusher, grading at 82.9 last season and finishing 53rd<sup> </sup>in the draft class with a pass-rush productivity of only 6.4.</p>
<p><strong>Day 3</strong>: Wyatt Teller could be a steal in the fifth round after posting four years of grading in between 86.0 and 89.3. He is a powerful run-blocker and he finished ninth in the draft class with a run-block success percentage of 92.2.</p>
<p><img class="alignnone wp-image-214771" src="https://media.profootballfocus.com/2017/07/MIA-Dolphins-Header.png" alt="" width="650" srcset="https://media.profootballfocus.com/2017/07/MIA-Dolphins-Header.png 650w, https://media.profootballfocus.com/2017/07/MIA-Dolphins-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /></p>
<p><span style="font-weight: 400;">1 (11) Minkah Fitzpatrick, S, Alabama, 84.8</span></p>
<p><span style="font-weight: 400;">2 (42) Mike Gesicki, TE, Penn State, 84.9</span></p>
<p><span style="font-weight: 400;">3 (73) Jerome Baker, LB, Ohio State, 81.5</span></p>
<p><span style="font-weight: 400;">4 (123) Durham Smythe, TE, Notre Dame, 74.6</span></p>
<p><span style="font-weight: 400;">4 (131) Kalen Ballage, RB, Arizona State, 60.7</span></p>
<p><span style="font-weight: 400;">6 (209) Cornell Armstrong, CB, Southern Miss, 81.4</span></p>
<p><span style="font-weight: 400;">7 (227) Quentin Poling, LB, Ohio, 83.1</span></p>
<p><span style="font-weight: 400;">7 (229) Jason Sanders, K, New Mexico, n/a</span></p>
<p><strong>Day 1</strong>: Minkah Fitzpatrick is a fantastic fit for any defense, but perhaps even more crucial for the Dolphins in the AFC East as they look to eventually overtake the Patriots. Fitzpatrick excelled in Alabama’s “star” role where he covered well from the slot, played the run as well as any corner, and showed well as a blitzer. <a href="https://www.profootballfocus.com/news/pro-examining-the-value-of-slot-defensive-backs/">Covering tight ends and slot receivers is as valuable as ever in today’s NFL</a>, and Fitzpatrick is one of the few players in the draft who has already shown that skillset in college. His three-year production was consistent, as he graded between 81.8 and 88.4, doing his best work in 2016 when he picked off six passes and broke up eight more on only 61 targets.</p>
<p><strong>Day 2</strong>: Miami continued their theme of winning in between the numbers with the additions of Mike Gesicki and Jerome Baker. Gesicki crushed the NFL combine and he adds a long, athletic option at tight end. He’s not much of a blocker (50.5 run-block grade in 2017 was career-high), but he had the highest contested-catch rate in the nation among tight ends (75.0 percent) and his long frame allows him to make spectacular catches. Baker adds a much-needed athletic linebacker to the mix though he did his best work in 2016 with an 87.7 overall grade that dropped to 80.9 last season. He’s strong in man-coverage looks, but must improve when playing zone.</p>
<p><strong>Day 3</strong>: Durham Smythe showed promise as a run-blocker with an 80.2 grade in 2016, but he regressed back to 54.3 last season. Kalen Ballage could become a pass-game weapon as he has good size and athleticism, and his 86.6 receiving grade from 2016 is the number that gives hope that he can become a better pro than college player. He struggled as a runner in college, grading at only 69.2 last season while averaging just 2.8 yards after contact per rush during his career. Quentin Poling graded between 83.0 and 86.8 in all four years of his career and his run-stop percentage of 10.8 ranked 23rd<sup> </sup>among linebackers in the draft class in 2017.</p>
<p><img class="alignnone wp-image-214776" src="https://media.profootballfocus.com/2017/07/NYJ-Jets-Header.png" alt="" width="650" srcset="https://media.profootballfocus.com/2017/07/NYJ-Jets-Header.png 650w, https://media.profootballfocus.com/2017/07/NYJ-Jets-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /></p>
<p><img class="alignnone wp-image-247891" src="https://media.profootballfocus.com/2018/04/IMG_28042018_161345_0.png" alt="" width="800" srcset="https://media.profootballfocus.com/2018/04/IMG_28042018_161345_0.png 800w, https://media.profootballfocus.com/2018/04/IMG_28042018_161345_0-300x169.png 300w, https://media.profootballfocus.com/2018/04/IMG_28042018_161345_0-768x432.png 768w" sizes="(max-width: 706px) 89vw, (max-width: 767px) 82vw, 740px" /></p>
<p><span style="font-weight: 400;">1 (3) Sam Darnold, QB, USC, 83.6</span></p>
<p><span style="font-weight: 400;">3 (72) Nathan Shepherd, DI, Fort Hays State, n/a</span></p>
<p><span style="font-weight: 400;">4 (107) Christopher Herndon IV, TE, Miami (Fla.), 81.8</span></p>
<p><span style="font-weight: 400;">6 (179) Parry Nickerson, CB, Tulane, 85.1</span></p>
<p><span style="font-weight: 400;">6 (180) Folorunso Fatukasi, Edge, Connecticut, 83.2</span></p>
<p><span style="font-weight: 400;">6 (204) Trenton Cannon, RB, Virginia State, n/a</span></p>
<p><strong>Day 1</strong>: The Jets should be ecstatic that Darnold was still on the board at No. 3 overall. Our No. 2 player on the PFF Draft Board, Darnold has shown exceptional high-end play, throwing with the accuracy and anticipation desired from an NFL quarterback. He has two strong years of grading under his belt, and while last year was not as good as anticipated, Darnold <a href="https://www.profootballfocus.com/news/draft-2018-qb-study-sam-darnold/">was still the No. 3-graded quarterback</a> in the nation outside of his four poor games. He must cut back on the bad decisions and fumbles that marred that four-game stretch, as he finished with the fifth-highest percentage of turnover-worthy plays in the draft class last season, but it’s the big-time throws that make him a potentially special prospect as he ranked second. Darnold has <a href="https://www.profootballfocus.com/news/draft-sam-darnold-special-in-crunch-time/">shown well in crunch time</a>, whether at the end of the half or with the game on the line, and his ability to make plays both inside and outside the pocket will lead to memorable moments for Jets fans.</p>
<p><strong>Day 2</strong>: With only a third-round selection on Day 2, the Jets add athletic defensive lineman Nathan Shepherd to the mix, a small-school player who looked strong during his limited reps at the Senior Bowl. He has outstanding size and athleticism, and he could develop into a good all-around player given his measurables.</p>
<p><strong>Day 3</strong>: Christopher Herndon showed strong big-play ability last season, forcing nine missed tackles on only 40 receptions and averaging 9.3 yards after the catch per reception. Parry Nickerson could become a steal in the sixth round as he has three outstanding years of production to go with 4.32 speed. He allowed a passer rating of only 41.7 in 2017 and 32.5 when targeted in 2016. Folorunso Fatukasi is an outstanding run defender, grading between 82.8 and 86.1 in all four years at UConn, though he provided little as a pass-rusher, including a 3.1 pass-rush productivity last year that ranked 131st<sup> </sup>in the draft class.</p>
<p><img class="alignnone wp-image-214773" src="https://media.profootballfocus.com/2017/07/NE-Patriots-Header.png" alt="" width="650" srcset="https://media.profootballfocus.com/2017/07/NE-Patriots-Header.png 650w, https://media.profootballfocus.com/2017/07/NE-Patriots-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /></p>
<p><span style="font-weight: 400;">1 (23) Isaiah Wynn, OT, Georgia, 88.1</span></p>
<p><span style="font-weight: 400;">1 (31) Sony Michel, RB, Georgia, 83.3</span></p>
<p><span style="font-weight: 400;">2 (56) Duke Dawson, CB, Florida, 81.1 </span></p>
<p><span style="font-weight: 400;">5 (143) Ja’Whaun Bentley, LB, Purdue, 91.2</span></p>
<p><span style="font-weight: 400;">6 (178) Christian Sam, LB, Arizona State, 69.7</span></p>
<p><span style="font-weight: 400;">6 (210) Braxton Berrios, WR, Miami (Fla.), 80.6</span></p>
<p><span style="font-weight: 400;">7 (219) Danny Etling, QB, LSU, 78.2</span></p>
<p><span style="font-weight: 400;">7 (243) Keion Crossen, CB, Western Carolina, n/a</span></p>
<p><span style="font-weight: 400;">7 (250) Ryan Izzo, TE, Florida State, 73.8</span></p>
<p><strong>Day 1</strong>: The Patriots kicked off the night with Isaiah Wynn who played left tackle exceptionally well at Georgia last season and may stick at tackle for the Patriots despite being undersized and looking more like a guard. He allowed only five pressures on 330 attempts in pass protection and he finished with the No. 3 grade in the nation as a run blocker at 91.0. Wynn has three years of strong grading, both at guard and tackle, and he adds positional flexibility to the New England offensive line. They went back to Georgia to take Wynn’s teammate, Sony Michel, who adds a quick-cutting back with receiving potential to the offense. He ranked sixth in the draft class with an elusive rating of 95.1 last season, and despite seeing only 80 targets in the passing game in his career, Michel’s quickness should be a nice fit for New England’s scheme.</p>
<p><strong>Day 2</strong>: The Patriots spent most of Day 2 trading down, but they did make one selection as they traded back up to get Duke Dawson. He allowed a passer rating of only 41.0 when lined up in the slot last year, eighth-best in the nation, after allowing a rating of only 64.6 (38th) in 2016. Given the <a href="https://www.profootballfocus.com/news/pro-examining-the-value-of-slot-defensive-backs">value of slot defenders</a> in today’s NFL, Dawson fills an important need for the Patriots’ defense.</p>
<p><strong>Day 3</strong>: Ja&#8217;Whaun Bentley is a downhill thumper who posted the nation’s top grade against the run at 95.0 while ranking fourth in the draft class with a run-stop percentage of 13.3. He has work to do in coverage, and may be limited to early downs at the next level. Braxton Berrios ranked eighth among receivers in the draft class with 680 yards gained from the slot. Danny Etling posted a career-high 78.9 overall grade in 2017.</p>
<p><img class="alignnone wp-image-214758" src="https://media.profootballfocus.com/2017/07/CIN-Bengals-Header.png" alt="" width="650" srcset="https://media.profootballfocus.com/2017/07/CIN-Bengals-Header.png 650w, https://media.profootballfocus.com/2017/07/CIN-Bengals-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /></p>
<p><span style="font-weight: 400;">1 (21) Billy Price, C, Ohio State, 83.8</span></p>
<p><span style="font-weight: 400;">2 (54) Jessie Bates III, S, Wake Forest, 78.3</span></p>
<p><span style="font-weight: 400;">3 (77) Sam Hubbard, Edge, Ohio State, 80.8</span></p>
<p><span style="font-weight: 400;">3 (78) Malik Jefferson, LB, Texas, 87.5</span></p>
<p><span style="font-weight: 400;">4 (112) Mark Walton, RB, Miami (Fla.), 86.1</span></p>
<p><span style="font-weight: 400;">5 (151) Davontae Harris, CB, Illinois State, n/a</span></p>
<p><span style="font-weight: 400;">5 (158) Andrew Brown, DI, Virginia, 77.1</span></p>
<p><span style="font-weight: 400;">5 (170) Darius Phillips, CB, Western Michigan, 84.2</span></p>
<p><span style="font-weight: 400;">7 (249) Logan Woodside, QB, Toledo, 84.1</span></p>
<p><span style="font-weight: 400;">7 (252) Rod Taylor, OT, Ole Miss, 83.1</span></p>
<p><span style="font-weight: 400;">7 (253) Auden Tate, WR, Florida State, 82.3</span></p>
<p><strong>Day 1</strong>: The Bengals were rumored to have been targeting a center in the first round, and with our top center, Frank Ragnow, coming off the board right before their pick, they stuck with the need pick with Billy Price. He has experience playing multiple positions at Ohio State, capping his career with two solid years of grading (84.7 in 2016, 83.2 in 2017). Price is aggressive both as a run-blocker and in pass protection, a trait that works both for and against him. He ranked sixth in the draft class with a run-block success percentage of 92.0, but only 27th<sup> </sup>in pass-blocking efficiency at 97.6.</p>
<p><strong>Day 2</strong>: Jessie Bates is one of few safeties who can hang with receivers in 1-on-1 situations, and he’s made a few spectacular plays when matched up in “quarters” looks. He’s also willing to mix it up in the run game, though he must do a better job of preventing big plays after missing 16 tackles on only 81 attempts last season. Sam Hubbard had a solid career at Ohio State, grading at 83.0 in 2016 and 80.8 last season. He’s done his best work in the run game as his best pass-rush grade of 79.0 came in 2016. Malik Jefferson started to live up to his five-star pedigree last year after struggling in his first two seasons. He ranked 14th<sup> </sup>in the draft class with a run-stop percentage of 12.1 percent, though he must cut back on the missed tackles after missing 36 on only 250 career attempts.</p>
<p><strong>Day 3</strong>: Mark Walton has a number of spectacular cuts on tape, showing the quickness and speed to be a weapon as both a runner and as a receiver. He posted an excellent 86.1 overall grade last season before going down due to an ankle injury. Andrew Brown posted average grades throughout his career showing through in his 7.6 pass-rush productivity that ranked 28th<sup> </sup>in the class and his run-stop percentage of 5.6 that ranked 77th. Darius Phillips posted three solid years of grading at corner, picking off 12 passes and breaking up 26 on 206 targets. Logan Woodside is an intriguing backup option as he ranked 11th<sup> </sup>in big-time throw percentage in the draft class, but only 22nd<sup> </sup>at avoiding turnover-worthy plays. He posted grades of 86.3 in 2016 and 84.3 in 2017. Auden Tate can do damage in the red zone with his long frame and he ranked sixth in the nation with a 66.7 percent catch rate in contested situations last season.</p>
<p><img class="alignnone wp-image-214759" src="https://media.profootballfocus.com/2017/07/CLV-Browns-Header.png" alt="" width="650" srcset="https://media.profootballfocus.com/2017/07/CLV-Browns-Header.png 650w, https://media.profootballfocus.com/2017/07/CLV-Browns-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /></p>
<p><img class="alignnone wp-image-247894" src="https://media.profootballfocus.com/2018/04/IMG_28042018_161240_0.png" alt="" width="800" srcset="https://media.profootballfocus.com/2018/04/IMG_28042018_161240_0.png 800w, https://media.profootballfocus.com/2018/04/IMG_28042018_161240_0-300x169.png 300w, https://media.profootballfocus.com/2018/04/IMG_28042018_161240_0-768x432.png 768w" sizes="(max-width: 706px) 89vw, (max-width: 767px) 82vw, 740px" /></p>
<p><span style="font-weight: 400;">1 (1) Baker Mayfield, QB, Oklahoma, 94.8 </span></p>
<p><span style="font-weight: 400;">1 (4) Denzel Ward, CB, Ohio State, 91.4</span></p>
<p><span style="font-weight: 400;">2 (33) Austin Corbett, G/C, Nevada, 84.0</span></p>
<p><span style="font-weight: 400;">2 (35) Nick Chubb, RB, Georgia, 87.6</span></p>
<p><span style="font-weight: 400;">3 (67) Chad Thomas, Edge, Miami (Fla.), 83.9</span></p>
<p><span style="font-weight: 400;">4 (105) Antonio Callaway, WR, Florida, 77.7* (in 2016)</span></p>
<p><span style="font-weight: 400;">5 (150) Genard Avery, LB, Memphis, 82.4</span></p>
<p><span style="font-weight: 400;">6 (175) Damion Ratley, WR, Texas A&amp;M, 77.1</span></p>
<p><span style="font-weight: 400;">6 (188) Simeon Thomas, CB, Louisiana, 79.0</span></p>
<p><strong>Day 1</strong>: Mayfield was PFF’s pick to be the No. 1 overall pick for the Browns since last October and they made it a reality despite many rumors to the contrary. Mayfield has the two highest single-season grades we’ve given a quarterback in our four years of grading and he can make every necessary throw with zip and accuracy. No matter which way the numbers are sliced, Mayfield generally led the way, including the best PFF grade from a clean pocket (<a href="https://www.profootballfocus.com/news/draft-can-pff-data-predict-success-at-the-next-level/">the most consistent measure of year-to-year success</a>) and also the best grade when facing pressure. He also came out on top in our new advanced accuracy numbers that emphasized actual ball location on every throw, and his was nine percent better than the next-best quarterback on tight-window throws. After much speculation, the Browns selected the No. 1 player on the PFF draft board with the first pick of the draft.</p>
<p>As for Denzel Ward, he fills a massive need in the secondary and his straight-line speed and lateral agility make him a perfect candidate to match up with the best route runners in the NFL. Ward allowed a completion percentage of only 35.0 percent in his career when targeted, picking off two passes and breaking up 19 more on only 100 targets. He may struggle at the catch point at times against bigger receivers, but he knows how to play through the receiver’s hands to break up passes and he’s had his fair share of success when matched up against bigger bodies in college.</p>
<p><strong>Day 2</strong>: The Browns added a versatile offensive lineman in Austin Corbett who played left tackle at Nevada, though he could play guard or center where he showed well at the Senior Bowl. He has three years of grading in the mid-80.0s and his 98.0 pass-blocking efficiency ranked 13th<sup> </sup>in the draft class among tackles last season. Nick Chubb is one of the best runners in the class, and he looked back to form last year after two years of battling injuries and recovering. He maximizes what his run-blocking gives him and he averaged 3.7 yards after contact per rush during his four-year career at Georgia. Chad Thomas continued to improve throughout his career at Miami, and he did his best work in the run game where he graded at 84.5 last season while his pass-rush productivity of 9.9 ranked 39th<sup> </sup>in the draft class.</p>
<p><strong>Day 3</strong>: On the field, Antonio Callaway is a big-play threat as his impressive game speed makes him a weapon on the deep ball, taking short passes for big gains, and as a punt returner. He averaged 7.3 yards after the catch per reception in his career, but fell in the draft due to off-field concerns, including being suspended for the entire 2017 season. Genard Avery did plenty of damage on the edge at Memphis, notching nine sacks, 14 QB hits and 34 hurries last season, and he brings versatility to the Cleveland defense.</p>
<p><img class="alignnone wp-image-214754" src="https://media.profootballfocus.com/2017/07/BLT-Ravens-Header.png" alt="" width="650" srcset="https://media.profootballfocus.com/2017/07/BLT-Ravens-Header.png 650w, https://media.profootballfocus.com/2017/07/BLT-Ravens-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /></p>
<p><span style="font-weight: 400;">1 (25) Hayden Hurst, TE, South Carolina, 79.4</span></p>
<p><span style="font-weight: 400;">1 (32) Lamar Jackson, QB, Louisville, 90.3</span></p>
<p><span style="font-weight: 400;">3 (83) Orlando Brown, OT, Oklahoma, 87.9</span></p>
<p><span style="font-weight: 400;">3 (86) Mark Andrews, TE, Oklahoma, 87.7</span></p>
<p><span style="font-weight: 400;">4 (118) Anthony Averett, CB, Alabama, 81.4</span></p>
<p><span style="font-weight: 400;">4 (122) Kenny Young, LB, UCLA, 68.9</span></p>
<p><span style="font-weight: 400;">4 (132) Jaleel Scott, WR, New Mexico State, 82.5</span></p>
<p><span style="font-weight: 400;">5 (162) Jordan Lasley, WR, UCLA, 86.0</span></p>
<p><span style="font-weight: 400;">6 (190) DeShon Elliott, S, Texas, 85.5</span></p>
<p><span style="font-weight: 400;">6 (212) Greg Senat, OT, Wagner, n/a</span></p>
<p><span style="font-weight: 400;">6 (215) Bradley Bozeman, C, Alabama, 86.5</span></p>
<p><span style="font-weight: 400;">7 (238) Zach Sieler, Edge, Ferris State, n/a</span></p>
<p><strong>Day 1</strong>: The Ravens were active on the first night of the draft, initially moving back to take Hayden Hurst and then jumping back into the first round to snag Jackson. Hurst brings a contested-catch presence to the offense where he uses good body control and sure hands to haul in difficult catches. Like most tight ends in the draft class, he’s not much of a blocker, but he can locate targets on the move and he has a handful of highlight-reel blocks to his name. As for Lamar Jackson, the Ravens have an eye toward the future, and they can bring him along slowly in order to try to tie up some of his weaknesses as a passer. He’s a dynamic athlete, capable of changing the game as a runner and he’s more than capable of making &#8220;NFL throws&#8221; as he’s shown the ability to work through progressions, throw with progression, and make tight-window throws. However, his down-to-down accuracy is lacking as he ranked 10th<sup> </sup>out of 10 quarterbacks in PFF’s advanced charting accuracy, so it’s crucial for the Ravens to use his athletic ability to create a higher percentage of open throws. There’s a path to success for Jackson in the NFL as long as the Ravens build around his unique skillset.</p>
<p><strong>Day 2</strong>: Baltimore added two Oklahoma Sooners in Round 3, starting with Orlando Brown who went from potential first-round pick to the third round after a poor showing on the workout circuit. He’s still a monster in the run game, grading at 89.2 last season, though he must show that he can handle speed rushers at the next level. Mark Andrews adds another mismatch weapon to the mix after he was a glorified slot receiver in Oklahoma’s offense. He’s a smooth route-runner who ranked second in the draft class with 2.63 yards per route while leading tight ends with 288 yards on deep (20-plus yard) passes.</p>
<p><strong>Day 3</strong>: Anthony Averett is a fluid athlete, capable of sticking with receivers in man coverage, though he must do a better job of making plays on the ball. His 81.5 overall grade in 2017 was the best of his career and he allowed only 0.84 yards per cover snap, 28th-best in the drat class. Kenny Young had his best season in 2016, grading at 81.6, though he took a big step back to grade at 68.9 in 2017. Jaleel Scott has an incredible highlight reel of catches as he routinely used his long frame to catch off-target throws. He adds another contested-catch option to the pass game after ranking seventh in the nation with 326 yards in contested situations last season. Jordan Lasley is a solid route runner who knows how to create leverage against man coverage and he could do damage from the slot, though he must cut down on the drops after dropping 19 out of 131 career catchable targets and ranking 334th<sup> </sup>in the nation in drop rate in 2017. Bradley Bozeman had a nice career at Alabama, grading at 86.8 overall in 2016 and 86.5 in 2017.</p>
<p><img class="alignnone wp-image-214779" src="https://media.profootballfocus.com/2017/07/PIT-Steelers-Header.png" alt="" width="650" srcset="https://media.profootballfocus.com/2017/07/PIT-Steelers-Header.png 650w, https://media.profootballfocus.com/2017/07/PIT-Steelers-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /></p>
<p><span style="font-weight: 400;">1 (28) Terrell Edmunds, S, Virginia Tech, 76.7</span></p>
<p><span style="font-weight: 400;">2 (60) James Washington, WR, Oklahoma State, 87.8 </span></p>
<p><span style="font-weight: 400;">3 (76) Mason Rudolph, QB, Oklahoma State, 91.9</span></p>
<p><span style="font-weight: 400;">3 (92) Chukwuma Okorafor, OT, Western Michigan, 77.6</span></p>
<p><span style="font-weight: 400;">5 (148) Marcus Allen, S, Penn State, 84.4</span></p>
<p><span style="font-weight: 400;">5 (165) Jaylen Samuels, RB/TE, NC State, 73.6</span></p>
<p><span style="font-weight: 400;">7 (246) Joshua Frazier, DI, Alabama, 75.1</span></p>
<p><strong>Day 1</strong>: In one of the bigger surprises of Round 1, the Steelers add Terrell Edmunds who brings an exceptional athletic profile, but an inconsistent on-field performance. His best overall grade of 76.8 came in 2016 and given his athleticism, his best path to success is as a versatile coverage player. His movement skills show up on film, and he has plenty of highlight-reel plays, including six interceptions and 10 pass breakups on 104 career targets, but there are also far too many plays where he is simply a step out of position at the catch point.</p>
<p><strong>Day 2</strong>: The Steelers snagged one of the nation’s most prolific duos in the nation in Oklahoma State’s James Washington and Mason Rudolph. Washington led the country with 815 yards on deep passes last season and he has downfield body control to continue that production at the next level. Rudolph is a fine developmental option behind Ben Roethlisberger as he was in the first-round discussion throughout the draft process. Rudolph posted the top grade in the draft class on third downs, though his short-area ball location and red zone work must improve. Chukwuma Okorafor has a classic offensive tackle frame, but he’s a developmental player at this stage after topping out with a 78.6 overall grade in 2016.</p>
<p><strong>Day 3</strong>: Marcus Allen is a classic box-safety who is strong against the run, but he may be limited as a coverage player. His run-stop percentage of 8.3 when lined up in the box ranked fifth in the nation in 2016 and he’s posted grades of 88.0 and 83.4 against the run the last two years. Jaylen Samuels is an offensive mismatch weapon as he played running back, tight end, fullback and slot receiver at NC State. He rushed for 1,095 yards picked up 1,865 yards as a receiver in college, while ranking 16th<sup> </sup>among draft-class tight ends with 1.43 yards per route run last season.</p>
<p><img class="alignnone wp-image-214765" src="https://media.profootballfocus.com/2017/07/IND-Colts-Header.png" alt="" width="650" srcset="https://media.profootballfocus.com/2017/07/IND-Colts-Header.png 650w, https://media.profootballfocus.com/2017/07/IND-Colts-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /></p>
<p><span style="font-weight: 400;">1 (6) Quenton Nelson, G, Notre Dame, 95.1</span></p>
<p><span style="font-weight: 400;">2 (36) Darius Leonard, LB, South Carolina State, n/a</span></p>
<p><span style="font-weight: 400;">2 (37) Braden Smith, G, Auburn, 88.1</span></p>
<p><span style="font-weight: 400;">2 (52) Kemoko Turay, Edge, Rutgers, 78.4 </span></p>
<p><span style="font-weight: 400;">2 (64) Tyquan Lewis, Edge, Ohio State, 80.3</span></p>
<p><span style="font-weight: 400;">4 (104) Nyheim Hines, RB, NC State, 89.6</span></p>
<p><span style="font-weight: 400;">5 (159) Daurice Fountain, WR, Northern Iowa, n/a</span></p>
<p><span style="font-weight: 400;">5 (169) Jordan Wilkins, RB, Ole Miss, 85.6</span></p>
<p><span style="font-weight: 400;">6 (185) Deon Cain, WR, Clemson, 78.2</span></p>
<p><span style="font-weight: 400;">7 (221) Matthew Adams, LB, Houston, 77.5</span></p>
<p><span style="font-weight: 400;">7 (235) Zaire Franklin, LB, Syracuse, 83.0</span></p>
<p><strong>Day 1</strong>: There’s not much to pick apart with Quenton Nelson’s game as he was the top guard on our board after posting three exceptional years of grading. He can make any block in any run scheme, whether being asked to play with power at the point of attack, tracking linebackers at the second level, or making blocks on the move as a puller. Nelson was the nation’s top-graded run-blocker last season at 96.4, and he’s continued to improve in pass protection in each of his three years at Notre Dame, finishing with only five pressures allowed in 2017.</p>
<p><strong>Day 2</strong>: The Colts kicked off a busy Day 2 with Darius Leonard, a small-school linebacker who had his ups and downs at the Senior Bowl before putting forth an outstanding effort in the game with 11 tackles and six stops. They add another guard to the mix with Braden Smith who is strong in the run game while continuing to improve as a pass protector, ranking ninth in the draft class with a pass-blocking efficiency of 98.8 last season. The Colts then went to the edge to grab Kemoko Turay who had an odd career at Rutgers, but when he was on the field, was incredibly productive. On only 548 career rushes in four years (a season’s worth for some), Turay notched an incredible 16 sacks, 24 QB hits and 70 hurries. Tyquan Lewis can move around the defensive front and he had a solid career at Ohio State, averaging 47 pressures and 20 stops over the last two years.</p>
<p><strong>Day 3</strong>: Nyheim Hines shows good patience as a runner, then hits the hole with impressive burst and lateral agility. He has the skills to become a receiving weapon at the next level after ranking 13th<sup> </sup>in the draft class with an elusive rating of 76.2. Jordan Wilkins will contend for snaps with Hines after showing well as a receiver (78.8 grade) and as a pass-blocker (85.2 grade) last season while ranking eighth in the class with an elusive rating of 78.5. Deon Cain is a potential downfield threat as he runs well and knows how to create late separation at the catch point. He caught 43.8 percent of his deep targets in 2016 while playing with Deshaun Watson, though that dropped to only 23.5 percent last season.</p>
<p><img class="alignnone wp-image-214766" src="https://media.profootballfocus.com/2017/07/JAX-Jaguars-Header.png" alt="" width="650" srcset="https://media.profootballfocus.com/2017/07/JAX-Jaguars-Header.png 650w, https://media.profootballfocus.com/2017/07/JAX-Jaguars-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /></p>
<p><span style="font-weight: 400;">1 (29) Taven Bryan, DI, Florida, 89.1</span></p>
<p><span style="font-weight: 400;">2 (61) D.J. Chark, WR, LSU, 82.8</span></p>
<p><span style="font-weight: 400;">3 (93) Ronnie Harrison, S, Alabama, 84.8</span></p>
<p><span style="font-weight: 400;">4 (129) Will Richardson, OT, NC State, 89.6</span></p>
<p><span style="font-weight: 400;">6 (203) Tanner Lee, QB, Nebraska, 73.4</span></p>
<p><span style="font-weight: 400;">7 (230) Leon Jacobs, Edge, Wisconsin, 83.9</span></p>
<p><span style="font-weight: 400;">7 (247) Logan Cooke, P, Mississippi State, n/a</span></p>
<p><strong>Day 1</strong>: The Jaguars added more pieces to their defensive front and the Taven Bryan pick has an eye toward the future. He improved every year at Florida, culminating in a breakout 2017 season that saw him grade at 89.1 overall. He’s an explosive athlete, capable of disrupting on the interior of the defensive line, though his best early-down fit may be outside at defensive end as he can get swallowed up by bigger guards in the run game. Bryan may not have to contribute right away on Jacksonville’s loaded defensive line, but he adds immediate depth and if his college progression continues, he should be one of the best interior disruptors in the draft class.</p>
<p><strong>Day 2</strong>: D.J. Chark adds an immediate deep threat to the Jaguars’ offense as he ran a 4.34 40 at the NFL Combine and that speed shows up on the field. He ranked sixth in the nation with 572 yards on deep passes and those plays made up 66 percent of his total receiving yards. Ronnie Harrison has an excellent feel for the game, whether playing zone or timing up blitzes and his run-stop percentage of 6.7 when lined up in the box ranked 10th<sup> </sup>in the draft class. That skillset fits well with what the Jaguars want in their strong safeties, and Harrison also has the skills to match up with tight ends in man coverage.</p>
<p><strong>Day 3</strong>: Will Richardson has off-field concerns, but he was outstanding in 2017, grading at 89.5 overall, good for fourth-best in the nation among tackles. The tight splits in NC State’s offense aided him in pass protection, but nonetheless, allowing only five pressures on 400 attempts is impressive. Tanner Lee is a developmental quarterback with a good arm, though he graded at only 73.4 last season while ranking 36th<sup> </sup>out of 37 qualifiers at avoiding turnover-worthy throws. Leon Jacobs is an excellent athlete who broke out as a pass-rusher in 2017, notching four sacks, 10 QB hits and 20 hurries on only 234 rushes. He may be more of a traditional linebacker at the next level.</p>
<p><img class="alignnone wp-image-214764" src="https://media.profootballfocus.com/2017/07/HST-Texans-Header.png" alt="" width="650" srcset="https://media.profootballfocus.com/2017/07/HST-Texans-Header.png 650w, https://media.profootballfocus.com/2017/07/HST-Texans-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /></p>
<p><span style="font-weight: 400;">3 (68) Justin Reid, S, Stanford, 80.4</span></p>
<p><span style="font-weight: 400;">3 (80) Martinas Rankin, G/C, Mississippi State, 77.1</span></p>
<p><span style="font-weight: 400;">3 (98) Jordan Akins, TE, UCF, 83.5</span></p>
<p><span style="font-weight: 400;">6 (177) Duke Ejiofor, Edge, Wake Forest, 85.7</span></p>
<p><span style="font-weight: 400;">6 (211) Jordan Thomas, TE, Mississippi State, 51.1</span></p>
<p><span style="font-weight: 400;">6 (214) Peter Kalambayi, Edge, Stanford, 76.6</span></p>
<p><span style="font-weight: 400;">7 (222) Jermaine Kelly, CB, San Jose State, 79.3</span></p>
<p><strong>Day 1</strong>: n/a</p>
<p><strong>Day</strong> <strong>2</strong>: Houston finally got to play draft, starting in the third round, and they got good value in Justin Reid who was getting some first-round love leading up to the draft. He’s an athletic safety who struggled at times in a challenging role covering slot receivers at Stanford, but when used in more of a traditional safety role, he closed quickly on underneath routes and showed off his ball skills down the field. He picked off four passes and deflected 14 on 137 targets over the last three years. Martinas Rankins improved from a 47.7 overall grade in 2016 to 71.2 last season, but there’s still more work to do after he ranked 79th<sup> </sup>in the draft class with a pass-blocking efficiency of 94.0 in 2017. Jordan Akins is a smooth route runner who ranked third in the draft class with 1.93 yards per route, but he must cut down on the drops after letting 10 out of 93 catchable targets hit the ground in his career.</p>
<p><strong>Day 3</strong>: Keke Coutee adds another playmaker to the mix as he can be a weapon on gadget plays, but also from the slot where his speed makes him a vertical slot threat. He ranked eighth in the nation with 542 yards on deep passes despite ranking 114th<sup> </sup>with only 18 deep targets. Duke Ejiofor is a solid player who produced three straight years of grading in between 82.0 and 85.7 overall. He knows how to win with his hands and a multiple moves as a pass-rusher, and he could move around the defensive front to create mismatches. Peter Kalambayi best overall grade came in 2015 (77.2) and his 82.4 grade against the run last season was a career-high.</p>
<p><img class="alignnone wp-image-214783" src="https://media.profootballfocus.com/2017/07/TEN-Titans-Header.png" alt="" width="650" srcset="https://media.profootballfocus.com/2017/07/TEN-Titans-Header.png 650w, https://media.profootballfocus.com/2017/07/TEN-Titans-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /></p>
<p><span style="font-weight: 400;">1 (22) Rashaan Evans, LB, Alabama, 85.6</span></p>
<p><span style="font-weight: 400;">2 (41) Harold Landry, Edge, Boston College, 83.9 </span></p>
<p><span style="font-weight: 400;">5 (152) Dane Cruikshank, DB, Arizona, 81.9</span></p>
<p><span style="font-weight: 400;">6 (199) Luke Falk, QB, Washington State, 78.1</span></p>
<p><strong>Day 1</strong>: Tennessee moved up to snag Rashaan Evans who fills a need in the middle of the field. After starting his career at Alabama as an explosive and productive edge rusher, Evans played more of a traditional linebacker role the last two seasons where he put the pass-rushing to good use as a blitzer while showing well in the run game. The question mark for Evans is in coverage where his season-best grade came last year at 76.6, but he can become a movable chess piece in passing situations where his pass-rushing prowess will be a nightmare if matched up on opposing running backs.</p>
<p><strong>Day 2</strong>: The Titans moved up to make one of the best value picks in the draft, perhaps securing the best pass-rusher off the edge in Harold Landry. His 2017 season was disappointing as his production dipped and he battled injury, but <a href="https://www.profootballfocus.com/news/draft-harold-landrys-combine-performance-puts-him-in-rarified-air/">he was outstanding in 2016</a>, posting an 89.0 pass-rush grade, the best single-season mark from anyPower-5 edge defender in this class. Landry also fits the mold with regard to athleticism, burst, and bend off the edge.</p>
<p><strong>Day 3</strong>: Dane Cruikshank is a good athlete who ranked second in the draft class with a run-stop percentage of 6.2 last season. Luke Falk has solid backup potential as he doesn’t have a great arm, but he’s capable of throwing with accuracy and touch in the short and intermediate game. He’s coming off the worst season of his career as he ranked 33rd<sup> </sup>in the draft class in big-time throw percentage and 27th<sup> </sup>at avoiding turnover-worthy plays.</p>
<p><img class="alignnone wp-image-214761" src="https://media.profootballfocus.com/2017/07/DEN-Broncos-Header.png" alt="" width="650" srcset="https://media.profootballfocus.com/2017/07/DEN-Broncos-Header.png 650w, https://media.profootballfocus.com/2017/07/DEN-Broncos-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /></p>
<p><img class="alignnone wp-image-247892" src="https://media.profootballfocus.com/2018/04/IMG_28042018_161420_0.png" alt="" width="800" srcset="https://media.profootballfocus.com/2018/04/IMG_28042018_161420_0.png 800w, https://media.profootballfocus.com/2018/04/IMG_28042018_161420_0-300x169.png 300w, https://media.profootballfocus.com/2018/04/IMG_28042018_161420_0-768x432.png 768w" sizes="(max-width: 706px) 89vw, (max-width: 767px) 82vw, 740px" /></p>
<p><span style="font-weight: 400;">1 (5) Bradley Chubb, edge defender, NC State, 89.4</span></p>
<p><span style="font-weight: 400;">2 (40) Courtland Sutton, WR, SMU, 84.6</span></p>
<p><span style="font-weight: 400;">3 (71) Royce Freeman, RB, Oregon, 86.3</span></p>
<p><span style="font-weight: 400;">3 (99) Isaac Yiadom, CB, Boston College, 83.6 </span></p>
<p><span style="font-weight: 400;">4 (106) Josey Jewell, LB, Iowa, 86.8</span></p>
<p><span style="font-weight: 400;">4 (113) DaeSean Hamilton, WR, Penn State, 85.2</span></p>
<p><span style="font-weight: 400;">5 (156) Troy Fumagalli, TE, Wisconsin, 83.9</span></p>
<p><span style="font-weight: 400;">6 (183) Sam Jones, G, Arizona State, 81.3</span></p>
<p><span style="font-weight: 400;">6 (217) Keishawn Bierria, LB, Washington, 78.2</span></p>
<p><span style="font-weight: 400;">7 (226) David Williams, RB, Arkansas, 81.6</span></p>
<p><strong>Day 1</strong>: Bradley Chubb is one of the draft’s best all-around players and he’ll continue to the pipeline of productive edge rushers in Denver. He’s outstanding in the run game, playing with good leverage and technique and as a pass-rusher, he attacks offensive tackles with a full array of moves. The question for Chubb is whether or not he’ll every become an elite pass-rusher as his peak college pass-rush grade of <a href="https://www.profootballfocus.com/news/draft-college-prospects-whose-pass-rushing-should-translate-to-the-nfl/">86.4 from last season is more indicative</a> of a mid-tier rusher at the next level. However, his size and burst could be utilized on the interior in nickel situations, and if he can exploit guards as a pass-rusher, it makes the Broncos’ defensive front all the more dangerous.</p>
<p><strong>Day 2</strong>: Denver adds another big playmaker to their receiving corps with Courtland Sutton who has a massive frame, but also impressive quickness as evidenced by his 6.57 3-cone drill. He can make defenders miss after the catch, forcing 26 missed tackles on only 143 catches over the last two years, and he ranked 13th<sup> </sup>in the nation with 574 yards on deep passes in 2016. Sutton’s strengths and weaknesses compare favorably to current Broncos receiver Demaryius Thomas. Royce Freeman had an up-and-down career at Oregon, posting an excellent 92.4 overall grade back in 2015, before struggling in 2016 (77.1 grade) and bouncing back in 2017 (86.3 grade). He ranked 14th<sup> </sup>in elusive rating last season at 76.1 and he has the balance and vision to be an efficient next-level runner. Isaac Yiadom brings good size to the cornerback position, and he capped his career with two solid years, grading at 83.9 in 2016 and 83.6 last season.</p>
<p><strong>Day 3</strong>: Josey Jewell had a fantastic career at Iowa, grading between 85.9 and 87.9 in each of the last three seasons. He finished his career with 15 pass breakups and six interceptions while not allowing a touchdown as the primary defender in coverage. DaeSean Hamilton could see the field early as he’s a polished route runner and adept at varying the speed of his routes to set up defenders. He gained 845 yards from the slot last season, eighth-most among FBS wide receivers. Troy Fumagalli ranked fourth among draft-eligible tight ends with 1.87 yards per route and he’s one of the better blockers in the draft class as he has experience blocking in-line and he can at least get in the way of bigger, more athletic defensive ends. Sam Jones’ best overall grade came in 2016 (84.9) and he ranked 36th<sup> </sup>among draft-class guards with a pass-blocking efficiency of 97.9 last season.</p>
<p><img class="alignnone wp-image-214768" src="https://media.profootballfocus.com/2017/07/LAC-Chargers-Header.png" alt="" width="650" srcset="https://media.profootballfocus.com/2017/07/LAC-Chargers-Header.png 650w, https://media.profootballfocus.com/2017/07/LAC-Chargers-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /></p>
<p><span style="font-weight: 400;">1 (17) Derwin James, S, Florida State, 92.1</span></p>
<p><span style="font-weight: 400;">2 (48) Uchenna Nwosu, Edge, USC, 86.9</span></p>
<p><span style="font-weight: 400;">3 (84) Justin Jones, DI, NC State, 76.9</span></p>
<p><span style="font-weight: 400;">4 (119) Kyzir White, S, West Virginia, 86.4</span></p>
<p><span style="font-weight: 400;">5 (155) Scott Quessenberry, C, UCLA, 85.5</span></p>
<p><span style="font-weight: 400;">6 (191) Dylan Cantrell, WR, Texas Tech, 80.1</span></p>
<p><span style="font-weight: 400;">7 (251) Justin Jackson, RB, Northwestern, 56.1</span></p>
<p><strong>Day 1</strong>: The Chargers made one of our<a href="https://www.profootballfocus.com/news/pro-best-picks-from-the-2018-nfl-draft-round-1/"> favorite Day 1 picks</a> as Derwin James should step right into their strong safety role and excel. While James as the versatility to play multiple roles on defense, and the Chargers should tap into that skillset, he can still have an impact as a traditional strong safety given his ability to attack downhill in the run game and cover with great range at the underneath level. James has the size and movement skills to match up with tight ends or slot receivers in the passing game, and if the Chargers want to get creative with him as a blitzer, pass-rushing may be the best part of his game (a rarity for a safety. James posted the highest safety grades in the nation in his two healthy seasons, 2015 and 2017.</p>
<p><strong>Day 2</strong>: Uchenna Nwosu should bring versatility to the Chargers’ defense after playing mostly on the edge at USC. He moves extremely well, posted an 85.1 pass-rush grade last season that included a nation-high 10 batted passes, and he has 317 career snaps dropping into coverage. He provides pass rush depth with the ability to move around the defensive front to create mismatches in subpackages. Justin Jones did his best work in 2016, grading at 84.1 overall, but his 4.1 pass-rush productivity (99th<sup> </sup>in the draft class) and a 77.9 grade against the run in 2017 is a concern.</p>
<p><strong>Day 3</strong>: Kyzir White showed excellent ball skills when playing underneath zones and he’s posted two strong grades against the run, 83.8 in 2016 and 86.9 in 2017, while playing in the slot in West Virginia’s hybrid safety role. Scott Quessenberry has played both guard and center with his best season being 2017 as he graded at 85.5 overall. Dylan Cantrell is a good athlete with some nuance to his route-running and he could become a sure-handed possession receiver after dropping only nine out of 158 catchable passes in his career. Justin Jackson had his best season in 2014, grading at 87.4, though he did rank seventh in the draft class with an elusive rating of 79.0 last season despite a 63.9 overall grade.</p>
<p><img class="alignnone wp-image-214767" src="https://media.profootballfocus.com/2017/07/KC-Chiefs-Header.png" alt="" width="650" srcset="https://media.profootballfocus.com/2017/07/KC-Chiefs-Header.png 650w, https://media.profootballfocus.com/2017/07/KC-Chiefs-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /></p>
<p><span style="font-weight: 400;">2 (46) Breeland Speaks, Edge, Ole Miss, 82.4</span></p>
<p><span style="font-weight: 400;">3 (75) Derrick Nnadi, DI, Florida State, 85.5</span></p>
<p><span style="font-weight: 400;">3 (100) Dorian O’Daniel, LB, Clemson, 87.8</span></p>
<p><span style="font-weight: 400;">4 (124) Armani Watts, S, Texas A&amp;M, 82.8</span></p>
<p><span style="font-weight: 400;">6 (196) Tremon Smith, CB, Central Arkansas, n/a</span></p>
<p><span style="font-weight: 400;">6 (198) Khalil McKenzie, DI, Tennessee, 78.8</span></p>
<p><strong>Day 1</strong>: n/a</p>
<p><strong>Day 2</strong>: Breeland Speaks had a solid 2017 season, grading at 83.7 against the run but only 76.1 as a pass-rusher. Derrick Nnadi adds another run-stopping presence after posting three straight grades in the 80.0&#8217;s, including an 86.7 mark against the run last season. He provides little as a pass-rusher, ranking 84th<sup> </sup>in pass-rush productivity last season at 5.1. Dorian O’Daniel is an athletic, coverage linebacker coming off a strong 2017 season, grading at 87.8 overall. He can step right in as a nickel linebacker, while also adding extra value after playing 198 special teams snaps in all phases last year and finishing with 39 career special teams tackles.</p>
<p><strong>Day 3</strong>: Armani Watts has some versatility to his game as he can cover the slot (allowed a passer rating of only 54.3 in the slot in 2016) and he showed good ball skills at safety, picking off 10 passes and deflecting nine on 144 career targets.</p>
<p><img class="alignnone wp-image-214777" src="https://media.profootballfocus.com/2017/07/OAK-Raiders-Header.png" alt="" width="650" srcset="https://media.profootballfocus.com/2017/07/OAK-Raiders-Header.png 650w, https://media.profootballfocus.com/2017/07/OAK-Raiders-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /></p>
<p><span style="font-weight: 400;">1 (15) Kolton Miller, OT, UCLA, 87.4</span></p>
<p><span style="font-weight: 400;">2 (57) P.J. Hall, DI, Sam Houston State, n/a</span></p>
<p><span style="font-weight: 400;">3 (65) Brandon Parker, OT, North Carolina A&amp;T, n/a</span></p>
<p><span style="font-weight: 400;">3 (87) Arden Key, Edge, LSU, 81.6</span></p>
<p><span style="font-weight: 400;">4 (110) Nick Nelson, CB, Wisconsin, 89.1</span></p>
<p><span style="font-weight: 400;">5 (140) Maurice Hurst, DI, Michigan, 96.8</span></p>
<p><span style="font-weight: 400;">5 (173) Johnny Townsend, P, Florida, n/a</span></p>
<p><span style="font-weight: 400;">6 (216) Azeem Victor, LB, Washington, 73.8</span></p>
<p><span style="font-weight: 400;">7 (228) Marcell Ateman, WR, Oklahoma State, 87.9</span></p>
<p><strong>Day 1</strong>: The Raiders moved back and secured the draft’s most athletic tackle in Kolton Miller who excels on the front side of outside zone runs. However, Miller has had an uneven career at UCLA, showing well as a freshman with a 79.9 overall grade before declining to 62.9 in 2016, before finishing strong at 87.2 last season. Even last season, Miller had too many quick losses, both in pass protection and in the run game, and he must do a better job with his hands in order to succeed at the next level. He allowed 56 pressures on 1,108 snaps in pass protection in his career.</p>
<p><strong>Day 2</strong>: Oakland kicked off Day 2 with small school defensive tackle P.J. Hall who is an athletic freak, but extremely raw on the field. He ran an impressive 4.73 40 to go with a 1.70 10-yard split at his pro day. They went the small school route once again with Brandon Parker who is another size/length/athleticism project. He struggled during Senior Bowl week, both in one-on-ones and in the game where he allowed five pressures on 36 pass-blocking attempts.Arden  Key looked like a first-round talent after two impressive seasons at LSU in 2015 and 2016, but off-field question marks and a lack of bulk dropped him to the third round. He has the length and burst to win off the edge and his 88.0 pass-rush grade in 2016 is among the best single-season marks in the class, though a drop to only 78.2 last season is a concern.</p>
<p><strong>Day 3</strong>: Nick Nelson had a breakout 2017 season, ranking fifth in the nation with an 89.1 overall grade. He did not intercept a pass in his three years of action, but he broke up 29 passes and last year allowed a completion percentage of only 37.7 into his coverage. Maurice Hurst is the potential prize of Day 3 as he was the No. 3 player on the PFF draft board, but heart concerns kept him off the board for a number of teams. When on the field, <a href="https://www.profootballfocus.com/news/draft-maurice-hursts-pff-grading-suggests-hes-a-special-nfl-prospect/">Hurst is a classic interior disruptor</a> in both the run game and as a pass-rusher, and his 96.3 overall grade is the best we’ve seen from an interior defensive lineman in our four years of grading. Marcell Ateman could make a nice possession receiver, as he uses his body well on slants and back-shoulder throws and he did a fine job against press coverage last season, catching 15-of-20 targets for 250 yards, three touchdowns and the second-best passer rating in the nation at 156.3.</p>
<p><img class="alignnone wp-image-214760" src="https://media.profootballfocus.com/2017/07/DAL-Cowboys-Header.png" alt="" width="650" srcset="https://media.profootballfocus.com/2017/07/DAL-Cowboys-Header.png 650w, https://media.profootballfocus.com/2017/07/DAL-Cowboys-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /></p>
<p><span style="font-weight: 400;">1 (19) Leighton Vander Esch, LB, Boise State, 89.8</span></p>
<p><span style="font-weight: 400;">2 (50) Connor Williams, T/G, Texas, 85.7</span></p>
<p><span style="font-weight: 400;">3 (81) Michael Gallup, WR, Colorado State, 92.1</span></p>
<p><span style="font-weight: 400;">4 (116) Dorance Armstrong Jr., Edge, Kansas, 78.5</span></p>
<p><span style="font-weight: 400;">4 (137) Dalton Schultz, TE, Stanford, 82.1</span></p>
<p><span style="font-weight: 400;">5 (171) Mike White, QB, WKU, 84.2</span></p>
<p><span style="font-weight: 400;">6 (193) Chris Covington, LB, Indiana, 85.5</span></p>
<p><span style="font-weight: 400;">6 (208) Cedrick Wilson, WR, Boise State, 89.2</span></p>
<p><span style="font-weight: 400;">7 (236) Bo Scarbrough, RB, Alabama, 75.6</span></p>
<p><strong>Day 1</strong>: Dallas made some interesting picks in the draft, and none more than their top pick of Boise State LB Leighton Vander Esch. Despite being older than the other top linebackers in this class, Vander Esch is actually younger than all of them in terms of playing time experience, with just one season of significant playing time in college. That season though was spectacular, seeing him lead the nation with 76 defensive stops and showing the kind of flow to the football that teams love. His potential remains high because of that lack of experience, and if he can develop his coverage skills to match his run defense he could quickly become one of the game’s best linebackers.</p>
<p><strong>Day 2</strong>: When the Cowboys were at their best, they had the league’s most dominant offensive line, and they’re trying to get back there with the offseason hire of offensive line coach Paul Alexander and now selecting Connor Williams in the second round. Williams was the No. 2 tackle on our draft board and allowed just one sack across three seasons of play for Texas. He has shown excellent pass-blocking and run-blocking skills and looked to have the ability to stay outside at tackle but was seen as a candidate to move in to guard by many. Dallas could use an upgrade at either right tackle or left guard, and they will need to decide how they are going to deploy Williams and La’el Collins to best improve those two positions.</p>
<p>The Cowboys also added a PFF favorite, Michael Gallup, the highest-graded wide receiver in the nation in 2017 and one of the most productive players in college football. Gallup faced press coverage on 64 of his targets in 2017, catching 30 of those passes for 568 yards, and showed well at the Senior Bowl against improved competition.</p>
<p><strong>Day 3</strong>: Dallas grabbed QB Mike White in the fifth round to back up Dak Prescott. He posted the sixth-highest grade in the draft class on deep throws. Cedrick Wilson adds nice receiver depth to this group and at 6-foot-3, he gained 4.6 yards per route against Power-5 competition in 2017, leading the FBS. With their last pick, they grabbed Alabama RB Bo Scarbrough, who never quite lived up to his huge frame, breaking 62 tackles on 267 college carries.</p>
<p><img class="alignnone wp-image-214778" src="https://media.profootballfocus.com/2017/07/PHI-Eagles-Header.png" alt="" width="650" srcset="https://media.profootballfocus.com/2017/07/PHI-Eagles-Header.png 650w, https://media.profootballfocus.com/2017/07/PHI-Eagles-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /></p>
<p><span style="font-weight: 400;">2 (49) Dallas Goedert, TE, South Dakota State, 96.8</span></p>
<p><span style="font-weight: 400;">4 (125) Avonte Maddox, CB, Pittsburgh, 85.2</span></p>
<p><span style="font-weight: 400;">4 (130) Josh Sweat, Edge, Florida State, 82.7</span></p>
<p><span style="font-weight: 400;">6 (206) Matt Pryor, OT, TCU, 84.9</span></p>
<p><span style="font-weight: 400;">7 (233) Jordan Mailata, OT, South Sydney, Australia, n/a</span></p>
<p><strong>Day 1</strong>: n/a</p>
<p><strong>Day 2</strong>: With one pick in the first two days of the draft, it’s just as well the Eagles roster is in good shape, and they showed that by making something of a luxury pick with the selection of TE Dallas Goedert out of South Dakota State. Goedert has reminded many in the pre-draft process of Zach Ertz, so it’s interesting to see the two players on the same roster. Against admittedly questionable competition, Goedert was on another level of dominance, averaging 8.1 yards per catch after the reception and breaking a dozen tackles along the way. Goedert’s run-blocking grade was solid, but this was against FCS competition and it will be unlikely to be a major strength at the next level.</p>
<p><strong>Day 3</strong>: Josh Sweat is an edge rusher a lot of people had higher on their boards but had some injury concerns. He had 34 total pressures in 2017 and 32 defensive stops. Avonte Maddox would be a much higher pick if he wasn’t just 5-foot-9 as he had 30 pass breakups over the past four seasons. They also grabbed an Australian NRL rugby player in OT Jordan Mailata in the seventh round as a flier.</p>
<p><img class="alignnone wp-image-214775" src="https://media.profootballfocus.com/2017/07/NYG-Giants-Header.png" alt="" width="650" srcset="https://media.profootballfocus.com/2017/07/NYG-Giants-Header.png 650w, https://media.profootballfocus.com/2017/07/NYG-Giants-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /></p>
<p><img class="alignnone wp-image-247893" src="https://media.profootballfocus.com/2018/04/IMG_28042018_161311_0.png" alt="" width="800" srcset="https://media.profootballfocus.com/2018/04/IMG_28042018_161311_0.png 800w, https://media.profootballfocus.com/2018/04/IMG_28042018_161311_0-300x169.png 300w, https://media.profootballfocus.com/2018/04/IMG_28042018_161311_0-768x432.png 768w" sizes="(max-width: 706px) 89vw, (max-width: 767px) 82vw, 740px" /></p>
<p><span style="font-weight: 400;">1 (2) Saquon Barkley, RB, Penn State, 89.9</span></p>
<p><span style="font-weight: 400;">2 (34) Will Hernandez, G, UTEP, 91.4</span></p>
<p><span style="font-weight: 400;">3 (66) Lorenzo Carter, Edge, Georgia, 79.0 </span></p>
<p><span style="font-weight: 400;">3 (69) B.J. Hill, DI, NC State, 81.5</span></p>
<p><span style="font-weight: 400;">4 (108) Kyle Lauletta, QB, Richmond, 87.9</span></p>
<p><span style="font-weight: 400;">5 (139) RJ McIntosh, DI, Miami (Fla.), 87.7</span></p>
<p><strong>Day 1</strong>: Saquon Barkley is one of the most divisive and interesting picks in the first round. He is undoubtedly a huge talent, but the Giants passed up the chance to select a future franchise quarterback, or trade back for a significant haul of picks in order to select him. Barkley is dynamic in the passing game, with legitimate matchup problems for any defense in the NFL but running between the tackles is not necessarily a strength as he has a tendency to try and turn every carry into a home run hit rather than taking the necessary single when the time calls for it. Barkley had the No. 2 breakaway percentage in this draft class, with 19 runs of 15 or more yards in 2017. This will be a franchise-defining pick for the Giants for years to come and will be one of the most interesting players to watch perform at the next level.</p>
<p><strong>Day 2</strong>: With Barkley now on board, the Giants went hard at the top of the second round to give Barkley the blocking to maximize his opportunities. Will Hernandez earned the best single-season grade we have seen from a college guard in 2016 (95.2) and had the second-best pass blocking efficiency in the draft class.  With two third-round picks, the Giants also added to their defense with Lorenzo Carter on the edge and B.J. Hill in the middle. Both players flashed talent, but were inconsistent in college, so their impact will be determined by how much they can iron out the lows of their play. Carter had 36 total pressures, and eight of them came against the best O-line in the country in Notre Dame.</p>
<p><strong>Day 3</strong>: Kyle Lauletta from Richmond has a chance to validate the selection of Saquon Barkley at No. 2 overall, and the team’s decision to pass up a new franchise quarterback that high. Lauletta showed an average arm, but impressive accuracy, completing 76.9 percent of his passes at the intermediate depth. He posted the top grade among the Senior Bowl quarterbacks in the 1-on-1 drills and was the game’s MVP.</p>
<p><img class="alignnone wp-image-214784" src="https://media.profootballfocus.com/2017/07/WAS-Redskins-Header.png" alt="" width="650" srcset="https://media.profootballfocus.com/2017/07/WAS-Redskins-Header.png 650w, https://media.profootballfocus.com/2017/07/WAS-Redskins-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /></p>
<p><span style="font-weight: 400;">1 (13) Da’Ron Payne, DI, Alabama, 87.7</span></p>
<p><span style="font-weight: 400;">2 (59) Derrius Guice, RB, LSU, 85.1</span></p>
<p><span style="font-weight: 400;">3 (74) Geron Christian, OT, Louisville, 84.9</span></p>
<p><span style="font-weight: 400;">4 (109) Troy Apke, S, Penn State, 82.5</span></p>
<p><span style="font-weight: 400;">5 (163) Tim Settle, DI, Virginia Tech, 86.0</span></p>
<p><span style="font-weight: 400;">6 (197) Shaun Dion Hamilton, LB, Alabama, 82.6</span></p>
<p><span style="font-weight: 400;">7 (241) Greg Stroman, CB, Virginia Tech, 84.4</span></p>
<p><span style="font-weight: 400;">7 (256) Trey Quinn, WR, SMU, 91.1</span></p>
<p><strong>Day 1</strong>: Washington’s defensive front was in good shape in 2017 with the exception of the nose tackle position, where Ziggy Hood was still playing over 500 snaps and generating next to nothing in production to show for them. Matt Ioannidis and Jonathan Allen should set the team up well with pass-rushing interior players up front, which leaves Alabama’s Da’ron Payne to assume those nose tackle snaps and be their primary run-stuffing force up front. Like most Alabama defensive linemen, Payne’s run-stuffing credentials are unimpeachable, and his PFF grade in that regard has improved each year, as has the number of defensive stops he notched, topping out with 29 in 2017. Payne’s pass-rushing skills are more of a question mark, and this is a passing league, so how much he can impact the game on third downs will likely determine how good this pick was.</p>
<p><strong>Day 2</strong>: The Redskins halted the slide of RB Derrius Guice in this draft, snagging him in the second round with the 59th<sup> </sup>overall pick. Guice earned an overall PFF grade of 85.1 in a down year for him as he was slowed by injury, but he can be a complete back for them and broke 106 tackles on 470 career carries. They also added Geron Christian to the offensive line from Louisville. Christian has improved each year of his career but had the 46th-best pass blocking efficiency score in this draft class, surrendering 12 sacks over his three previous seasons.</p>
<p><strong>Day 3</strong>: LB Shaun Dion Hamilton from Alabama has early-round talent, but injuries saw him tumble in the draft. He had an overall PFF grade of 86.6 in 2016. In the seventh they go back to Virginia Tech to replace a departed corner (Kendall Fuller) with another in Greg Stroman. When targeted, Stroman allowed a passer rating of just 26.8 and surrendered only 12 catches all year.</p>
<p><img class="alignnone wp-image-214757" src="https://media.profootballfocus.com/2017/07/CHI-Bears-Header.png" alt="" width="650" srcset="https://media.profootballfocus.com/2017/07/CHI-Bears-Header.png 650w, https://media.profootballfocus.com/2017/07/CHI-Bears-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /></p>
<p><span style="font-weight: 400;">1 (8) Roquan Smith, LB, Georgia, 90.8</span></p>
<p><span style="font-weight: 400;">2 (39) James Daniels, C, Iowa, 89.0</span></p>
<p><span style="font-weight: 400;">2 (51) Anthony Miller, WR, Memphis, 86.8 </span></p>
<p><span style="font-weight: 400;">4 (115) Joel Iyiegbuniwe, LB, WKU, 82.5</span></p>
<p><span style="font-weight: 400;">5 (145) Bilal Nichols, DI, Delaware, n/a</span></p>
<p><span style="font-weight: 400;">6 (181) Kylie Fitts, Edge, Utah, 78.7</span></p>
<p><span style="font-weight: 400;">7 (224) Javon Wims, WR, Georgia, 81.8</span></p>
<p><strong>Day 1</strong>: Chicago selected the top linebacker on PFF’s draft board and <a href="https://www.profootballfocus.com/news/draft-roquan-smith-the-perfect-lb-for-todays-nfl">a perfect linebacker for the 2018 NFL</a> in Roquan Smith out of Georgia. Smith has special coverage skills and the potential to become one of the game’s best coverage linebackers – players that can legitimately change games and be the difference between winning and losing. Smith also has impressive sideline-to-sideline range and the ability to find the ball, with 74 defensive stops in 2017 second in the nation. Smith may not have the size and bulk of some of the other linebackers to be drafted after him, but the game doesn’t require 250-pound linebackers anymore, and his playmaking ability more than makes up for any lack of size. Smith was one of the top players on our board and a solid choice this high.</p>
<p><strong>Day 2</strong>: Chicago’s offensive line is in flux at the moment with personnel moves, so the addition of James Daniels at center from Iowa should go some way to stabilizing it. Daniels earned an overall PFF grade of 89.0 in 2017 and comes from an offense that is very pro-oriented when it comes to run concepts. His overall play strength can be questionable, but his agility is impressive and he has an outstanding feel for zone blocking. Allowed just 10 total pressures in 2017. In the third round they snagged Anthony Miller out of Memphis, to add yet another weapon to the offense for Mitchell Trubisky to throw to. Miller is a poor man’s Odell Beckham Jr. with the skills to play far bigger than his size.</p>
<p><strong>Day 3</strong>: The Bears grabbed a small school interior defensive lineman in Bilal Nichols out of Delaware and he graded well in the limited games we have for him at PFF, and had an impressive East West Shrine game, notching a sack and two hurries in that game. In the sixth round, they drafted Kylie Fitts to add pass-rush from Utah. Fitts has played just 500 snaps over the past two years, but in 2015, he had eight sacks and 41 total pressures.</p>
<p><img class="alignnone wp-image-214762" src="https://media.profootballfocus.com/2017/07/DET-Lions-Header.png" alt="" width="650" srcset="https://media.profootballfocus.com/2017/07/DET-Lions-Header.png 650w, https://media.profootballfocus.com/2017/07/DET-Lions-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /></p>
<p><span style="font-weight: 400;">1 (20) Frank Ragnow, C, Arkansas, 93.7</span></p>
<p><span style="font-weight: 400;">2 (43) Kerryon Johnson, RB, Auburn, 87.9</span></p>
<p><span style="font-weight: 400;">3 (82) Tracy Walker, S, Louisiana, 74.3</span></p>
<p><span style="font-weight: 400;">4 (114) Da’Shawn Hand, DI, Alabama, 75.1</span></p>
<p><span style="font-weight: 400;">5 (153) Tyrell Crosby, OT, Oregon, 87.3</span></p>
<p><span style="font-weight: 400;">7 (237) Nick Bawden, FB, San Diego State, 75.7</span></p>
<p><strong>Day 1</strong>: The Lions selected one of the players that <a href="https://www.profootballfocus.com/news/draft-frank-ragnow-the-forgotten-superstar-of-the-2018-nfl-draft">PFF has been championing as a potential dominant force</a> throughout the pre-draft process in Arkansas C Frank Ragnow. With a new coaching staff in the building, the Lions are making a concerted effort to get better at the line of scrimmage, and become a more powerful team, and Ragnow achieves that. He was a dominant run-blocker and did not allow a sack in pass protection throughout his entire college career. He was one of a few players that have distanced themselves as the best player we have seen at their respective positions since we have been grading college football, and those players typically translate very well to the next level. Ragnow should plug in to the middle of that offensive line and anchor it immediately, but he has shown the ability to play guard as well, starting at right guard against Alabama in 2017 and still grading very well.</p>
<p><strong>Day 2</strong>: The Lions shook up the draft board at the running back position by taking Kerryon Johnson out of Auburn over a couple of more celebrated prospects. Johnson only really has one excellent season of performance, with an overall grade of 87.8 in 2017, and he has an interesting style of running the ball, gliding to the hole and accelerating through it like Arian Foster. They also added Tracy Walker from Louisiana to the secondary. Walker is a safety who has covered the slot and has been a better run defender than he has been in coverage.</p>
<p><strong>Day 3</strong>: Tyrell Crosby’s slide was halted by the Lions who bring in a monstrous offensive lineman. At Oregon, he allowed only seven total pressures and no sacks in 2017 at left tackle, but has the size and power to move inside to guard and dominate. Completing their power-focus, they grabbed one of the few fullbacks in the draft with Nick Bawden in the seventh round. Bawden played the second-most snaps of any fullback in 2017 with 588, none of which were him carrying the ball.</p>
<p><img class="alignnone wp-image-214763" src="https://media.profootballfocus.com/2017/07/GB-Packers-Header.png" alt="" width="650" srcset="https://media.profootballfocus.com/2017/07/GB-Packers-Header.png 650w, https://media.profootballfocus.com/2017/07/GB-Packers-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /></p>
<p><span style="font-weight: 400;">1 (18) Jaire Alexander, CB, Louisville, 82.2</span></p>
<p><span style="font-weight: 400;">2 (45) Josh Jackson, CB, Iowa, 96.6</span></p>
<p><span style="font-weight: 400;">3 (88) Oren Burks, LB, Vanderbilt, 41.9</span></p>
<p><span style="font-weight: 400;">4 (133) J’Mon Moore, WR, Missouri, 75.1</span></p>
<p><span style="font-weight: 400;">5 (138) Cole Madison, OT, Washington State, 81.5</span></p>
<p><span style="font-weight: 400;">5 (172) J.K. Scott, P, Alabama, n/a</span></p>
<p><span style="font-weight: 400;">5 (174) Marquez Valdes-Scantling, WR, USF, 76.3</span></p>
<p><span style="font-weight: 400;">6 (207) Equanimeous St. Brown, WR, Notre Dame, 78.4</span></p>
<p><span style="font-weight: 400;">7 (232) James Looney, DI, California, 79.3</span></p>
<p><span style="font-weight: 400;">7 (239) Hunter Bradley, LS, Mississippi State, n/a</span></p>
<p><span style="font-weight: 400;">7 (248) Kendall Donnerson, LB, SE Missouri State, n/a</span></p>
<p><strong>Day 1</strong>: Green Bay is one team with a real case for ‘winning’ the 2018 NFL Draft. The Packers traded down in the first round to allow the Saints to jump up and select their man, and in doing so picked up a first round pick in 2019, but they then jumped back up themselves to select Jaire Alexander out of Louisville. If you even out the trades, you could make the case that the Packers drafted Alexander with the third-round pick it cost them to move up with the Seahawks. This is a team that desperately needed to improve their coverage, and Alexander is a game-changer at corner. A smaller, quick coverage man, Alexander allowed a passer rating of just 19.9 when targeted in an injury-shortened 2017 and was an even better player the season before when fully healthy. He was the No. 4 CB on PFF’s draft board, and even though players above him were still on the board when they selected him, that board is subject more to changes by scheme than at other position.</p>
<p><strong>Day 2</strong>: The Packers erased any concerns we had of getting the right player at corner by snagging the No. 1 guy on PFF’s cornerback rankings to pair with the No. 4 in Iowa’s Josh Jackson. A relatively pedestrian 40-time likely caused him to slip down some draft boards, but Jackson was a ballhawk in 2017, catching eight interceptions, breaking up 17 passes and yielding an NFL passer rating of just 31.3 when targeted. Jackson wasn’t beaten for a catch longer than 30 yards all season and allowed just 43.8 percent of passes thrown his way to be caught. The Packers kept working on their coverage in the third round with the selection of Oren Burks at linebacker. Burks has played everything from deep safety, to edge rusher, to off-ball linebacker, resulting in an average career from a grading standpoint, but his athleticism and versatility could make him more valuable at the next level.</p>
<p><strong>Day 3</strong>: Green Bay snagged a Jordy Nelson replacement in Notre Dame’s Equanimeous St. Brown in the sixth round. St. Brown is a big receiver but moves well for that size and dropped just six passes in his college career. Cole Madison was a right tackle at Washington State, allowing just 22 total pressures across 827 pass-blocking snaps in 2017. He was projected as a guard by some, and should help Green Bay’s line regardless of which spot he plays.</p>
<p><img class="alignnone wp-image-214772" src="https://media.profootballfocus.com/2017/07/MIN-Vikings-Header.png" alt="" width="650" srcset="https://media.profootballfocus.com/2017/07/MIN-Vikings-Header.png 650w, https://media.profootballfocus.com/2017/07/MIN-Vikings-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /></p>
<p><span style="font-weight: 400;">1 (30) Mike Hughes, CB, UCF, 88.6</span></p>
<p><span style="font-weight: 400;">2 (62) Brian O’Neill, OT, Pittsburgh, 83.5</span></p>
<p><span style="font-weight: 400;">5 (157) Tyler Conklin, TE, Central Michigan, 77.0</span></p>
<p><span style="font-weight: 400;">5 (167) Daniel Carlson, K, Auburn, n/a</span></p>
<p><span style="font-weight: 400;">6 (213) Colby Gossett, G, App. State, 81.5</span></p>
<p><span style="font-weight: 400;">6 (218) Ade Aruna, DI, Tulane, 49.4</span></p>
<p><span style="font-weight: 400;">7 (225) Devante Downs, LB, California, 81.6</span></p>
<p><strong>Day 1</strong>: The Minnesota Vikings added to their secondary with UCF cornerback Mike Hughes. There were few more talented corners in this draft than Hughes, who allowed a passer rating of just 40.7 over his college career when targeted. He surrendered just one touchdown an wasn’t beaten for a pass longer than 21 yards in his entire 2017 season. Hughes also adds value as a return man, though that becomes less and less relevant as the league edges ever closer to eliminating the kick off entirely. Hughes does have some off-field character concerns, but his play on the field is well worth a first-round pick and attacks a clear area of need for the Vikings who are trying to find players to complement Harrison Smith at safety and Xavier Rhodes at corner.</p>
<p><strong>Day 2</strong>: The Vikings traded out of the third round late in the day, so their only Day 2 pick was spent on Brian O’Neill, an offensive tackle out of Pittsburgh. The team will be hoping that they fare better with this Pitt tackle than they did with T.J. Clemmings, and O’Neill allowed just nine total pressures in 2017 for the eighth-best pass blocking efficiency score in the draft class. The Vikings offensive line is still a work in progress and could definitely use an upgrade at tackle, allowing them to move Mike Remmers inside to guard on a permanent basis. O’Neill will likely have every opportunity to prove he can continue his pass blocking at the next level.</p>
<p><strong>Day 3</strong>: The Vikings went back to the offensive line in Round 6 with G Colby Gossett, a player who had four-straight years of impressive PFF grading. He played 3,162 career snaps in college and allowed just 36 total pressures over four years. They traded up in the fifth round to grab a kicker in Auburn’s Daniel Carlson, who was the second-highest graded kicker in the nation last season at PFF.</p>
<p><img class="alignnone wp-image-214782" src="https://media.profootballfocus.com/2017/07/TB-Buccaneers-Header.png" alt="" width="650" srcset="https://media.profootballfocus.com/2017/07/TB-Buccaneers-Header.png 650w, https://media.profootballfocus.com/2017/07/TB-Buccaneers-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /></p>
<p><img class="alignnone wp-image-247890" src="https://media.profootballfocus.com/2018/04/IMG_28042018_161548_0.png" alt="" width="800" srcset="https://media.profootballfocus.com/2018/04/IMG_28042018_161548_0.png 800w, https://media.profootballfocus.com/2018/04/IMG_28042018_161548_0-300x169.png 300w, https://media.profootballfocus.com/2018/04/IMG_28042018_161548_0-768x432.png 768w" sizes="(max-width: 706px) 89vw, (max-width: 767px) 82vw, 740px" /></p>
<p><span style="font-weight: 400;">1 (12) Vita Vea, DI, Washington, 93.2</span></p>
<p><span style="font-weight: 400;">2 (38) Ronald Jones II, RB, USC, 92.4</span></p>
<p><span style="font-weight: 400;">2 (53) M.J. Stewart, CB, UNC, 87.9</span></p>
<p><span style="font-weight: 400;">2 (63) Carlton Davis, CB, Auburn, 82.0</span></p>
<p><span style="font-weight: 400;">3 (940 Alex Cappa, OT, Humboldt State, n/a</span></p>
<p><span style="font-weight: 400;">4 (117) Jordan Whitehead, S, Pittsburgh, 64.9</span></p>
<p><span style="font-weight: 400;">5 (144) Justin Watson, WR, Penn, n/a</span></p>
<p><span style="font-weight: 400;">6 (202) Jack Cichy, LB, Wisconsin, 89.0* (in 2016)</span></p>
<p><strong>Day 1</strong>: The Bucs have been targeting defense in their draft, and in the first round they did so in a big way – literally. Washington defensive tackle Vita Vea completes the offseason transformation of their defensive line and gives them another player that will attempt to occupy that nose tackle spot next to Gerald McCoy and succeed. Vea has been a dominant run defender in college, but the question will be how much of a factor in the passing game can he be at the next level, with this being a league where passing is paramount. Vea has generated pressure at the college level, with eight sacks, 15 hits and 26 hurries in 2017 alone, but he wins with power and the bull rush rather than a variety of moves and may struggle to replicate that as successfully at the next level.</p>
<p><strong>Day 2</strong>: Tampa had a busy Day 2 with three selections in the second round and one in the third. That second round haul netted them a new running back in USC’s Ronald Jones II, and two new defensive backs in the shape of M.J. Stewart out of UNC and Carlton Davis from Auburn. Jones earned the highest PFF grade of any back in this class in ANY season of their college careers this past season but has just 40 career targets in the passing game, so is something of an unknown in that area. Stewart and Davis should be big additions to the secondary, with Stewart having extensive experience in the slot and a game that is reminiscent of Micah Hyde – a player that can match up with problem players on offense and neutralize a personnel advantage. In the third round, they grabbed Alex Cappa, an offensive tackle out of Humboldt State. Cappa was at the Senior Bowl and held his own in the 1-on-1 drills, even if he struggled in team drills, surrendering a sack and five hurries on 65 snaps.</p>
<p><strong>Day 3</strong>: Injuries kept Jack Cichy off the field entirely in 2017, but he had a PFF grade of 89.0 the year before and dominated against Ohio State specifically. Safety Jordan Whitehead from Pitt has seen his grade go in the wrong direction over his college career, but his 2015 season was excellent, and showed the potential he could have, with 29 defensive stops over 761 snaps.</p>
<p><img class="alignnone wp-image-214753" src="https://media.profootballfocus.com/2017/07/ATL-Falcons-Header.png" alt="" width="650" srcset="https://media.profootballfocus.com/2017/07/ATL-Falcons-Header.png 650w, https://media.profootballfocus.com/2017/07/ATL-Falcons-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /></p>
<p><span style="font-weight: 400;">1 (26) Calvin Ridley, WR, Alabama, 82.4</span></p>
<p><span style="font-weight: 400;">2 (58) Isaiah Oliver, CB, Colorado, 85.3</span></p>
<p><span style="font-weight: 400;">3 (90) Deadrin Senat, DI, USF, 85.0</span></p>
<p><span style="font-weight: 400;">4 (126) Ito Smith, RB, Southern Miss, 83.2</span></p>
<p><span style="font-weight: 400;">6 (194) Russell Gage, WR, LSU, 73.3</span></p>
<p><span style="font-weight: 400;">6 (200) Foye Oluokun, LB, Yale, n/a</span></p>
<p><strong>Day 1</strong>: This was a draft without a clear-cut superstar at wide receiver. There were a number of players each of whom had strengths and weaknesses. There is no Julio Jones in this draft, but as luck would have it, the Falcons already have a Julio Jones, so adding a complementary piece was all they were looking for. In Calvin Ridley, they secured the <a href="https://www.profootballfocus.com/news/draft-calvin-ridley-can-simply-get-open">best route runner in this class</a>, and a receiver whose strength is simply getting open, which is a skill that will inevitably translate to the next level. Ridley does have weaknesses, but those skills as a route runner make him the perfect complement to Jones and the rest of that Falcons passing attack. Ridley’s play strength is something of a concern, but he has experience in the slot, and his floor as a prospect should be what the Eagles were able to achieve with Nelson Agholor last season by moving him to the slot where he was able to avoid the physical press coverage that troubled him so much on the outside.</p>
<p><strong>Day 2</strong>: Colorado’s Isaiah Oliver represents a corner that fits far better in some schemes than others, and the Falcons are one of the teams where he is a perfect fit. From their perspective, they may well have secured a player they had a first-round grade on in the second, with the 58th<sup> </sup>overall selection. Oliver is a tall, long corner with the ability to eliminate the deep ball down his sideline. Last season on go routes, he allowed a passer rating of just 23.8, 67-points lower than the national average. He may struggle a little to change direction underneath against shifty receivers, but that’s the trade off with that type of corner. The Falcons then added Deadrin Senat in the third round – a player that gives them the chance to keep Grady Jarrett at three-technique along their defensive line by playing the Dontari Poe role as their nose tackle run stuffer. Senat had a PFF grade of 85.0 last season, with 37 defensive stops and outstanding grades against the run.</p>
<p><strong>Day 3</strong>: Ito Smith is an all-around back that excels as a receiver, with 37 broken tackles on receptions over his career and another 188 on the ground. With two sixth-round picks, the Falcons drafted a linebacker from Yale in Foye Oluokun and LSU’s WR Russell Gage. Gage saw just 48 targets over his LSU career, catching 26 of them for 347 yards while also forcing 12 missed tackles on just 27 carries for the Tigers in 2017.</p>
<p><img class="alignnone wp-image-214774" src="https://media.profootballfocus.com/2017/07/NO-Saints-Header.png" alt="" width="650" srcset="https://media.profootballfocus.com/2017/07/NO-Saints-Header.png 650w, https://media.profootballfocus.com/2017/07/NO-Saints-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /></p>
<p><span style="font-weight: 400;">1 (14) Marcus Davenport, edge, UTSA, 89.8</span></p>
<p><span style="font-weight: 400;">3 (91) Tre’Quan Smith, WR, UCF, 86.3</span></p>
<p><span style="font-weight: 400;">4 (127) Rick Leonard, OT, Florida State, 78.3</span></p>
<p><span style="font-weight: 400;">5 (164) Natrell Jamerson, S, Wisconsin, 87.3</span></p>
<p><span style="font-weight: 400;">6 (189) Kamrin Moore, S, Boston College, 85.1</span></p>
<p><span style="font-weight: 400;">6 (201) Boston Scott, RB, Louisiana Tech, 89.1</span></p>
<p><span style="font-weight: 400;">7 (245) Will Clapp, C, LSU, 86.4</span></p>
<p><strong>Day 1</strong>: The Saints made one of the most aggressive moves in the first round of the draft and did so without a quarterback in their crosshairs. They traded up with the Green Bay Packers to the No. 14 overall pick to snare edge rusher Marcus Davenport from UTSA and surrendered their first-round draft pick in 2019 to get it done. Davenport – in a weak edge rush class – has supreme talent but is a very raw prospect. In 2017, he notched nine sacks, six hits and 37 hurries as a pass rusher, and had several highlight reels plays that displayed his monstrous physical gifts. He took some time to adjust to the higher level of play at the Senior Bowl but grading of the practice reps shows a better overall performance than many of the negative reports would suggest, and he then went on to have one of the best grades of any player in the game itself, recording a sack and four hurries on 25 pass rushing snaps. Davenport is a talented player and a nice fit for the Saints, but it took a lot of draft capital to make that move happen.</p>
<p><strong>Day 2</strong>: New Orleans were left with just a third-round pick on Day 2, but they made good use of it by selecting UCF’s Tre’Quan Smith at wide receiver. Smith is outstanding deep down the field and underneath and had the second-best WR rating in the nation at 142.9 last season. On deep passes, he caught 70.8 percent of his targets this past season, the second-highest number of any receiver in the nation, bringing in 17 passes of 20 or more air-yards and scoring nine touchdowns on those plays.</p>
<p><strong>Day 3</strong>: Boston Scott was a PFF stud in 2017, averaging 3.9 yards per carry after contact and breaking 41 tackles on the ground as an undersized back. The Saints added him to their roster with a sixth-round draft selection to give them a terrifying potential backfield. Will Clapp earned some impressive grades at center for LSU, surrendering just eight total pressures in 2017 and one sack in his entire college career.</p>
<p><img class="alignnone wp-image-214756" src="https://media.profootballfocus.com/2017/07/CAR-Panthers-Header.png" alt="" width="650" srcset="https://media.profootballfocus.com/2017/07/CAR-Panthers-Header.png 650w, https://media.profootballfocus.com/2017/07/CAR-Panthers-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /></p>
<p><span style="font-weight: 400;">1 (24) D.J. Moore, WR, Maryland, 84.6</span></p>
<p><span style="font-weight: 400;">2 (55) Donte Jackson, CB, LSU, 83.6</span></p>
<p><span style="font-weight: 400;">3 (85) Rashaan Gaulden, CB, Tennessee, 84.1</span></p>
<p><span style="font-weight: 400;">4 (136) Marquise Haynes, Edge, Ole Miss, 70.2</span></p>
<p><span style="font-weight: 400;">5 (161) Jermaine Carter, LB, Maryland, 59.1</span></p>
<p><span style="font-weight: 400;">7 (234) Andre Smith, LB, NC State, 78.3</span></p>
<p><span style="font-weight: 400;">7 (242) Kendrick Norton, DI, Miami (Fla.), 77.5</span></p>
<p><strong>Day 1</strong>: Sitting at pick No. 24, the Carolina Panthers found themselves with the pick of the best wide receivers in this draft class, and a need at receiver that provided the perfect scenario. They elected to grab Maryland’s D.J. Moore, making him the top receiver selected in this draft. Moore effectively <b><i>was </i></b>the Maryland passing attack, seeing the ball come his way on 36 percent of his routes, the third-most in the draft class. He has excellent route running skills, and top end acceleration that manifests itself both in his patterns and after the catch with the ball in his hands. He forced 39 missed tackles on 146 career receptions and showed the skills to go up and get the ball in contested situations, albeit not consistently as he was able to catch just 38.5 percent of his contested targets. Moore dropped 15 passes on 161 catchable targets during his career, but that is a number that undoubtedly wasn’t aided by some questionable quarterback play in college.</p>
<p><strong>Day 2</strong>: The second day of the draft was all about the secondary for Carolina, with the addition of cornerbacks in both the second and third round. Donte Jackson out of LSU has blazing 4.3 speed and incredible athleticism. He can mirror receivers and has experience in the slot or out wide. He is undersized, but incredibly physical and feisty, but plays notably better in man coverage than he does in zone. In the third round, the team snagged Rashaan Gaulden out of Tennessee, a bigger corner who has experience playing inside in the slot. The Panthers will need to decide which player moves inside to the slot and who mans the outside, but both players have a good shot of being two of their three primary corners in 2018.</p>
<p><strong>Day 3</strong>: The Panthers selected TE Ian Thomas in the fourth round, giving them a player who averaged 9.2 yards after the catch in 2017, scoring five times from 35 targets. In the seventh, they drafted Kendrick Norton out of Miami, giving them a stout run defender up the middle who has notched 30 defensive stops over the past two seasons.</p>
<p><img class="alignnone wp-image-214781" src="https://media.profootballfocus.com/2017/07/SF-49ers-Header.png" alt="" width="650" srcset="https://media.profootballfocus.com/2017/07/SF-49ers-Header.png 650w, https://media.profootballfocus.com/2017/07/SF-49ers-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /></p>
<p><span style="font-weight: 400;">1 (9) Mike McGlinchy, OT, Notre Dame, 90.6</span></p>
<p><span style="font-weight: 400;">3 (70) Fred Warner, LB, BYU, 86.1</span></p>
<p><span style="font-weight: 400;">3 (95) Tarvarius Moore, S, Southern Miss, 88.6</span></p>
<p><span style="font-weight: 400;">4 (128) Kentavius Street, Edge, NC State, 73.7</span></p>
<p><span style="font-weight: 400;">5 (142) D.J. Reed, CB, Kansas State, 89.9</span></p>
<p><span style="font-weight: 400;">6 (184) Marcell Harris, S, Florida, 74.8* (in 2016)</span></p>
<p><span style="font-weight: 400;">7 (223) Julian Taylor, DI, Temple, 84.1</span></p>
<p><span style="font-weight: 400;">7 (240) Richie James, WR, MTSU, 70.4</span></p>
<p><strong>Day 1</strong>: While many had the 49ers targeting a specific need at the top of the draft, they pulled a bit of a surprise by selecting the top tackle on the board in Notre Dame’s Mike McGlinchey. One half of the best double team in college football, McGlinchey provides them a new starter at right tackle after the team dealt Trent Brown to the New England Patriots, and a potential future replacement for Joe Staley down the road. McGlinchey was a dominant run-blocker and while he was a good pass-blocker – surrendering 16 total pressures over his final season – there were some ugly plays on his tape as well where he can be beaten decisively and quickly in the play. His game still needs some refinement, but he was one of the best offensive linemen available in this draft and should provide a solid upgrade to the line.</p>
<p><strong>Day 2</strong>: After attacking offense with their first-round pick, the 49ers went defense on Day 2, selecting LB Fred Warner out of BYU with their second-round pick and then defensive back Tarvarius Moore out of Southern Miss in the third. Warner has graded very well at PFF for multiple seasons playing the overhang or walk-out linebacker spot in that defensive scheme that doesn’t really exist in the NFL. He has the movement skills and coverage ability that fits perfectly in today’s NFL, but he is going to need to get more acclimatized to playing inside in tighter quarters with bigger bodies in close proximity. Moore flies to the football and moves well, showing the ability to hang with receivers 1-on-1 as a safety in college, but he may project outside to cornerback at the next level and could end up playing alongside Richard Sherman on the outside.</p>
<p><strong>Day 3</strong>: D.J. Reed was an undersized corner with outstanding PFF grades, and wasn’t beaten for a catch longer than 30 yards in 2017 and he may play free safety for the 49ers given his height. They also selected Kentavius Street, despite him tearing his knee in the pre-draft process. Street is a powerhouse who will likely split time between edge and interior of the line once he’s healthy. They also snagged Temple’s Julian Taylor, who notched 28 defensive stops and graded very well against the run.</p>
<p><img class="alignnone wp-image-214752" src="https://media.profootballfocus.com/2017/07/ARZ-Cardinals-Header.png" alt="" width="650" srcset="https://media.profootballfocus.com/2017/07/ARZ-Cardinals-Header.png 650w, https://media.profootballfocus.com/2017/07/ARZ-Cardinals-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /></p>
<p><span style="font-weight: 400;">1 (10) Josh Rosen, QB, UCLA, 85.8</span></p>
<p><span style="font-weight: 400;">2 (47) Christian Kirk, WR, Texas A&amp;M, 83.9</span></p>
<p><span style="font-weight: 400;">3 (97) Mason Cole, C, Michigan, 84.6</span></p>
<p><span style="font-weight: 400;">4 (134) Chase Edmonds, RB, Fordham, n/a</span></p>
<p><span style="font-weight: 400;">6 (182) Christian Campbell, CB, Penn State, 78.1</span></p>
<p><span style="font-weight: 400;">7 (254) Korey Cunningham, OT, Cincinnati, 80.0</span></p>
<p><strong>Day 1</strong>: With the drama at the top of the draft, one of the big four quarterback prospects began to slip down the draft, and the Cardinals made a move up to the No. 10 overall spot to snag their quarterback or the future in UCLA’s Josh Rosen. With Sam Bradford and Mike Glennon already in that quarterback room, the Cardinals shouldn’t need Rosen to start right away, and that gives them an opportunity to see if they can remove <a href="https://www.profootballfocus.com/news/draft-josh-rosen-good-bad-highly-volatile">some of the volatility</a> in his game before he steps on the field. Rosen was an impressive player as a true freshman in college, earning an overall PFF grade of 84.9 that year, but the concern is that he didn’t really progress and get much better over his career, topping out at just 86.3 two seasons later. Rosen posted the highest grade of the draft class on intermediate throws, where much of the NFL passing game lies. Rosen ends up in a good situation and could provide the team with their quarterback of the future if things unfold as planned.</p>
<p><strong>Day</strong> <strong>2</strong>: The second-round pick for the Cardinals saw them secure an insurance plan for the day Larry Fitzgerald eventually hangs up his cleats. Christian Kirk was an excellent slot receiver at Texas A&amp;M, averaging 2.5 yards per route run inside, but will likely have to move around the formation with Fitzgerald the primary slot receiver in the desert. Kirk only lined up on the outside 21 times in 2017, and Fitzgerald has obviously played outside in the past, so the team may elect to move him back outside and keep Kirk in the slot. In the third round, the team snagged Michigan center Mason Cole. His PFF grades improved each year despite bouncing between center and tackle in college.</p>
<p><strong>Day 3</strong>: CB Christian Campbell was a monster at the Senior Bowl, forcing seven incompletions in 1-on-1 drills, the most of any defensive back over the week. Chase Edmunds from Fordham University was a sleeper on many people’s draft boards and he came on board with the 134th<sup> </sup>pick of the draft in the fourth round.</p>
<p><img class="alignnone wp-image-233179" src="https://media.profootballfocus.com/2017/11/LA-Rams-Header-2017.png" alt="" width="650" srcset="https://media.profootballfocus.com/2017/11/LA-Rams-Header-2017.png 650w, https://media.profootballfocus.com/2017/11/LA-Rams-Header-2017-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /></p>
<p><span style="font-weight: 400;">3 (89) Joseph Noteboom, OT, TCU, 84.0</span></p>
<p><span style="font-weight: 400;">4 (111) Brian Allen, C, Michigan State, 86.5</span></p>
<p><span style="font-weight: 400;">4 (135) John Franklin-Myers, DI, Stephen F. Austin, n/a</span></p>
<p><span style="font-weight: 400;">5 (147) Micah Kiser, LB, Virginia, 78.4</span></p>
<p><span style="font-weight: 400;">5 (160) Ogbonnia Okoronkwo, Edge, Oklahoma, 86.6</span></p>
<p><span style="font-weight: 400;">6 (176) John Kelly, RB, Tennessee, 80.9</span></p>
<p><span style="font-weight: 400;">6 (192) Jamil Demby, G, Maine, n/a</span></p>
<p><span style="font-weight: 400;">6 (195) Sebastian Joseph, DI, Rutgers, 81.1</span></p>
<p><span style="font-weight: 400;">6 (205) Trevon Young, Edge, Louisville, 82.7</span></p>
<p><span style="font-weight: 400;">7 (231) Travin Howard, LB, TCU, 83.1</span></p>
<p><span style="font-weight: 400;">7 (244) Justin Lawler, Edge, SMU, 89.5</span></p>
<p><strong>Day 1</strong>: n/a</p>
<p><strong>Day 2</strong>: With just one pick to play with over the first two days of the draft, the Rams didn’t come on the clock until the 89th<sup> </sup>pick of the draft, and they used that to select Joseph Noteboom, an offensive tackle out of TCU. With Andrew Whitworth over 35 years of age and coming off a season in which he looked mortal for the first time in a while, Noteboom makes a lot of sense as an insurance policy. Noteboom allowed just 13 total pressures in his final year at TCU, and that gave him his second strong college season of pass protection. Run-blocking has been more of a challenge for him, but that has never been less of an issue in the NFL given how much the league is pass first in 2018.</p>
<p><strong>Day 3</strong>: Ogbonnia Okoronkwo could prove to be an important player for a team in need of edge rush. He had 10 sacks and 47 total pressures in 2017. John Kelly is an intriguing smaller back that runs with power and determination, breaking 37 tackles last season. They went back to the well at edge with Trevon Young in Round 6 as Young had 40 total pressures in 2017.</p>
<p><img class="alignnone wp-image-214780" src="https://media.profootballfocus.com/2017/07/SEA-Seahawks-Header.png" alt="" width="650" srcset="https://media.profootballfocus.com/2017/07/SEA-Seahawks-Header.png 650w, https://media.profootballfocus.com/2017/07/SEA-Seahawks-Header-300x55.png 300w" sizes="(max-width: 650px) 100vw, 650px" /></p>
<p><span style="font-weight: 400;">1 (27) Rashad Penny, RB, San Diego St., 88.4</span></p>
<p><span style="font-weight: 400;">3 (79) Rasheem Green, Edge, USC, 80.1</span></p>
<p><span style="font-weight: 400;">4 (120) Will Dissly, TE, Washington, 83.5</span></p>
<p><span style="font-weight: 400;">5 (141) Shaquem Griffin, Edge, UCF, 86.7</span></p>
<p><span style="font-weight: 400;">5 (146) Tre Flowers, S, Oklahoma State, 84.0</span></p>
<p><span style="font-weight: 400;">5 (149) Michael Dickson, P, Texas n/a</span></p>
<p><span style="font-weight: 400;">5 (168) Jamarco Jones, OT, Ohio State, 85.5</span></p>
<p><span style="font-weight: 400;">6 (186) Jacob Martin, Edge, Temple, 79.5</span></p>
<p><span style="font-weight: 400;">7 (220) Alex McGough, QB, FIU, 88.3</span></p>
<p><strong>Day 1</strong>: Seattle pulled one of the surprises of the first round by selecting RB Rashaad Penny with the 27th<sup> </sup>overall pick having traded down with the Green Bay Packers. Maybe the Seahawks were simply reading PFF, who have been telling people that <a href="https://www.profootballfocus.com/news/draft-san-diego-state-rb-rashaad-penny-a-first-round-talent">Penny is a first-round talent</a> for some time. His production was outstanding, but his numbers were impressive even on a per-carry basis, not simply due to workload. He broke 86 tackles on the ground to lead the nation, had the second-best breakaway percentage with 35 runs of 15 or more yards, and led the nation in PFF’s elusive rating (128.6), a metric designed to separate the work a back does from the blocking he is dealing with. The Seahawks talked about the metrics they had seen illustrating Penny’s prowess after contact, and sure enough he averaged 4.5 yards per carry after contact and led the draft class in yards per carry after contact when hit at or behind the line of scrimmage. Penny is a capable all-around back whose only weakness is pass protection.</p>
<p><strong>Day 2</strong>: The Seahawks didn’t pick again until the third round, and they brought in defensive lineman Rasheem Green from USC. Green’s grading has never been fantastic, topping out in 2017 with a mark of just 80.1 overall, but he has shown the ability to get after the passer and his PFF pass-rush grade was up at 85.3 the same season. He had the 22nd-best pass-rush productivity score in the draft class among edge rushers, notching 46 total pressures in his final season. With the Seahawks looking to add pressure up front, Green represents an intriguing player to add to the mix.</p>
<p><strong>Day 3</strong>: The Seahawks reunite Shaquem Griffin with his brother, but more importantly bring him to a team that has experience with the Bruce Irvin deployment plan to potentially get him edge rush snaps. OT Jamarco Jones in the fifth round is also a steal, and they got the best punter prospect in the draft too in Michael Dickson.</p>


            </article>

            <div class="social">
              <span class="social-copy">What do you think? Start a conversation…</span>
              <div class="social-icons">
                <a href="http://www.twitter.com/share?url=https://www.profootballfocus.com/news/pro-all-32-nfl-teams-2018-nfl-draft-grades" class="fa fa-twitter share-icon" target="_blank"></a>
                <a href="https://www.facebook.com/sharer/sharer.php?u=https://www.profootballfocus.com/news/pro-all-32-nfl-teams-2018-nfl-draft-grades" class="fa fa-facebook share-icon"></a>
                <a href="whatsapp://send?text=https://www.profootballfocus.com/news/pro-all-32-nfl-teams-2018-nfl-draft-grades" class="fa fa-whatsapp share-icon" data-action="share/whatsapp/share"></a>
              </div>
            </div>

              <div class="pff-cta-article p-3">
                <h4>PFF Edge & <span>Elite</span></h4>
<a class="col-md-6 btn btn-secondary" href="https://www.profootballfocus.com/features-and-faq/?camp=ftrfeats">Learn More &amp; Compare</a>              </div>
          </div>
        </div>

      </div>
    </div>
  </div>
      <div id="footer" class="hidden-print">
    <div class="container">
      <div class="row">
        <div class="col footer-menu">
          <h4 class="mb-4"><a href="/newsletter?camp=emfooter">Get PFF Updates</a></h4>
          <h4>Customer Service</h4>
          <ul>
            <li>
              <a href="https://pff.desk.com/">FAQS</a>
            </li>
            <li>
              <a href="https://pff.desk.com/customer/portal/emails/new">Contact Us</a>
            </li>
          </ul>
        </div>
        <div class="col footer-menu">
          <h4>About Us</h4>
          <ul>
            <li>
              <a href="/jobs">Jobs</a>
            </li>
            <li>
              <a href="/media">Media &amp; Partnerships</a>
            </li>
            <li>
              <a href="/pff-offers">Special Offers</a>
            </li>
          </ul>
        </div>
        <div class="col footer-content">
          <div class="icons-social">
            <a href="/pff-rss" class="rss"><span class="fa fa-rss"></span></a>
            <a href="/newsletter" class="email"><span class="fa fa-envelope"></span></a>
            <a href="https://twitter.com/pff" class="twitter"><span class="fa fa-twitter"></span></a>
            <a href="https://www.facebook.com/ProFootballFocus/" class="facebook"><span class="fa fa-facebook">&nbsp;</span></a>
            <a href="/podcasts" class="podcasts"><span class="fa fa-headphones">&nbsp;</span></a>
          </div>
          <div class="container-footer-links">
            <img src="/images/webui/pff-shorthand-white.svg" class="logo">
            <div class="footer-links">
              <a href="/sitemap">Sitemap</a>
              <i class="fa fa-circle" aria-hidden="true"></i>
              <a href="/privacy">Privacy Policy</a>
              <i class="fa fa-circle" aria-hidden="true"></i>
              <a href="/terms">Terms of Use</a>
            </div>
            <span>&copy; 2017 ProFootballFocus.com All rights reserved.</span>
          </div>
        </div>
      </div>
    </div>
  </div>

    </div>
    <script src="/js/webui-a18bbfd1c2acf2d2db31fc51521e4743.js?vsn=d"></script>
  </body>
</html>
